Bug 287533 - Plasma Desktop crashed after PolicyKit1-KDE crash
Summary: Plasma Desktop crashed after PolicyKit1-KDE crash
Status: RESOLVED DUPLICATE of bug 287531
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-25 12:59 UTC by markuss
Modified: 2011-11-25 15:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markuss 2011-11-25 12:59:08 UTC
Version:           unspecified (using KDE 4.7.2) 
OS:                Linux

After PolicyKit1-KDE crashed because I wanted to remove a network connection
(see bug 287531 ), Plasma Desktop crashed as well.

Reproducible: Didn't try

Steps to Reproduce:
Network Management -> Manage Connections -> Select one -> Delete -> See PolicyKit1-KDE crash -> See Plasma Desktop crash


Expected Results:  
Not crash

Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb57df710 (LWP 1616))]

Thread 2 (Thread 0xae89eb70 (LWP 1619)):
#0  0xb5b11c96 in clock_gettime () from /lib/librt.so.1
#1  0xb6d9dc35 in do_gettime (frac=0xae89e020, sec=0xae89e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6e70206 in QTimerInfoList::updateCurrentTime (this=0x839cbcc) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb6e7056a in QTimerInfoList::timerWait (this=0x839cbcc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6e6edc3 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xae89e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6e6ee5d in timerSourcePrepare (source=0x839cb98, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5a5844c in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb5a59207 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb5a597fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6e6f897 in QEventDispatcherGlib::processEvents (this=0x84b5420, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6e4044d in QEventLoop::processEvents (this=0xae89e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6e40691 in QEventLoop::exec (this=0xae89e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6d4375b in QThread::exec (this=0x8532460) at thread/qthread.cpp:498
#14 0xb6e2108d in QInotifyFileSystemWatcherEngine::run (this=0x8532460) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6d46613 in QThreadPrivate::start (arg=0x8532460) at thread/qthread_unix.cpp:331
#16 0xb6cc9a7d in start_thread () from /lib/libpthread.so.0
#17 0xb60928fe in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb57df710 (LWP 1616)):
[KCrash Handler]
#6  Knm::Connection::uuid (this=0x0) at /usr/src/debug/networkmanagement-0.9.2.65git.1321935457/libs/internals/connection.cpp:323
#7  0xa8d04123 in ManageConnectionWidget::editGotSecrets (this=0x876b690, valid=false, errorMessage=..., uuid=...) at /usr/src/debug/networkmanagement-0.9.2.65git.1321935457/settings/config/manageconnectionwidget.cpp:546
#8  0xa8d023b4 in ManageConnectionWidget::qt_metacall (this=0x876b690, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe7e990) at /usr/src/debug/networkmanagement-0.9.2.65git.1321935457/build/settings/config/moc_manageconnectionwidget.cpp:100
#9  0xb6e477dd in metacall (argv=0xbfe7e990, idx=41, cl=QMetaObject::InvokeMetaMethod, object=0x876b690) at kernel/qmetaobject.cpp:237
#10 QMetaObject::metacall (object=0x876b690, cl=QMetaObject::InvokeMetaMethod, idx=41, argv=0xbfe7e990) at kernel/qmetaobject.cpp:232
#11 0xb6e56710 in QMetaObject::activate (sender=0x9b112f8, m=0xa87d8ac8, local_signal_index=1, argv=0xbfe7e990) at kernel/qobject.cpp:3287
#12 0xa8779fad in NMDBusSettingsConnectionProvider::getConnectionSecretsCompleted (this=0x9b112f8, _t1=false, _t2=..., _t3=...) at /usr/src/debug/networkmanagement-0.9.2.65git.1321935457/build/backends/NetworkManager/moc_nmdbussettingsconnectionprovider.cpp:128
#13 0xa87be039 in NMDBusSettingsConnectionProvider::onConnectionSecretsArrived (this=0x9b112f8, watcher=0x9c98108) at /usr/src/debug/networkmanagement-0.9.2.65git.1321935457/backends/NetworkManager/nmdbussettingsconnectionprovider.cpp:520
#14 0xa877a1d5 in NMDBusSettingsConnectionProvider::qt_metacall (this=0x9b112f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe7ec48) at /usr/src/debug/networkmanagement-0.9.2.65git.1321935457/build/backends/NetworkManager/moc_nmdbussettingsconnectionprovider.cpp:106
#15 0xb6e477dd in metacall (argv=0xbfe7ec48, idx=11, cl=QMetaObject::InvokeMetaMethod, object=0x9b112f8) at kernel/qmetaobject.cpp:237
#16 QMetaObject::metacall (object=0x9b112f8, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbfe7ec48) at kernel/qmetaobject.cpp:232
#17 0xb6e56710 in QMetaObject::activate (sender=0x9c98108, m=0xb5c61bd8, local_signal_index=0, argv=0xbfe7ec48) at kernel/qobject.cpp:3287
#18 0xb5c448c5 in QDBusPendingCallWatcher::finished (this=0x9c98108, _t1=0x9c98108) at .moc/release-shared/moc_qdbuspendingcall.cpp:92
#19 0xb5c44973 in _q_finished (this=<optimized out>) at qdbuspendingcall.cpp:482
#20 QDBusPendingCallWatcher::qt_metacall (this=0x9c98108, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x85891a8) at .moc/release-shared/moc_qdbuspendingcall.cpp:80
#21 0xb6e477dd in metacall (argv=0x85891a8, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x9c98108) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0x9c98108, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x85891a8) at kernel/qmetaobject.cpp:232
#23 0xb6e52305 in QMetaCallEvent::placeMetaCall (this=0x97c6318, object=0x9c98108) at kernel/qobject.cpp:535
#24 0xb6e5982f in QObject::event (this=0x9c98108, e=0x97c6318) at kernel/qobject.cpp:1226
#25 0xb635cee4 in notify_helper (e=0x97c6318, receiver=0x9c98108, this=0x8123c90) at kernel/qapplication.cpp:4481
#26 QApplicationPrivate::notify_helper (this=0x8123c90, receiver=0x9c98108, e=0x97c6318) at kernel/qapplication.cpp:4453
#27 0xb6362272 in QApplication::notify (this=0x97c6318, receiver=0x9c98108, e=0x97c6318) at kernel/qapplication.cpp:4228
#28 0xb7585681 in KApplication::notify (this=0x8117780, receiver=0x9c98108, event=0x97c6318) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#29 0xb6e4142e in QCoreApplication::notifyInternal (this=0x8117780, receiver=0x9c98108, event=0x97c6318) at kernel/qcoreapplication.cpp:787
#30 0xb6e44bf4 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x805b568) at kernel/qcoreapplication.cpp:1428
#32 0xb6e44d3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#33 0xb6e6f404 in sendPostedEvents () at kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x81238a0) at kernel/qeventdispatcher_glib.cpp:277
#35 0xb5a58e2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb5a59560 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb5a597fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb6e6f837 in QEventDispatcherGlib::processEvents (this=0x8123ef8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#39 0xb6410aaa in QGuiEventDispatcherGlib::processEvents (this=0x8123ef8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0xb6e4044d in QEventLoop::processEvents (this=0xbfe7f404, flags=...) at kernel/qeventloop.cpp:149
#41 0xb6e40691 in QEventLoop::exec (this=0xbfe7f404, flags=...) at kernel/qeventloop.cpp:201
#42 0xb6e44dea in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#43 0xb635ad64 in QApplication::exec () at kernel/qapplication.cpp:3755
#44 0xb017c7cb in kdemain (argc=1, argv=0x80e3f18) at /usr/src/debug/kde-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#45 0x0804fbcd in _start ()
Comment 1 Lamarque V. Souza 2011-11-25 14:22:32 UTC
Have you restarted the KDE session after bug #287531?

Bug #287531 probably left your KDE session in unstable state, so this bug is probably just new symptom of #287531 and should be marked as its duplicate.
Comment 2 markuss 2011-11-25 14:56:41 UTC
No, the Plasma crash happened like 1 second after the PolicyKit1-KDE crash.
Comment 3 Lamarque V. Souza 2011-11-25 15:01:41 UTC
So this is just another symptom of #287531. Marking it as duplicate.

*** This bug has been marked as a duplicate of bug 287531 ***