Bug 287486 - Kontact crashes while opening an email
Summary: Kontact crashes while opening an email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-24 19:52 UTC by Jose Arthur Benetasso Villanova
Modified: 2011-11-29 17:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jose Arthur Benetasso Villanova 2011-11-24 19:52:20 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.1-2.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Opening a specific email. All other emails works. My machine is up-to-date.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f69389b7840 (LWP 2704))]

Thread 4 (Thread 0x7f692d519700 (LWP 2705)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000349d1973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x349db90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x000000349d1974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003479807d90 in start_thread (arg=0x7f692d519700) at pthread_create.c:309
#4  0x0000003478ceed8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f692cc18700 (LWP 2706)):
#0  0x0000003479809dd5 in __pthread_mutex_lock (mutex=0x7f69240009a8) at pthread_mutex_lock.c:65
#1  0x000000347c044f4f in g_main_context_poll (n_fds=1, fds=0x7f69240013e0, priority=<optimized out>, timeout=7587, context=0x7f69240009a0) at gmain.c:3381
#2  g_main_context_iterate (context=0x7f69240009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x000000347c04544c in g_main_context_iteration (context=0x7f69240009a0, may_block=1) at gmain.c:3136
#4  0x00000034835a6896 in QEventDispatcherGlib::processEvents (this=0x7f69240008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003483576c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003483576ed7 in QEventLoop::exec (this=0x7f692cc17d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003483478ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000348347bb1b in QThreadPrivate::start (arg=0x23d1d10) at thread/qthread_unix.cpp:298
#9  0x0000003479807d90 in start_thread (arg=0x7f692cc18700) at pthread_create.c:309
#10 0x0000003478ceed8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f68e0154700 (LWP 2760)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000348347c02b in wait (time=18446744073709551615, this=0x7f68d80074c0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f68d8005c90, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003483477e44 in QSemaphore::acquire (this=0x7f68e0152cc0, n=1) at thread/qsemaphore.cpp:144
#4  0x000000348358bcb5 in QMetaObject::activate (sender=0x4acf100, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f68e0152d30) at kernel/qobject.cpp:3524
#5  0x00000034852f59c4 in QHttpThreadDelegate::authenticationRequired (this=<optimized out>, _t1=<optimized out>, _t2=0x7f68d8002748) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:178
#6  0x00000034852f5f08 in QHttpThreadDelegate::qt_static_metacall (_o=0x4acf100, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:104
#7  0x000000348358b7d1 in QMetaObject::activate (sender=0x7f68d8005940, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f68e0152f60) at kernel/qobject.cpp:3546
#8  0x00000034852f46f7 in QHttpNetworkReply::authenticationRequired (this=<optimized out>, _t1=<optimized out>, _t2=0x7f68d8002748) at .moc/release-shared/moc_qhttpnetworkreply_p.cpp:192
#9  0x00000034852558d7 in QHttpNetworkConnectionPrivate::handleAuthenticateChallenge (this=0x7f68d8002600, socket=0x7f68d8002390, reply=0x7f68d8005940, isProxy=false, resend=@0x7f68e01531ef) at access/qhttpnetworkconnection.cpp:378
#10 0x000000348525bb44 in QHttpNetworkConnectionChannel::handleStatus (this=0x7f68d80026e8) at access/qhttpnetworkconnectionchannel.cpp:824
#11 0x000000348525c2ba in QHttpNetworkConnectionChannel::allDone (this=0x7f68d80026e8) at access/qhttpnetworkconnectionchannel.cpp:700
#12 0x000000348525cdcb in QHttpNetworkConnectionChannel::_q_receiveReply (this=0x7f68d80026e8) at access/qhttpnetworkconnectionchannel.cpp:505
#13 0x000000348525d8b2 in QHttpNetworkConnectionChannel::_q_readyRead (this=0x7f68d80026e8) at access/qhttpnetworkconnectionchannel.cpp:968
#14 0x000000348358b7d1 in QMetaObject::activate (sender=0x7f68d8002390, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3546
#15 0x00000034852cc8bf in QAbstractSocketPrivate::canReadNotification (this=0x7f68d8002f50) at socket/qabstractsocket.cpp:651
#16 0x00000034852d4391 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1151
#17 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1148
#18 0x00000034865c96f4 in notify_helper (e=0x7f68e0153b30, receiver=0x7f68d8006020, this=0x23ce2d0) at kernel/qapplication.cpp:4518
#19 QApplicationPrivate::notify_helper (this=0x23ce2d0, receiver=0x7f68d8006020, e=0x7f68e0153b30) at kernel/qapplication.cpp:4490
#20 0x00000034865ce573 in QApplication::notify (this=0x7fff0361efd0, receiver=0x7f68d8006020, e=0x7f68e0153b30) at kernel/qapplication.cpp:4379
#21 0x0000003487c50396 in KApplication::notify (this=0x7fff0361efd0, receiver=0x7f68d8006020, event=0x7f68e0153b30) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#22 0x0000003483577b4c in QCoreApplication::notifyInternal (this=0x7fff0361efd0, receiver=0x7f68d8006020, event=0x7f68e0153b30) at kernel/qcoreapplication.cpp:876
#23 0x00000034835a5e87 in sendEvent (event=0x7f68e0153b30, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#24 socketNotifierSourceDispatch (source=0x7f68d8001e00) at kernel/qeventdispatcher_glib.cpp:110
#25 0x000000347c044a7d in g_main_dispatch (context=0x7f68d80009a0) at gmain.c:2425
#26 g_main_context_dispatch (context=0x7f68d80009a0) at gmain.c:2995
#27 0x000000347c045278 in g_main_context_iterate (context=0x7f68d80009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#28 0x000000347c04544c in g_main_context_iteration (context=0x7f68d80009a0, may_block=1) at gmain.c:3136
#29 0x00000034835a682f in QEventDispatcherGlib::processEvents (this=0x7f68d80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#30 0x0000003483576c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003483576ed7 in QEventLoop::exec (this=0x7f68e0153d40, flags=...) at kernel/qeventloop.cpp:204
#32 0x0000003483478ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#33 0x000000348347bb1b in QThreadPrivate::start (arg=0x245a8f0) at thread/qthread_unix.cpp:298
#34 0x0000003479807d90 in start_thread (arg=0x7f68e0154700) at pthread_create.c:309
#35 0x0000003478ceed8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f69389b7840 (LWP 2704)):
[KCrash Handler]
#6  same_key (key0=..., h0=220613635, this=0x7272727274747474) at ../../src/corelib/tools/qhash.h:225
#7  QHash<QByteArray, QNetworkAccessCache::Node>::findNode (this=<optimized out>, akey=..., ahp=0x0) at ../../src/corelib/tools/qhash.h:887
#8  0x000000348526512f in contains (akey=<optimized out>, this=0x4f4abb0) at ../../src/corelib/tools/qhash.h:874
#9  QNetworkAccessCache::hasEntry (this=0x4f4aba0, key=<optimized out>) at access/qnetworkaccesscache.cpp:267
#10 0x000000348525ef47 in QNetworkAccessAuthenticationManager::fetchCachedCredentials (this=0x4f4aba0, url=..., authentication=<optimized out>) at access/qnetworkaccessauthenticationmanager.cpp:281
#11 0x0000003485262019 in QNetworkAccessManagerPrivate::authenticationRequired (this=0x4852630, backend=0x48535f0, authenticator=0x7f68d8002748) at access/qnetworkaccessmanager.cpp:1071
#12 0x00000034852f4f80 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x48535f0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:93
#13 0x00000034835909e6 in QObject::event (this=0x48535f0, e=<optimized out>) at kernel/qobject.cpp:1194
#14 0x00000034865c96f4 in notify_helper (e=0x7f68d8007710, receiver=0x48535f0, this=0x23ce2d0) at kernel/qapplication.cpp:4518
#15 QApplicationPrivate::notify_helper (this=0x23ce2d0, receiver=0x48535f0, e=0x7f68d8007710) at kernel/qapplication.cpp:4490
#16 0x00000034865ce573 in QApplication::notify (this=0x7fff0361efd0, receiver=0x48535f0, e=0x7f68d8007710) at kernel/qapplication.cpp:4379
#17 0x0000003487c50396 in KApplication::notify (this=0x7fff0361efd0, receiver=0x48535f0, event=0x7f68d8007710) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#18 0x0000003483577b4c in QCoreApplication::notifyInternal (this=0x7fff0361efd0, receiver=0x48535f0, event=0x7f68d8007710) at kernel/qcoreapplication.cpp:876
#19 0x000000348357b5da in sendEvent (event=0x7f68d8007710, receiver=0x48535f0) at kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x23a1070) at kernel/qcoreapplication.cpp:1500
#21 0x00000034835a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=0x23d0370) at kernel/qeventdispatcher_glib.cpp:279
#23 0x000000347c044a7d in g_main_dispatch (context=0x23d0280) at gmain.c:2425
#24 g_main_context_dispatch (context=0x23d0280) at gmain.c:2995
#25 0x000000347c045278 in g_main_context_iterate (context=0x23d0280, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#26 0x000000347c04544c in g_main_context_iteration (context=0x23d0280, may_block=1) at gmain.c:3136
#27 0x00000034835a682f in QEventDispatcherGlib::processEvents (this=0x23a2530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#28 0x000000348666c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#29 0x0000003483576c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x0000003483576ed7 in QEventLoop::exec (this=0x7fff0361ef60, flags=...) at kernel/qeventloop.cpp:204
#31 0x000000348357b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#32 0x00000000004037b9 in main (argc=1, argv=0x7fff0361f5f8) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Sérgio Basto 2011-11-24 22:07:55 UTC
this is a duplicated of bug #286307,
Comment 2 Christophe Giboudeaux 2011-11-29 17:12:04 UTC

*** This bug has been marked as a duplicate of bug 286307 ***