Bug 287270 - application crush in close
Summary: application crush in close
Status: RESOLVED WORKSFORME
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 4.2.3
Assignee: kdevelop-bugs-null
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2011-11-22 15:11 UTC by chenjun
Modified: 2018-10-27 02:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chenjun 2011-11-22 15:11:23 UTC
Application: kdevelop (4.0.0 (using KDevPlatform 1.0.0))
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-35-generic i686
Distribution: Ubuntu 10.04.3 LTS

-- Information about the crash:
i open a cpp source file in full screen mode,when i close current session an close KDevelop,the application crush down.
my project is imported from a cmake file.

 -- Backtrace:
Application: KDevelop (kdevelop.bin), signal: Aborted
[Current thread is 1 (Thread 0xb77a1710 (LWP 2018))]

Thread 5 (Thread 0xb480cb70 (LWP 2024)):
#0  0x00b79422 in __kernel_vsyscall ()
#1  0x00accd33 in __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/lowlevellock.S:95
#2  0x00a63697 in _L_lock_9639 () from /lib/tls/i686/cmov/libc.so.6
#3  0x00a61ec6 in *__GI___libc_free (mem=0x9c4ae98) at malloc.c:3736
#4  0x08f28fc6 in g_free () from /lib/libglib-2.0.so.0
#5  0x08f1ff5a in ?? () from /lib/libglib-2.0.so.0
#6  0x00d0f0fd in ~QEventDispatcherGlib (this=0x9c49708, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:366
#7  0x00bdfe9a in QThreadPrivate::finish (arg=0xdf7890) at thread/qthread_unix.cpp:284
#8  0x00be0336 in ~__pthread_cleanup_class (arg=0xdf7890) at /usr/include/pthread.h:535
#9  QThreadPrivate::start (arg=0xdf7890) at thread/qthread_unix.cpp:253
#10 0x003b596e in start_thread (arg=0xb480cb70) at pthread_create.c:300
#11 0x00abfa4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xb35b4b70 (LWP 2043)):
#0  0x00b79422 in __kernel_vsyscall ()
#1  0x00accd33 in __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/lowlevellock.S:95
#2  0x00a63697 in _L_lock_9639 () from /lib/tls/i686/cmov/libc.so.6
#3  0x00a61ec6 in *__GI___libc_free (mem=0xa97a7b0) at malloc.c:3736
#4  0x00bdaa5d in qFree (ptr=0xa97a7b0) at global/qmalloc.cpp:60
#5  0x00bfe2d6 in QHashData::freeNode (this=0xa97a7a8, node=0xfffffe00) at tools/qhash.cpp:189
#6  0x00bfe349 in QHashData::free_helper (this=0xaaf2390, node_delete=0x1ac9410) at tools/qhash.cpp:276
#7  0x01ac73d0 in KDevelop::ModificationRevisionSet::clearCache() () from /usr/lib/libkdevplatformlanguage.so.1
#8  0x01b134f8 in ?? () from /usr/lib/libkdevplatformlanguage.so.1
#9  0x00be032e in QThreadPrivate::start (arg=0xdf73c0) at thread/qthread_unix.cpp:248
#10 0x003b596e in start_thread (arg=0xb35b4b70) at pthread_create.c:300
#11 0x00abfa4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xb2d6bb70 (LWP 2046)):
#0  0x00b79422 in __kernel_vsyscall ()
#1  0x003ba015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x00acc9dd in __pthread_cond_wait (cond=0x9d56868, mutex=0x9d56850) at forward.c:139
#3  0x00be1287 in QWaitConditionPrivate::wait (this=0x9d3d6c8, mutex=0x9ca7c58, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x9d3d6c8, mutex=0x9ca7c58, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x01e22870 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x01e2538c in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x01e2127b in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x01e25482 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x01e224d3 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x01e2351e in ?? () from /usr/lib/libthreadweaver.so.4
#11 0x01e23c3b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#12 0x00be032e in QThreadPrivate::start (arg=0x9724518) at thread/qthread_unix.cpp:248
#13 0x003b596e in start_thread (arg=0xb2d6bb70) at pthread_create.c:300
#14 0x00abfa4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb256ab70 (LWP 2159)):
#0  0x00b79422 in __kernel_vsyscall ()
#1  0x003ba015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x00acc9dd in __pthread_cond_wait (cond=0x59b128c, mutex=0x59b1274) at forward.c:139
#3  0x058d2c97 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x59ac1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#4  0x058d2ce1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x59ac1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#5  0x003b596e in start_thread (arg=0xb256ab70) at pthread_create.c:300
#6  0x00abfa4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77a1710 (LWP 2018)):
[KCrash Handler]
#6  0x00b79422 in __kernel_vsyscall ()
#7  0x00a1c651 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x00a1fa82 in *__GI_abort () at abort.c:92
#9  0x00a5349d in __libc_message (do_abort=2, fmt=0xb27f98 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#10 0x00a5d591 in malloc_printerr (action=<value optimized out>, str=0x6 <Address 0x6 out of bounds>, ptr=0xa642398) at malloc.c:6266
#11 0x00a5d9ea in malloc_consolidate (av=<value optimized out>) at malloc.c:5152
#12 0x00a5ed65 in _int_free (av=<value optimized out>, p=0xa4c8760) at malloc.c:5017
#13 0x00a61ecd in *__GI___libc_free (mem=0xa4d0e58) at malloc.c:3738
#14 0x00bdaa5d in qFree (ptr=0xa4d0e58) at global/qmalloc.cpp:60
#15 0x00bfe2d6 in QHashData::freeNode (this=0x6, node=0x0) at tools/qhash.cpp:189
#16 0x00bfe349 in QHashData::free_helper (this=0x9e35aa0, node_delete=0x1327750 <QHash<unsigned long long, QGradientCache::CacheInfo>::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:276
#17 0x013270ac in QHash<unsigned long long, QGradientCache::CacheInfo>::freeData (this=0x1a6cc58, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:567
#18 ~QHash (this=0x1a6cc58, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:284
#19 ~QMultiHash (this=0x1a6cc58, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:918
#20 ~QGradientCache (this=0x1a6cc58, __in_chrg=<value optimized out>) at painting/qpaintengine_raster.cpp:4800
#21 ~QGlobalStaticDeleter (this=0x1a6cc58, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1803
#22 0x00a211bf in __run_exit_handlers (status=0, listp=0xb48324, run_list_atexit=true) at exit.c:78
#23 0x00a2122f in *__GI_exit (status=0) at exit.c:100
#24 0x00a08bde in __libc_start_main (main=0x804b5e0 <_start+240>, argc=1, ubp_av=0xbfc79e34, init=0x80512d0 <__libc_csu_init>, fini=0x80512c0 <__libc_csu_fini>, rtld_fini=0xf1e030 <_dl_fini>, 
    stack_end=0xbfc79e2c) at libc-start.c:258
#25 0x0804b511 in _start ()

Possible duplicates by query: bug 283019, bug 251003, bug 250807, bug 250327, bug 245488.

Reported using DrKonqi
Comment 1 Milian Wolff 2011-11-22 18:27:28 UTC
Sorry, but I cannot follow your steps to reproduce this bug. Could you maybe try to repeat the steps involved, and explain it differently? Or make screenshots of what you do.

Alternatively, if you can easily reproduce this issue, please run KDevelop through valgrind and paste the errors it reports when you hit the crash:

valgrind --track-origins=yes --num-callers=25 kdevelop

thanks
Comment 2 Andrew Crouthamel 2018-09-22 01:51:00 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-27 02:47:55 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!