Bug 287263 - KMail shows no mails at all, just the loading animation
Summary: KMail shows no mails at all, just the loading animation
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: misc (show other bugs)
Version: 1.99.0
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-22 14:34 UTC by Unknown
Modified: 2017-01-14 15:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
My mails disappeared (41.33 KB, image/png)
2011-11-22 14:34 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2011-11-22 14:34:13 UTC
Created attachment 65935 [details]
My mails disappeared

Version:           1.99.0 (using KDE 4.7.3) 
OS:                Linux

After I migrated to KMail 2, and manually imported my sent mails, closed the program and waited until Akonadi re-downloads everything (with the help of Akonaditray to follow the process). Then I started KMail 2 again and with the exception of my main account's inbox, I see no mails.

Even my sent-mails folder is empty.

mysql --socket /home/…/.local/share/akonadi/socket-linux-suse/mysql.socket

mysql> show full processlist;
+----+------+-----------+---------+---------+-------+-------+-----------------------+
| Id | User | Host      | db      | Command | Time  | State | Info                  |
+----+------+-----------+---------+---------+-------+-------+-----------------------+
|  3 | aki  | localhost | akonadi | Sleep   |    33 |       | NULL                  |
|  4 | aki  | localhost | akonadi | Sleep   | 64705 |       | NULL                  |
|  5 | aki  | localhost | akonadi | Sleep   | 64705 |       | NULL                  |
|  6 | aki  | localhost | akonadi | Sleep   |     1 |       | NULL                  |
|  7 | aki  | localhost | akonadi | Sleep   | 64705 |       | NULL                  |
| 12 | aki  | localhost | akonadi | Sleep   |     0 |       | NULL                  |
| 17 | aki  | localhost | akonadi | Sleep   | 64705 |       | NULL                  |
| 19 | aki  | localhost | akonadi | Sleep   | 64704 |       | NULL                  |
| 46 | aki  | localhost | akonadi | Sleep   |   495 |       | NULL                  |
| 54 | aki  | localhost | akonadi | Sleep   |     1 |       | NULL                  |
| 57 | aki  | localhost | akonadi | Sleep   |   273 |       | NULL                  |
| 68 | aki  | localhost | akonadi | Sleep   |  7260 |       | NULL                  |
| 71 | aki  | localhost | akonadi | Query   |     0 | NULL  | show full processlist |
| 82 | aki  | localhost | akonadi | Sleep   |   324 |       | NULL                  |
| 83 | aki  | localhost | akonadi | Sleep   |   473 |       | NULL                  |
+----+------+-----------+---------+---------+-------+-------+-----------------------+
15 rows in set (0.00 sec)


Reproducible: Didn't try



Expected Results:  
 

OS: Linux (x86_64) release 3.1.0-1.2-desktop
Compiler: gcc
Comment 1 Unknown 2011-11-23 08:19:27 UTC
After 5-10 minutes most of my folders content were shown. But one folder icon was still the animation even after 6 hours. mysqld (from akonadi) had a full-one-core-usage all this time.

When I restarted KMail, the mysqld still used a CPU core 100%, but at least loading animation was gone (until I clicked on the folder's name).
Comment 2 sedrubal 2016-06-27 13:46:18 UTC
The same here:

Akonadi 5.1.51:
Driver=QSQLITE3

kmail2 5.1.3
Comment 3 Denis Kurz 2017-01-14 14:18:31 UTC
sedrubal, your issue has probably nothing to do with the original bug reported here. That's because KMail has seen several huge changes since 2011. Also, the orininal reporter deleted her account, so we cannot contact her for feedback any more. Please open a new report with more details about your setup, since mixing up different bugs in one report is a sure path to confusion.
Comment 4 sedrubal 2017-01-14 15:13:16 UTC
You may be right, I'm sorry... I don't anymore know how I could fix my issue, but it is fixed anyway. So this works for me...
Comment 5 Denis Kurz 2017-01-14 15:22:54 UTC
No worries, we are always grateful for feedback. Glad to hear that it works for you now.