Bug 287076 - NetworkManager Plasma widget ignores OpenVPN connection attempt
Summary: NetworkManager Plasma widget ignores OpenVPN connection attempt
Status: RESOLVED NOT A BUG
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: 0.9
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-20 15:09 UTC by Thilo-Alexander Ginkel
Modified: 2011-11-22 04:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thilo-Alexander Ginkel 2011-11-20 15:09:03 UTC
Version:           0.9 (using KDE 4.7.2) 
OS:                Linux

When attempting to Connect to my configured VPN connection by clicking on the respective entry in th Plasma widget's Connections list while connected via WiFi or WWAN, nothing happens. It does not make a difference whether I set up the VPN connection as a system connection or not.

Version: 0.9~git20111103.1240c6f-2 (rc2 + the patch from bugs #283241 and #286424).

Reproducible: Always

Steps to Reproduce:
1. Connect to WiFi.
2. Attempt to connect to (OpenVPN) VPN.

Actual Results:  
Nothing happens.

Expected Results:  
A VPN connection is established.
Comment 1 Lamarque V. Souza 2011-11-20 18:19:41 UTC
I cannot reproduce this problem here. I have a OpenVPN connection and it works.

Usually when you click on a connection and nothing happens is because NM has invalidated the connection. Attach the NM log, the reason should the there.
Comment 2 Thilo-Alexander Ginkel 2011-11-22 01:49:45 UTC
On Sun, Nov 20, 2011 at 19:19, Lamarque V. Souza <lamarque@kde.org> wrote:
> I cannot reproduce this problem here. I have a OpenVPN connection and it works.
>
> Usually when you click on a connection and nothing happens is because NM has
> invalidated the connection. Attach the NM log, the reason should the there.

You are right, this was a NM problem (not sure what caused
nm-openvpn-service to be uninstalled):

Nov 22 02:32:27 orion NetworkManager[1301]: <info> Starting VPN
service 'openvpn'...
Nov 22 02:32:27 orion NetworkManager[1301]: <warn> VPN service
'openvpn': could not launch the VPN service. error: (8) Failed
 to execute child process "/usr/lib/NetworkManager/nm-openvpn-service"
(No such file or directory).
Nov 22 02:32:27 orion NetworkManager[1301]: <warn> connection
/org/freedesktop/NetworkManager/Settings/3 failed to activate:
(3) Failed to execute child process
"/usr/lib/NetworkManager/nm-openvpn-service" (No such file or
directory)

Is there any chance to see such errors in the UI in the future (just an idea)?

Thanks!
Comment 3 Lamarque V. Souza 2011-11-22 03:23:13 UTC
(In reply to comment #2)
> Is there any chance to see such errors in the UI in the future (just an idea)?

Well, I tried to implement it here but NetworkManager simply does not return anything to Plasma NM when the NetworkManager's vpn plugin is uninstalled.

I managed to implement error reporting for other errors, such as invalid connection and some other very rare errors, which I have never seen happening so they are not much usefull.
Comment 4 Lamarque V. Souza 2011-11-22 04:18:26 UTC
Git commit 1b61dfbe8fcb38d07380f0ba75181592f46d667d by Lamarque V. Souza.
Committed on 22/11/2011 at 05:17.
Pushed by lvsouza into branch 'master'.

Report error message on VPN activation failure.

CCBUG: 287076

M  +1    -0    backends/NetworkManager/CMakeLists.txt
M  +37   -1    backends/NetworkManager/nmdbussettingsconnectionprovider.cpp
M  +1    -0    backends/NetworkManager/nmdbussettingsconnectionprovider.h
M  +4    -0    libs/service/notificationmanager.cpp
M  +1    -0    libs/service/notificationmanager.h

http://commits.kde.org/networkmanagement/1b61dfbe8fcb38d07380f0ba75181592f46d667d
Comment 5 Lamarque V. Souza 2011-11-22 04:22:28 UTC
Git commit a3a91df8bbbf2293454cf4630fe1657554f4f92a by Lamarque V. Souza.
Committed on 22/11/2011 at 05:17.
Pushed by lvsouza into branch 'nm09'.

Report error message on VPN activation failure.

CCBUG: 287076
(cherry picked from commit 1b61dfbe8fcb38d07380f0ba75181592f46d667d)

M  +1    -0    backends/NetworkManager/CMakeLists.txt
M  +37   -1    backends/NetworkManager/nmdbussettingsconnectionprovider.cpp
M  +1    -0    backends/NetworkManager/nmdbussettingsconnectionprovider.h
M  +4    -0    libs/service/notificationmanager.cpp
M  +1    -0    libs/service/notificationmanager.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/a3a91df8bbbf2293454cf4630fe1657554f4f92a
Comment 6 Lamarque V. Souza 2011-11-22 04:24:31 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Is there any chance to see such errors in the UI in the future (just an idea)?
> 
> Well, I tried to implement it here but NetworkManager simply does not return
> anything to Plasma NM when the NetworkManager's vpn plugin is uninstalled.
> 
> I managed to implement error reporting for other errors, such as invalid
> connection and some other very rare errors, which I have never seen happening
> so they are not much usefull.

I have found what I did wrong, now Plasma NM fetches the error message.