Bug 286712 - Crash: ASSERT failure in QVector<T>::at: "index out of range"
Summary: Crash: ASSERT failure in QVector<T>::at: "index out of range"
Status: RESOLVED FIXED
Alias: None
Product: calligrastage
Classification: Applications
Component: filter/ppt (show other bugs)
Version: 2.4-snapshots
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-15 17:33 UTC by LukasT
Modified: 2011-11-25 16:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LukasT 2011-11-15 17:33:25 UTC
Version:           2.4-snapshots
OS:                Linux

File crashed when trying to open

Reproducible: Always

Steps to Reproduce:
Open file located at

http://aplicaciones02.fod.ac.cr/cienciaaventura/ciencias_marinas/descargas/corazon_ballenas.ppt

Actual Results:  
Crash

Expected Results:  
Load file without crash
Comment 1 LukasT 2011-11-15 17:41:15 UTC
Adding backtrace:

Application: Stage (calligrastage), signal: Aborted
[KCrash Handler]
#7  0x00da6424 in __kernel_vsyscall ()
#8  0x073632f1 in raise () from /lib/libc.so.6
#9  0x07364d5e in abort () from /lib/libc.so.6
#10 0x0529b63a in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#11 0x0529b809 in ?? () from /usr/lib/libQtCore.so.4
#12 0x0529b91a in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#13 0x0529b95d in qt_assert_x(char const*, char const*, char const*, int) () from /usr/lib/libQtCore.so.4
#14 0x044531b7 in QVector<QPoint>::at (this=0xbf94f2d0, i=13) at /usr/include/QtCore/qvector.h:339
#15 0x0445179a in ODrawToOdf::setEnhancedGeometry (this=0xbf94f720, o=..., out=...) at /home/lukas/src/calligra/filters/libmso/shapes.cpp:1187
#16 0x0444e804 in ODrawToOdf::processNotPrimitive (this=0xbf94f720, o=..., out=...) at /home/lukas/src/calligra/filters/libmso/shapes.cpp:459
#17 0x0444e8fc in ODrawToOdf::processDrawingObject (this=0xbf94f720, o=..., out=...) at /home/lukas/src/calligra/filters/libmso/shapes.cpp:472
#18 0x04446f50 in ODrawToOdf::processDrawing (this=0xbf94f720, of=..., out=...) at /home/lukas/src/calligra/filters/libmso/ODrawToOdf.cpp:95
#19 0x04446e4b in ODrawToOdf::processGroupShape (this=0xbf94f720, o=..., out=...) at /home/lukas/src/calligra/filters/libmso/ODrawToOdf.cpp:76
#20 0x04446f2a in ODrawToOdf::processDrawing (this=0xbf94f720, of=..., out=...) at /home/lukas/src/calligra/filters/libmso/ODrawToOdf.cpp:93
#21 0x04446e9d in ODrawToOdf::processGroupShape (this=0xbf94f720, o=..., out=...) at /home/lukas/src/calligra/filters/libmso/ODrawToOdf.cpp:80
#22 0x04330252 in PptToOdp::processSlideForBody (this=0xbf94f940, slideNo=29, out=...) at /home/lukas/src/calligra/filters/stage/powerpoint/PptToOdp.cpp:2779
#23 0x0432d98c in PptToOdp::createContent (this=0xbf94f940, styles=...) at /home/lukas/src/calligra/filters/stage/powerpoint/PptToOdp.cpp:2087
#24 0x04326b3c in PptToOdp::doConversion (this=0xbf94f940, storeout=0x8f80dd8) at /home/lukas/src/calligra/filters/stage/powerpoint/PptToOdp.cpp:825
#25 0x04326773 in PptToOdp::convert (this=0xbf94f940, inputFile=..., to=..., storeType=KoStore::Zip) at /home/lukas/src/calligra/filters/stage/powerpoint/PptToOdp.cpp:778
#26 0x04323617 in PowerPointImport::convert (this=0x8cd90f8, from=..., to=...) at /home/lukas/src/calligra/filters/stage/powerpoint/PowerPointImport.cpp:39
#27 0x00baa29b in CalligraFilter::ChainLink::invokeFilter (this=0x8c3aa20, parentChainLink=0x0) at /home/lukas/src/calligra/libs/main/KoFilterChainLink.cpp:90
#28 0x00ba0c54 in KoFilterChain::invokeChain (this=0x8ce0d38) at /home/lukas/src/calligra/libs/main/KoFilterChain.cpp:94
#29 0x00b9a8a6 in KoFilterManager::importDocument (this=0x8cb8480, url=..., documentMimeType=..., status=@0xbf94fba4) at /home/lukas/src/calligra/libs/main/KoFilterManager.cpp:170
#30 0x00b47bc8 in KoDocument::openFile (this=0x8b4b9b8) at /home/lukas/src/calligra/libs/main/KoDocument.cpp:1495
#31 0x0034ba15 in ?? () from /usr/lib/libkparts.so.4
#32 0x0034c10b in KParts::ReadOnlyPart::openUrl(KUrl const&) () from /usr/lib/libkparts.so.4
#33 0x00b469de in KoDocument::openUrl (this=0x8b4b9b8, _url=...) at /home/lukas/src/calligra/libs/main/KoDocument.cpp:1254
#34 0x00b6c4bd in KoMainWindow::openDocumentInternal (this=0x8b984e8, url=..., newdoc=0x8b4b9b8) at /home/lukas/src/calligra/libs/main/KoMainWindow.cpp:643
#35 0x00b6c35c in KoMainWindow::openDocument (this=0x8b984e8, newdoc=0x8b4b9b8, url=...) at /home/lukas/src/calligra/libs/main/KoMainWindow.cpp:626
#36 0x00b3c66e in KoApplication::start (this=0xbf950234) at /home/lukas/src/calligra/libs/main/KoApplication.cpp:282
#37 0x003fce7a in kdemain (argc=2, argv=0xbf950344) at /home/lukas/src/calligra/stage/part/main.cpp:41
#38 0x08048789 in main (argc=2, argv=0xbf950344) at /home/lukas/src/build/calligra/stage/part/calligrastage_dummy.cpp:3
Comment 2 Matus Uzak 2011-11-25 16:26:58 UTC
Git commit 639b6430f4b95fb27da33577d1d77667cdaa7b1d by Matus Uzak.
Committed on 25/11/2011 at 17:21.
Pushed by uzak into branch 'master'.

ppt: Fixed a crash in setEnhancedGeometry - complex data related.

TODO: There's something wrong with complex properties, because the test file
was crashing only sometimes.  Another workaround might be needed because some
of the old MS Office versions is messing up the complex data.

BUG:286712

M  +5    -5    filters/libmso/shapes.cpp

http://commits.kde.org/calligra/639b6430f4b95fb27da33577d1d77667cdaa7b1d