Bug 286607 - Order of the pictures is wrong
Summary: Order of the pictures is wrong
Status: RESOLVED FIXED
Alias: None
Product: calligrasheets
Classification: Applications
Component: filter/xls (show other bugs)
Version: 2.4-snapshots
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: LukasT
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-14 18:34 UTC by LukasT
Modified: 2011-11-29 09:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
MS Excel 2003 screenshot (346.16 KB, image/png)
2011-11-14 18:37 UTC, LukasT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LukasT 2011-11-14 18:34:25 UTC
Version:           2.4-snapshots (using KDE 4.7.3) 
OS:                Linux

z-index is not properly set in the processing of the pictures.

Reproducible: Always

Steps to Reproduce:
1. Observe attached document in MS Excel 2003

Actual Results:  
Wrong order of the pictures

Expected Results:  
See attachment, screenshot from MS Excel 2003

1. draw:z-index is not correctly set in filters
2. after setting it to some values in the filter code, it seems to be ignored..but odf rendered with oocalc is displayed correctly, but then the shapes are ordered there according the z-index so it seems that it renders the shapes as they are ordered in the document.
Comment 1 LukasT 2011-11-14 18:37:06 UTC
Created attachment 65664 [details]
MS Excel 2003 screenshot
Comment 2 LukasT 2011-11-14 18:50:24 UTC
I will send the file by email on request as it is bigger then allowed size.
Comment 3 LukasT 2011-11-15 09:08:32 UTC
I put the file here 
http://dl.dropbox.com/u/49515273/zindex.xls
Comment 4 LukasT 2011-11-22 16:21:06 UTC
Git commit 4f2b42ceead86b95d8000aa1de384aaa4a54bf98 by Lukáš Tvrdý.
Committed on 22/11/2011 at 17:16.
Pushed by lukast into branch 'tables-filter-fix-pictures-ltvrdy'.

Fix z-index for odraw objects (autoshapes, pictures)

Index the drawing records as the order
define the z-index of the shapes.

Tested with cstester.

CCBUG:286607

M  +4    -0    filters/libmso/ODrawToOdf.h
M  +2    -0    filters/libmso/shapes.cpp
M  +27   -4    filters/tables/excel/import/ExcelImport.cpp
M  +11   -1    filters/tables/excel/import/ODrawClient.cpp
M  +6    -0    filters/tables/excel/import/ODrawClient.h
M  +12   -2    filters/tables/excel/sidewinder/objects.cpp
M  +4    -1    filters/tables/excel/sidewinder/objects.h
M  +4    -2    filters/tables/excel/sidewinder/worksheetsubstreamhandler.cpp

http://commits.kde.org/calligra/4f2b42ceead86b95d8000aa1de384aaa4a54bf98
Comment 5 LukasT 2011-11-23 08:37:32 UTC
Git commit 67ce609a4bd1c372f19d64736d0b6735ae80434e by Lukáš Tvrdý.
Committed on 22/11/2011 at 17:16.
Pushed by lukast into branch 'master'.

Fix z-index for odraw objects (autoshapes, pictures)

Index the drawing records as the order
define the z-index of the shapes.

Tested with cstester.

CCBUG:286607

M  +4    -0    filters/libmso/ODrawToOdf.h
M  +2    -0    filters/libmso/shapes.cpp
M  +27   -4    filters/tables/excel/import/ExcelImport.cpp
M  +11   -1    filters/tables/excel/import/ODrawClient.cpp
M  +6    -0    filters/tables/excel/import/ODrawClient.h
M  +12   -2    filters/tables/excel/sidewinder/objects.cpp
M  +4    -1    filters/tables/excel/sidewinder/objects.h
M  +4    -2    filters/tables/excel/sidewinder/worksheetsubstreamhandler.cpp

http://commits.kde.org/calligra/67ce609a4bd1c372f19d64736d0b6735ae80434e