Bug 286142 - KDE4 Loads Both Plasma Panel and KDE3 Kicker?
Summary: KDE4 Loads Both Plasma Panel and KDE3 Kicker?
Status: RESOLVED DUPLICATE of bug 262444
Alias: None
Product: plasma4
Classification: Unclassified
Component: panel (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-08 22:37 UTC by David Rankin
Modified: 2011-12-02 19:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot showing 4.7.3 loading plasma panel and kde3 kicker panel on start (129.55 KB, image/png)
2011-11-08 22:37 UTC, David Rankin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Rankin 2011-11-08 22:37:04 UTC
Created attachment 65414 [details]
Screenshot showing 4.7.3 loading plasma panel and kde3 kicker panel on start

Version:           unspecified (using KDE 4.7.3) 
OS:                Linux

Guys,

  This bug has plagued kde4 for some time. I am trying to test kde 4.7.3-1, but I cannot get it to load without also loading the kde3 kicker in the middle of the page. This is on Arch Linux which basically just packages a clean upstream kde4 from you guys, so this has got to be a generic kde4 issue. I know openSuSE does something to prevent the conflict, but how do I stop this behavior on Arch?

  Prior to launching 4.7.3-1, I removed all prior ~/.kde4 directories and the only other existing .kde3 dir is ~/.kdemod3. Why does 4.7.3 insist on loading the kde3 kicker? Look at the attached screenshot. This is what I see when kde4 loads -- that should not happen. Granted the screenshot is wide due to my dual-monitor layout, but this occurs on single monitor setups as well.

  I don't even know what else to send you that would help. (let me know). I've looked through /usr/share/config/kdm/kdmrc and I can't find anything that would trigger a kicker load. Where to look?  On Arch (as in most distros) the old kde is installed in /opt/kde while the new 4.7.3 is installed in /usr/bin, so there shouldn't be a conflict. Regardless, I need to know how to fix this problem so that this conflict doesn't occur with Trinity as well.

  Let me know what else to send. Thanks.

Reproducible: Didn't try

Steps to Reproduce:
launch kde4 on arch with an earlier kde3 (or Trinity) installed.

Actual Results:  
Plasma panel loads on the bottom and kde3 kicker loads just above the plasma panel

Expected Results:  
No kde3 kicker at all
Comment 1 Martin Klapetek 2011-12-02 17:32:41 UTC
I think it might be just a misconfiguration of some sort.

Btw. does plasma actually crash or did you set "crash" by mistake? ;)
Comment 2 Jekyll Wu 2011-12-02 18:59:00 UTC
I once met such problem in archlinux after installing kde3mod, but the strange thing is it only happened to one user account. I forgot how the problem got resolved :(

And I agree this looks more like packaging or configuration problem.

However, I think the same problem has already been reported by the reporter in bug 262444.
Comment 3 Martin Klapetek 2011-12-02 19:35:06 UTC
Ok, I'll mark it as a duplicate of 262444 then so it can be solved at one place ;)

Thanks.

*** This bug has been marked as a duplicate of bug 262444 ***