Bug 285712 - Resizing the Files Browser pane causes breadcrumbs to show in separate windows for each path level. Path doesn't show in the breadcrumb line at all
Summary: Resizing the Files Browser pane causes breadcrumbs to show in separate window...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: File Browser (show other bugs)
Version: 2.5-git
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords: regression
: 286873 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-03 23:29 UTC by Clinton
Modified: 2013-01-02 16:23 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments
Screenshot of problem (679.58 KB, image/png)
2011-11-04 00:16 UTC, Clinton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clinton 2011-11-03 23:29:06 UTC
Version:           2.4.3
OS:                Linux

I have wobbly-windows enabled on my desktop. When I have the file-browser open to a specific folder and then drag the main Amarok window each directory in the breadcrumb path becomes a new windows. I have taskbar entries (Amarok <1>, Amarok <2>, etc.) for each, and all they are is a single widget with a folder-name on it.

I can not always get the seperate windows to come up, but the actual breadcrumb folder-navigator in Amarok no longer shows my path at all, ever. All I ever see is my root directory (/). Clicking on the breadcrumb navigator to show the editable text-field, however, shows the entire directory I am currently navigating.

Reproducible: Sometimes

Steps to Reproduce:
Enable wobbly-windows in KWin, browse to any folder in the file-explorer, drag the Amarok window.

Actual Results:  
Sometimes new windows are spawned containing each breadcrumb element, sometimes not. After the first time the bug occurs the breadcrumb navigator stops displaying any paths other than /.

Expected Results:  
Window moves normally.

OS: Linux (i686) release 3.0.0-12-generic
Compiler: gcc
Comment 1 Clinton 2011-11-04 00:16:33 UTC
Created attachment 65211 [details]
Screenshot of problem
Comment 2 Myriam Schweingruber 2011-11-17 20:52:34 UTC
This also happens without the Wobbly Windows effect, so not related to KWin. Changing title accordingly.
Comment 3 Myriam Schweingruber 2011-11-17 20:52:45 UTC
*** Bug 286873 has been marked as a duplicate of this bug. ***
Comment 4 Myriam Schweingruber 2012-11-24 08:45:53 UTC
I can't reproduce this here at all, current Amarok 2.6-git, KDE 4.9.3. PLease test with git or check with Amarok 2.7 beta, to be released in a few days.
Comment 5 Matěj Laitl 2012-12-15 10:06:47 UTC
Neiter I am able to reproduce this wit 2.7 Beta & kdelibs 4.9.3. Instead, I'm getting less severe bug 246029.
Comment 6 Matěj Laitl 2013-01-02 16:23:40 UTC
Git commit 9134490e54824f4c6090230d249c36ca284f1654 by Matěj Laitl.
Committed on 02/01/2013 at 17:19.
Pushed by laitl into branch 'master'.

BrowserBreadcrumbWidget, ElidingButton: fix lay-outing issues wrt minimumSize

BUGFIXES:
 * Fix Media Sources pane growing in size when navigating in it. (BR )
 * Fix Media Sources breadcrumb items sometimes appearing as new windows. (BR )
Related: bug 246029
FIXED-IN: 2.7

M  +2    -0    ChangeLog
M  +37   -31   src/browsers/BrowserBreadcrumbWidget.cpp
M  +21   -12   src/browsers/BrowserBreadcrumbWidget.h
M  +3    -3    src/widgets/ElidingButton.cpp

http://commits.kde.org/amarok/9134490e54824f4c6090230d249c36ca284f1654