Bug 285477 - Krita 2.4 (b3): 3 Adjust Filters have their preview not working on the canvas
Summary: Krita 2.4 (b3): 3 Adjust Filters have their preview not working on the canvas
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Filters (show other bugs)
Version: 2.4-snapshots
Platform: Ubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 285552 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-01 14:46 UTC by Silvio Grosso
Modified: 2012-02-29 14:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio Grosso 2011-11-01 14:46:54 UTC
Version:           2.4-snapshots (using Devel) 
OS:                Linux

Ubuntu 11.10 (Oneiric Ocelot) - Unity Shell
Kde 4.7.41
krita 2.4 beta 3 (throug ppa calligra neon-project)
Vbox 4.1.4 (Windows 7 as Host; Ubuntu is the guest)

Reproducible: Always

Steps to Reproduce:
- Open an image (e.g. a png);
- Filter > Adjust > Levels > change something in the values;
- Nothing occurs in the canvas even though the preview box is ticked;
- You are forced to hit Ok to apply your change to the image.

When you apply your change (by pressing ok) the Adjust effect is applied to the canvas

Actual Results:  
Preview doesn't work with 3 Adjust Filters

Expected Results:  
Preview should work with these 3 Filters

To recap, with these 3 filters their preview don't work: 
- Adjust > Levels;
- Adjust > Color Adjustments curves;
- Adjust > Brigthness, Contrast curves.
Comment 1 Ico_dY 2011-11-04 14:28:16 UTC
Same problem, here, with every filter (adjust, artistic, blur category etc. etc.) under Mint 10 (Ubuntu Maverick) with Krita compiled from git.
If I try to untick and tick again the box to force the preview refreshing, Krita quits abruptly showing the "Unable to start Dr. Konqi" error message.
Comment 2 Halla Rempt 2011-11-04 21:00:57 UTC
I also get lots of:

krita(8951)/krita (general) KisFilterMask::decorateRect: No filter configuration present 

messages, when using the levels filters. Sometimes, when toggling the show preview checkbox, I will after the first toggle see the preview. Toggling too quickly will crash Krita.
Comment 3 Sven Langkamp 2011-12-27 21:13:09 UTC
Still reproduceable? Works with all three filters here.
Comment 4 Ico_dY 2011-12-27 21:56:19 UTC
The three filters work for me too, but if I untick the preview box Krita continues to show the filtered version of the picture.
Comment 5 Sven Langkamp 2011-12-28 12:06:52 UTC
Git commit 16c00e70f79fae7c4cf5960b3f56380f65a85d56 by Sven Langkamp.
Committed on 28/12/2011 at 13:05.
Pushed by langkamp into branch 'master'.

fix hiding of filter preview

M  +4    -0    krita/ui/dialogs/kis_dlg_filter.cpp

http://commits.kde.org/calligra/16c00e70f79fae7c4cf5960b3f56380f65a85d56
Comment 6 Ico_dY 2011-12-28 15:54:41 UTC
Ok, the fix works but a new problem arose.

Sometimes (about 2/50 attempts) after moving 3 points on the filter curve, ticking/unticking/ticking again the preview box and applying the filter, a squared area of the picture in the left-up corner appears in "negative".
After undoing and reapplying the filter all works perfectly.
The problem afflicts the "brightness/contrast curve" filter and the "color adjustment curves" filter.
Comment 7 Sven Langkamp 2012-01-02 17:27:18 UTC
*** Bug 285552 has been marked as a duplicate of this bug. ***
Comment 8 Halla Rempt 2012-02-29 14:18:41 UTC
Hm, might be that my computer is too fast or my image too small, but I cannot reproduce that problem. I actually think that this bug is fixed; if there are issues with the previews themselves, we should make a new bug.