Bug 285448 - Web stream info displayed wrongly if it fails to play
Summary: Web stream info displayed wrongly if it fails to play
Status: RESOLVED DUPLICATE of bug 272243
Alias: None
Product: amarok
Classification: Unclassified
Component: Playback/Streams (show other bugs)
Version: 2.4.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-01 10:17 UTC by Marco Cimmino
Modified: 2011-11-02 11:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Before clicking last item is a web radio (179.30 KB, image/png)
2011-11-01 10:17 UTC, Marco Cimmino
Details
Last item info are overwritten! (174.56 KB, image/png)
2011-11-01 10:18 UTC, Marco Cimmino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Cimmino 2011-11-01 10:17:46 UTC
Created attachment 65108 [details]
Before clicking last item is a web radio

Version:           2.4.3 (using KDE 4.7.2) 
OS:                Linux

This is a nasty bug present since many versions, not sure how no one has fixed it yet.

Reproducible: Always

Steps to Reproduce:
1. add in the playlist some local mp3 AND one web radio stream
2. disconnect from internet
3. play one mp3
4. try to play the web stream


Actual Results:  
web stream fails to play (ofc) but the info in the playlist are overwritten taken from the previous mp3 played (see screenshot)

Expected Results:  
no info overwritten
Comment 1 Marco Cimmino 2011-11-01 10:18:38 UTC
Created attachment 65109 [details]
Last item info are overwritten!
Comment 2 Myriam Schweingruber 2011-11-01 13:29:48 UTC
You are aware that this is a display problem, no info is overwritten in a web stream, we couldn't even do that :)

Which phonon-backend are you using?
Comment 3 Marco Cimmino 2011-11-01 13:37:18 UTC
(In reply to comment #2)
> You are aware that this is a display problem, no info is overwritten in a web
> stream, we couldn't even do that :)
> 
> Which phonon-backend are you using?

I was obviously talking about Amarok playlist not the web stream, like the category where I filed the ticket.

Said this: I think I use GStreamer, at least this is the only one present under sound system
Comment 4 Myriam Schweingruber 2011-11-01 13:53:05 UTC
Could you please test with the phonon-backend-vlc as well?
All bug reports about streams go in the streams category.
Comment 5 Marco Cimmino 2011-11-01 14:02:40 UTC
(In reply to comment #4)
> Could you please test with the phonon-backend-vlc as well?

Got a nice Amarok crash while changing the backend, but this is an unrelated issue.
Seems I am not able to reproduce the issue with phonon-backend-vlc.
Comment 6 Myriam Schweingruber 2011-11-02 09:15:39 UTC
That's what I suspected, this is a problem with the Phonon backend. Now if you could also tell us which version of the backend you are using, that would be perfect.

*** This bug has been marked as a duplicate of bug 272243 ***
Comment 7 Marco Cimmino 2011-11-02 09:24:26 UTC
Phonon GStreamer backend v4.5.1
http://packages.ubuntu.com/oneiric/phonon-backend-gstreamer

Ubuntu seems using old version for some odd reason and try to cheat the package manager on the version too
4.7.0really4.5.1-1ubuntu3
Comment 8 Myriam Schweingruber 2011-11-02 09:48:22 UTC
There is no cheat, it is the KDE version it is shipped with. Also 4.5.1 is not that old :)
Comment 9 Marco Cimmino 2011-11-02 09:58:28 UTC
(In reply to comment #6)
> That's what I suspected, this is a problem with the Phonon backend. Now if you
> could also tell us which version of the backend you are using, that would be
> perfect.
> 
> *** This bug has been marked as a duplicate of bug 272243 ***


Actually I wanted to post it here :(

To not that my problem is a little different:
I DO get the info, those are just overwritten if I try to play the stream while
offline.
Not sure the two issues are related.
Comment 10 Myriam Schweingruber 2011-11-02 11:42:25 UTC
Well, since you can't reproduce ti with the vlc backend it is clearly related.