Bug 285167 - Ability to disable "Save to Sent Mail Folder" feature
Summary: Ability to disable "Save to Sent Mail Folder" feature
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: 4.7
Platform: FreeBSD Ports FreeBSD
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-28 12:46 UTC by Chuck Burns
Modified: 2013-01-01 22:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Burns 2011-10-28 12:46:24 UTC
Version:           4.7 (using KDE 4.7.2) 
OS:                FreeBSD

I would like to see the ability to disable the "Save sent message to the Sent Mail folder" because, on some IMAP connections, the server will automatically save them itself, which will result in duplicate messaged saved to the Sent Mail folder.  I am currently just not setting that folder, but would like to, because it's driving my OCD nuts.

Reproducible: Always

Steps to Reproduce:
Use gmail imap, set the Saved Mail folder to the correct imap folder, sent an email, look in "Sent Mail" now there are two copies of that sent email, one saved by gmail's servers, one saved by KMail

Actual Results:  
Duplicate emails present in the Sent Mail folder.

Expected Results:  
No duplicates.
Comment 1 Laurent Montel 2012-12-31 12:53:48 UTC
Git commit afc18b2a561e727ee19e9cf2ccac7c49667d6c31 by Montel Laurent.
Committed on 31/12/2012 at 13:53.
Pushed by mlaurent into branch 'master'.

Start to implement Bug 285167 - Ability to disable "Save to Sent Mail

Folder" feature

M  +1    -1    CMakeLists.txt
M  +6    -3    kmail/identitydialog.cpp
M  +1    -0    kmail/identitydialog.h

http://commits.kde.org/kdepim/afc18b2a561e727ee19e9cf2ccac7c49667d6c31
Comment 2 Laurent Montel 2012-12-31 12:57:03 UTC
Git commit 5ab5db10f1d28dc20595b81f9fa9738bd3a5e332 by Montel Laurent.
Committed on 31/12/2012 at 13:53.
Pushed by mlaurent into branch 'akregator_port'.

Start to implement Bug 285167 - Ability to disable "Save to Sent Mail

Folder" feature

M  +1    -1    CMakeLists.txt
M  +6    -3    kmail/identitydialog.cpp
M  +1    -0    kmail/identitydialog.h

http://commits.kde.org/kdepim/5ab5db10f1d28dc20595b81f9fa9738bd3a5e332
Comment 3 Laurent Montel 2013-01-01 22:20:27 UTC
Git commit 48632b4ad55e3fa5df22555fc73f2f299a3dc673 by Montel Laurent.
Committed on 01/01/2013 at 23:20.
Pushed by mlaurent into branch 'master'.

Fix Bug 285167 - Ability to disable "Save to Sent Mail Folder" feature

FIXED-IN: 4.11

M  +10   -1    kmail/kmcomposewin.cpp
M  +3    -1    messagecomposer/akonadisender.cpp
M  +7    -1    messagecomposer/composerviewbase.cpp
M  +10   -1    messagecomposer/messagefactory.cpp
M  +7    -0    messagecomposer/messagehelper.cpp
M  +1    -0    messagecore/stringutil.cpp

http://commits.kde.org/kdepim/48632b4ad55e3fa5df22555fc73f2f299a3dc673