Bug 285147 - crash when opening a zipped file
Summary: crash when opening a zipped file
Status: RESOLVED DUPLICATE of bug 265945
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-28 03:37 UTC by Sergey
Modified: 2011-11-06 17:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2011-10-28 03:37:17 UTC
Application: dolphin (1.6)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.7-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
open archive file
- Custom settings of the application:
2 panel in "column" mode of view
in settings chek "open archives as folders"

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5987710 (LWP 12759))]

Thread 2 (Thread 0xaff9cb70 (LWP 12760)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb617bffe in poll () from /lib/libc.so.6
#2  0xb5c010bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5bf0c46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5bf0fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6f70797 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6f4129d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6f414c9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6e427b9 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb6f2121d in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6e453aa in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6dc9b05 in start_thread () from /lib/libpthread.so.0
#12 0xb6186d1e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5987710 (LWP 12759)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb69ebd51 in ?? () from /usr/lib/libQtGui.so.4
#9  0xb69f08e4 in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#10 0xb6a3d874 in QTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#11 0xb2417d5d in DolphinTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libdolphinprivate.so.4
#12 0xb64a95b0 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#13 0xb68b7ed5 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#14 0xb69498a1 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb69edad4 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb6a391f6 in QTreeView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb694c196 in ?? () from /usr/lib/libQtGui.so.4
#18 0xb6f42156 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb644e3e4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb6457c20 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb759c1f1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb6f41fbe in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb644f45c in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#24 0xb64db030 in ?? () from /usr/lib/libQtGui.so.4
#25 0xb64da13e in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb6504960 in ?? () from /usr/lib/libQtGui.so.4
#27 0xb5bf0509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0xb5bf0d10 in ?? () from /lib/libglib-2.0.so.0
#29 0xb5bf0fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#30 0xb6f7074b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb650455a in ?? () from /usr/lib/libQtGui.so.4
#32 0xb6f4129d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0xb6f414c9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0xb6f45f70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#35 0xb644c104 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#36 0xb259384d in kdemain () from /usr/lib/libkdeinit4_dolphin.so
#37 0x0804e531 in _start ()

Possible duplicates by query: bug 282914, bug 276219, bug 274759, bug 268488.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2011-11-06 17:44:26 UTC
Thanks for the bug report! This crash has been reported already.

*** This bug has been marked as a duplicate of bug 265945 ***