Bug 285117 - Akonadi Google Mail resource crasged
Summary: Akonadi Google Mail resource crasged
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
: 288422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-27 18:19 UTC by Vit Pelcak
Modified: 2012-01-05 11:31 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vit Pelcak 2011-10-27 18:19:14 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I configured Google Mail resource for Akonadi (maybe I had that configuration window opened twice and thus configuring same resource twisce as well, I'm not sure). Upon confirming selected settings, it crashed.

-- Backtrace:
Application: Google Mail of type E-mailový IMAP server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbe9ac76780 (LWP 12669))]

Thread 4 (Thread 0x7fbe878c7700 (LWP 17733)):
#0  0x00007fbe966a6773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe94ff8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe94ff9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe9a0ecf3e in QEventDispatcherGlib::processEvents (this=0xce5e40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbe9a0c0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe9a0c0ef7 in QEventLoop::exec (this=0x7fbe878c6dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbe99fd827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fbe9a0a3cbf in QInotifyFileSystemWatcherEngine::run (this=0xce5070) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbe99fdad05 in QThreadPrivate::start (arg=0xce5070) at thread/qthread_unix.cpp:331
#9  0x00007fbe95f61efc in start_thread (arg=0x7fbe878c7700) at pthread_create.c:304
#10 0x00007fbe966b289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fbe7fbf5700 (LWP 17757)):
#0  0x00007fbe966a6773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe94ff8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe94ff9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe9a0ecf3e in QEventDispatcherGlib::processEvents (this=0x1267be0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbe9a0c0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe9a0c0ef7 in QEventLoop::exec (this=0x7fbe7fbf4de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbe99fd827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fbe98d00c13 in KIMAP::SessionThread::run (this=0xd30350) at ../../kimap/sessionthread.cpp:169
#8  0x00007fbe99fdad05 in QThreadPrivate::start (arg=0xd30350) at thread/qthread_unix.cpp:331
#9  0x00007fbe95f61efc in start_thread (arg=0x7fbe7fbf5700) at pthread_create.c:304
#10 0x00007fbe966b289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbe84b5e700 (LWP 17758)):
#0  0x00007fbe966a6773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe94ff8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe94ff9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe9a0ecf3e in QEventDispatcherGlib::processEvents (this=0xb53c40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbe9a0c0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe9a0c0ef7 in QEventLoop::exec (this=0x7fbe84b5dde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbe99fd827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fbe98d00c13 in KIMAP::SessionThread::run (this=0xd54d80) at ../../kimap/sessionthread.cpp:169
#8  0x00007fbe99fdad05 in QThreadPrivate::start (arg=0xd54d80) at thread/qthread_unix.cpp:331
#9  0x00007fbe95f61efc in start_thread (arg=0x7fbe84b5e700) at pthread_create.c:304
#10 0x00007fbe966b289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbe9ac76780 (LWP 12669)):
[KCrash Handler]
#6  KIMAP::Session::state (this=0x0) at ../../kimap/session.cpp:93
#7  0x000000000045392e in SessionPool::killSession (this=0xad77e0, session=0x0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:181
#8  0x00000000004547bb in SessionPool::cancelSessionCreation (this=0xad77e0, session=0x0, errorCode=2, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:226
#9  0x0000000000454ca4 in SessionPool::onPasswordRequestDone (this=0xad77e0, resultType=<optimized out>, password=...) at ../../../resources/imap/sessionpool.cpp:283
#10 0x000000000045621a in SessionPool::qt_metacall (this=0xad77e0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x7fffdaf301d0) at ./sessionpool.moc:117
#11 0x00007fbe9a0d4eba in QMetaObject::activate (sender=0xafe720, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdaf301d0) at kernel/qobject.cpp:3278
#12 0x0000000000441cd1 in PasswordRequesterInterface::done (this=<optimized out>, _t1=1, _t2=<optimized out>) at ./passwordrequesterinterface.moc:104
#13 0x000000000042083b in SettingsPasswordRequester::askUserInput (this=0xafe720, serverError=...) at ../../../resources/imap/settingspasswordrequester.cpp:66
#14 0x0000000000420bcc in SettingsPasswordRequester::qt_metacall (this=0xafe720, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fbe80003670) at ./settingspasswordrequester.moc:75
#15 0x00007fbe9a0d8a5e in QObject::event (this=0xafe720, e=<optimized out>) at kernel/qobject.cpp:1217
#16 0x00007fbe99472424 in notify_helper (e=0x7fbe80003230, receiver=0xafe720, this=0x91f490) at kernel/qapplication.cpp:4486
#17 QApplicationPrivate::notify_helper (this=0x91f490, receiver=0xafe720, e=0x7fbe80003230) at kernel/qapplication.cpp:4458
#18 0x00007fbe99477291 in QApplication::notify (this=0x7fffdaf30c10, receiver=0xafe720, e=0x7fbe80003230) at kernel/qapplication.cpp:4365
#19 0x00007fbe9758e126 in KApplication::notify (this=0x7fffdaf30c10, receiver=0xafe720, event=0x7fbe80003230) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007fbe9a0c1afc in QCoreApplication::notifyInternal (this=0x7fffdaf30c10, receiver=0xafe720, event=0x7fbe80003230) at kernel/qcoreapplication.cpp:787
#21 0x00007fbe9a0c551f in sendEvent (event=0x7fbe80003230, receiver=0xafe720) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8fb800) at kernel/qcoreapplication.cpp:1428
#23 0x00007fbe9a0eca73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007fbe94ff8a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fbe94ff9258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fbe94ff9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fbe9a0eced6 in QEventDispatcherGlib::processEvents (this=0x8fd210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007fbe9951a07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007fbe9a0c0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fbe9a0c0ef7 in QEventLoop::exec (this=0x7fffdaf30b90, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007fbe9a0c5789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#33 0x00007fbe9a7b5546 in Akonadi::ResourceBase::init (r=0xac35e0) at ../../akonadi/resourcebase.cpp:393
#34 0x000000000041a716 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#35 0x00007fbe965f230d in __libc_start_main (main=0x415050 <main(int, char**)>, argc=3, ubp_av=0x7fffdaf30d28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffdaf30d18) at libc-start.c:226
#36 0x0000000000415205 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-07 17:09:32 UTC
*** Bug 288422 has been marked as a duplicate of this bug. ***
Comment 2 David Faure 2012-01-05 11:31:30 UTC

*** This bug has been marked as a duplicate of bug 288268 ***