Bug 285039 - all nepomuk tags have disappeared, now there are just blank undelteable ones
Summary: all nepomuk tags have disappeared, now there are just blank undelteable ones
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-26 19:50 UTC by Jonathan Marten
Modified: 2013-01-25 11:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Tag list in KAddressBook (9.15 KB, image/png)
2011-10-26 19:56 UTC, Jonathan Marten
Details
KAddressBook categories after using above dialogue (3.87 KB, image/png)
2011-10-26 19:56 UTC, Jonathan Marten
Details
Tags list in Konqueror file properties (39.06 KB, image/png)
2011-10-26 19:57 UTC, Jonathan Marten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Marten 2011-10-26 19:50:57 UTC
Version:           unspecified (using Devel) 
OS:                Linux

This problem is showing up for me mainly in kaddressbook, but is also visible in kmail and konqueror.  Therefore I am assuming that it is a problem in Nepomuk rather than in those applications.

Some time ago (about 2-3 months I think), I had about a dozen tags defined in KAddressBook used for annotating contacts.  I was not using message tags in KMail2 nor file tags anywhere else.

At some time since then, all of those tags seem to have disappeared.  KAddressBook now shows blank "Categories", attempting to edit them shows a dialogue with a long list of blank but checked tags.  See the attached screenshot 1.

Trying to delete any of those blank tags (by hovering to the right and clicking the red "X") displays the confirmation

  Should the tag "" really be deleted for all files?

Confirming this with "Delete" does not remove any of the blank tags from the list.

Clicking "OK" in this dialogue, even if no changes have been made, displays a truncated nepomuk: URL in the categories.  See screenshot 2.  Going back to the categories list after this has happened shows many more - the list expands every time this dialogue is opened and OK'ed.

Viewing a file's tags with Konqueror (right click - Properties - Information - Add Tags) shows about the same number of tags as there are blank entries in KAddressBook, but unchecked and showing Nepomuk URLs.  See screenshot 3.


Reproducible: Sometimes

Steps to Reproduce:
Not sure whether this is reproducible, but it happens for me.


Actual Results:  
My previously used tags have disappeared, and meaningless blank ones are reproducing.


Expected Results:  
Tags as previously defined, and only those, should be shown.
Comment 1 Jonathan Marten 2011-10-26 19:56:24 UTC
Created attachment 64906 [details]
Tag list in KAddressBook
Comment 2 Jonathan Marten 2011-10-26 19:56:58 UTC
Created attachment 64907 [details]
KAddressBook categories after using above dialogue
Comment 3 Jonathan Marten 2011-10-26 19:57:31 UTC
Created attachment 64908 [details]
Tags list in Konqueror file properties
Comment 4 Torsten Grote 2012-01-10 00:20:37 UTC
I've got the exact same problem.
Comment 5 Vishesh Handa 2013-01-25 11:04:16 UTC
This was a problem with the underlying dbus model. Or at least it seems to have disappeared once the Dbus model was removed.

I need someone to confirm this has been fixed with KDE 4.9 or greater. Preferably 4.10 RC3. 

I'm marking this as FIXED. Please reopen if you still encounter this bug.