Bug 285016 - bugs.kde.org announces an IPv6 address but does not respond to it
Summary: bugs.kde.org announces an IPv6 address but does not respond to it
Status: RESOLVED NOT A BUG
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: FreeBSD Ports FreeBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-26 15:04 UTC by Martin
Modified: 2011-10-29 16:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2011-10-26 15:04:16 UTC
Version:           unspecified (using KDE 4.7.2) 
OS:                FreeBSD

The web site bugs.kde.org announces an IPv6 address but does not respond when requests are directed to it. Only the IPv4 address works.

Reproducible: Always

Steps to Reproduce:
Try to perform any action on the KDE bug database - access via the IPv6 address results in a timeout, whereas access via the IPv4 address poses no problems.

Actual Results:  
Timeout when using the IPv6 address of bugs.kde.org

Expected Results:  
Normal operation and responses from bugs.kde.org when accessing via IPv6.

[0]# nslookup -type=any bugs.kde.org
Server:         192.168.1.5
Address:        192.168.1.5#53

Non-authoritative answer:
Name:   bugs.kde.org
Address: 89.248.108.132
bugs.kde.org    has AAAA address 2a00:1380:719::132

Authoritative answers can be found from:
kde.org nameserver = a.ns.bytemark.co.uk.
kde.org nameserver = b.ns.bytemark.co.uk.
kde.org nameserver = ns2.kde.org.
a.ns.bytemark.co.uk     internet address = 80.68.80.26
b.ns.bytemark.co.uk     internet address = 85.17.170.78

[0]#
Comment 1 Ben Cooksley 2011-10-26 18:43:35 UTC
You need to check your IPv6 connection, bugs.kde.org is listening correctly on both IPv4 and IPv6.

root@cano:~# wget https://bugs.kde.org/
--2011-10-26 19:41:17--  https://bugs.kde.org/
Resolving bugs.kde.org... 2a00:1380:719::132, 89.248.108.132
Connecting to bugs.kde.org|2a00:1380:719::132|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `index.html'

    [ <=>                   ] 10,491      --.-K/s   in 0.02s   

2011-10-26 19:41:18 (415 KB/s) - `index.html' saved [10491]

root@cano:~# wget http://bugs.kde.org/
--2011-10-26 19:41:29--  http://bugs.kde.org/
Resolving bugs.kde.org... 2a00:1380:719::132, 89.248.108.132
Connecting to bugs.kde.org|2a00:1380:719::132|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://bugs.kde.org/ [following]
--2011-10-26 19:41:29--  https://bugs.kde.org/
Connecting to bugs.kde.org|2a00:1380:719::132|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `index.html.1'

    [ <=>                      ] 10,491      --.-K/s   in 0.03s   

2011-10-26 19:41:30 (342 KB/s) - `index.html.1' saved [10491]
Comment 2 Martin 2011-10-26 20:13:33 UTC
Hmmm... I am trying to connect from a 6to4 address, 2002:bc17:23dd:1::5. I am able to successfully connect to www.linux-ipv6.org via https and IPv6, and other sites also work.

I am fully aware that the problem could be on my end of the provider chain, but could you please double-check that you do not accidentally filter the 2002:: range?
Comment 3 Martin 2011-10-26 20:20:08 UTC
By the way, with mtr I get the following:

mtr -6 2a00:1380:719::132

                             My traceroute  [v0.81]
gandalf.xyzzy (::)                                     Wed Oct 26 22:17:16 2011
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                       Packets               Pings
 Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. ???
 2. c49-1.ix2.ffm.de.as39912.net      0.0%     2   27.0  65.9  27.0 104.9  55.1
 3. c76-3.ix1.vie.at.as39912.net      0.0%     2   40.3  42.0  40.3  43.7   2.4
 4. ???

mtr bugs.kde.org

                             My traceroute  [v0.81]
gandalf.xyzzy (0.0.0.0)                                Wed Oct 26 22:17:53 2011
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                       Packets               Pings
 Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. 62.47.95.239                      0.0%     3    7.3   9.2   7.3  12.8   3.1
 2. ???
 3. 195.3.118.165                     0.0%     2   51.2  29.4   7.7  51.2  30.8
 4. 195.3.70.198                      0.0%     2   14.1  14.5  14.1  14.8   0.5
 5. vix1.interoute.net                0.0%     2    8.1  10.3   8.1  12.5   3.1
 6. ae0-0.vie-per-score-2-re1.intero  0.0%     2   45.1  63.0  45.1  80.8  25.3
 7. ae2-0.mil-cal-score-1-re0.intero  0.0%     2   45.1  53.4  45.1  61.6  11.7
 8. ae0-0.mil-cal-score-2-re0.intero  0.0%     2   45.4  44.4  43.4  45.4   1.4
 9. ae1-0.mad-001-score-2-re1.intero  0.0%     2   46.9  46.7  46.4  46.9   0.4
10. ae0-0.mad-001-score-1-re1.intero  0.0%     2   63.2  56.1  48.9  63.2  10.1
11. 89.202.159.66                     0.0%     2   47.7  52.1  47.7  56.4   6.2
12. ???
13. bugs.kde.org                      0.0%     2   47.2  49.7  47.2  52.1   3.5
Comment 4 Ben Cooksley 2011-10-27 10:28:03 UTC
I can confirm that we do not block IPv6 requests from the 2002::/16. Various traceroutes to your address from multiple IPv6 enabled systems result in no response.

Based on your IPv6 address, your IPv4 address should be 62.47.95.239.

If you could allow your system to reply on it's IPv4 and IPv6 addresses, that would be very helpful.
Comment 5 Martin 2011-10-28 13:11:17 UTC
For the next few hours, I have IPv4 91.113.12.235 and IPv6 2002:5b71:ceb:1::5

The firewall is configured to accept and respond to ICMP and ICMPv6 echo requests and replies.

I'd appreciate if you could test this.

Thank you.
Comment 6 Martin 2011-10-28 13:22:18 UTC
You are quick... I see ICMP from gslb0[12].cnlb.cn.mozilla.com., but no ICMPv6

Just for your information, I always have to wait for my squid proxy to time out on the connection attempt to bugs.kde.org via IPv6, and then fall back to trying the IPv4 address (which will stay preferred for a few seconds - seems to be some squid setting).
Comment 7 Martin 2011-10-28 13:51:03 UTC
One more comment, youtube has IPv6 addresses for some (many/all?) of its cache servers. My squid prefers those over IPv4 (even if internally here, the request comes in via IPv4).

Example acces.log line:

1318524692.391  97075 fec0::4d42:c8a1:7f61:f8f9:eea3 TCP_MISS/200 6260583 GET http://o-o.preferred.fra02s07.v17.lscache8.c.youtube.com/videoplayback? - DIRECT/2a00:1450:4001:5::d video/x-flv

mtr -6 to 2a00:1450:4001:5::d

                             My traceroute  [v0.81]
gandalf.xyzzy (::)                                     Fri Oct 28 15:49:22 2011
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                       Packets               Pings
 Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. ???
 2. de-cix10.net.google.com           0.0%    10   82.9  60.9  40.1  82.9  15.5
 3. 2001:4860::1:0:10                 0.0%    10   23.6  37.5  22.7 107.1  27.2
 4. 2001:4860::3:0:380                0.0%    10   22.9  23.8  22.7  25.2   0.8
 5. 2001:4860:0:1::23f                0.0%    10   84.0  41.4  23.3  84.0  21.0
 6. 2a00:1450:4001:5::d               0.0%     9   49.0  42.2  36.5  49.0   3.3
Comment 8 Ben Cooksley 2011-10-28 21:46:57 UTC
The traffic from the Mozilla server wasn't from me. My traffic would have come from servers whose ip's reserved to *.kde.org.

In any case, pinging your IPv4 address worked fine. But your IPv6 address never replied to any pings. I tried from multiple KDE servers, and all unfortunately failed.
Comment 9 Martin 2011-10-29 13:30:18 UTC
By now I am nearly certain that the problem is some bad IPv6 routing. Compare the following traces for quickgit.kde.org (announces two IPv6 addresses) and again bugs.kde.org (announces one IPv6 address):

[0]# nslookup -type=any quickgit.kde.org
Server:         192.168.1.5
Address:        192.168.1.5#53

Non-authoritative answer:
Name:   quickgit.kde.org
Address: 138.246.255.177
Name:   quickgit.kde.org
Address: 46.4.199.72
quickgit.kde.org        has AAAA address 2a01:4f8:130:4ffd:1:cae:dee:ee02
quickgit.kde.org        has AAAA address 2001:4ca0:100::10:177

Authoritative answers can be found from:
kde.org nameserver = a.ns.bytemark.co.uk.
kde.org nameserver = b.ns.bytemark.co.uk.
kde.org nameserver = ns2.kde.org.
b.ns.bytemark.co.uk     internet address = 85.17.170.78
a.ns.bytemark.co.uk     internet address = 80.68.80.26

[0]# 

                             My traceroute  [v0.81]
gandalf.xyzzy (::)                                     Sat Oct 29 15:27:05 2011
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                       Packets               Pings
 Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. ???
 2. Tenge1-2-56.cr2.NBG2.content-cor  0.0%    11   26.8  30.8  25.2  56.9  10.7
 3. ???
 4. hos-bb2.juniper2.rz10.hetzner.de  0.0%    11   61.0  65.7  56.8  72.7   5.1
 5. 2a01:4f8:0:13:3:a:13:4            0.0%    11   48.9  58.0  46.1  94.7  18.2
 6. 2a01:4f8:130:4341::2              0.0%    11   62.4  52.7  46.4  67.6   7.8
 7. 2a01:4f8:130:4ffd:1:cae:dee:ee02  0.0%    10   46.1  58.4  45.5 125.0  25.9

                             My traceroute  [v0.81]
gandalf.xyzzy (::)                                     Sat Oct 29 15:27:37 2011
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                       Packets               Pings
 Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. ???
 2. zr-fra1-be1.x-win.dfn.de          0.0%    11   27.2  27.3  22.2  54.2   9.1
 3. xr-gar1-te2-2.x-win.dfn.de        0.0%    10   33.0  44.5  31.4  86.1  16.8
 4. kr-lrz.x-win.dfn.de              10.0%    10   32.1  38.5  31.1  69.5  13.3
 5. vl-3066.vss1-2wr.lrz.de           0.0%    10   32.0  45.3  31.1  95.3  19.2
 6. immanuel.kde.org                  0.0%    10   31.1  32.6  30.1  41.6   3.5

[0]# nslookup -type=any bugs.kde.org    
Server:         192.168.1.5
Address:        192.168.1.5#53

Non-authoritative answer:
Name:   bugs.kde.org
Address: 89.248.108.132
bugs.kde.org    has AAAA address 2a00:1380:719::132

Authoritative answers can be found from:
kde.org nameserver = b.ns.bytemark.co.uk.
kde.org nameserver = ns2.kde.org.
kde.org nameserver = a.ns.bytemark.co.uk.
b.ns.bytemark.co.uk     internet address = 85.17.170.78
a.ns.bytemark.co.uk     internet address = 80.68.80.26

[0]# 

                             My traceroute  [v0.81]
gandalf.xyzzy (::)                                     Sat Oct 29 15:28:47 2011
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                       Packets               Pings
 Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. 2002:c058:6301::                 88.9%    10   23.1  23.1  23.1  23.1   0.0
 2. c49-1.ix2.ffm.de.as39912.net      0.0%    10   24.4  60.1  22.9 194.1  65.9
 3. c76-3.ix1.vie.at.as39912.net      0.0%    10   38.6  41.6  38.0  59.8   7.1
 4. ???
Comment 10 Martin 2011-10-29 16:17:06 UTC
Please close this report. While I still have the problem, it does not seem caused by KDE.org. I have used http://www.sixxs.net/tools/traceroute/ and they show that everything is o.k. with bugs.kde.org. Furthermore, there is at least one other address which I found accidentally which also does not work from here (bird.network.cz).

It seems that there are issues with the 6to4 gateway of my provider.