Bug 284606 - Email folders get corrupt on slow connections
Summary: Email folders get corrupt on slow connections
Status: RESOLVED DUPLICATE of bug 289097
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: Git (master)
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-21 10:15 UTC by Emil Sedgh
Modified: 2012-02-02 20:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Describes the bug. (254.41 KB, image/png)
2011-10-21 10:17 UTC, Emil Sedgh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Sedgh 2011-10-21 10:15:11 UTC
Version:           Git (master) (using Devel) 
OS:                Linux

Im using kmail with a slow connection.
Some times, when i want to view emails on a folder, it starts fetching data, but, it gets stuck there. (due to slow connection)

From then, that folder becomes corrupt. kmail forgets about all previous emails on that folder and the folder icon stays as 'loading' forever.

Restarting kmail/akonadi doesnt help. Last time it happened I had to remove my imap account and add a new one.

Reproducible: Sometimes

Steps to Reproduce:
Use kmail for a month using a slow connection.

Actual Results:  
kmail forgets about previous emails on a folder.

Expected Results:  
It shouldnt forget any email.

I think I can describe what happens on the attached screenshot easier.

The 'Maintainance' and 'inbox' folders on my folders list has become corrupt. This means:

1) They have the 'loading' icon forever. The moment i open kmail, they have that loading icon.

2) They forgot all emails 'prior' their coruption. This means, my inbox was working fine. But at some point, the issue came up. From that point, it only shows emails from then.

(You can see that my inbox is supposed to have 3280 emails, but its only showing one)

Im available on #kde-devel for any more info.
Comment 1 Emil Sedgh 2011-10-21 10:17:49 UTC
Created attachment 64748 [details]
Describes the bug.
Comment 2 András Manţia 2011-12-06 15:52:31 UTC
This is IMAP right, not POP3.
Comment 3 Emil Sedgh 2011-12-06 16:58:48 UTC
Right.
Comment 4 Emil Sedgh 2011-12-18 08:17:54 UTC
I updated kdepim.

The bug is still there. However, instead of trying to load it forever, after a minute kmail throws this error:

"Unknown error. (Unable to fetch item from backend)"
Comment 5 Emil Sedgh 2012-02-02 20:45:34 UTC

*** This bug has been marked as a duplicate of bug 289097 ***