Bug 284400 - Kwin passing a focus to the window before close it.
Summary: Kwin passing a focus to the window before close it.
Status: RESOLVED DUPLICATE of bug 158262
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-18 18:38 UTC by Alexander
Modified: 2011-10-18 19:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2011-10-18 18:38:18 UTC
Version:           unspecified (using KDE 4.7.2) 
OS:                Linux

When I working with one window and trying to close some other, that hasn't focus, kwin passes focus to this one before close it, so window appears on top before closing. For me the problem is in heavy flickering that described behavior causes when I working with many windows.

Reproducible: Didn't try

Steps to Reproduce:
Open two window and try to close one, that hasnt focus (I like to do it by clicking the middle mouse button under taskbar item)

Actual Results:  
Window that hadn't a focus will give it and appears on top before closing.

Expected Results:  
Window should just be closed, without passing a focus to it.
Comment 1 Alexander 2011-10-18 18:40:08 UTC
Oops, sorry
"Window that hadn't a focus _got_ it"
Comment 2 Thomas Lübking 2011-10-18 19:07:16 UTC

*** This bug has been marked as a duplicate of bug 158262 ***