Bug 284391 - B&W tool doesn't work in Batch Queue Manager
Summary: B&W tool doesn't work in Batch Queue Manager
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Bqm-BlackWhite (show other bugs)
Version: 2.2.0
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-18 17:32 UTC by Frédéric COIFFIER
Modified: 2021-12-29 14:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric COIFFIER 2011-10-18 17:32:58 UTC
Version:           2.2.0 (using KDE 4.7.2) 
OS:                Linux

When the B&W effect is added in the Batch Queue Manager, the generated image is black.

Reproducible: Always

Steps to Reproduce:
1. Select some photos
2. Open the Batch Queue Manager
3. Add the B&W effect in the Assigned tools list
4. Click on Run

Actual Results:  
Generated photos are black.

Expected Results:  
Get B&W photos.
Comment 1 Andi Clemens 2011-10-18 18:24:18 UTC
Yes, I can confirm this. I will take a look at the issue.
Comment 2 caulier.gilles 2011-10-18 20:23:18 UTC
Andi,

I already take a look where is the problem. 

In fact B&W tool work fine until you don't touch Curves settings. It's due to a wrong translation between 8<->16bits curves api introduced with versionning feature. BQM don't care about versionning, but implementation is wrong as well. It's a side effect.

There is already a report about this problem here :

https://bugs.kde.org/show_bug.cgi?id=281095#c2

Gilles Caulier
Comment 3 Andi Clemens 2011-10-18 20:34:30 UTC
Ok... it seems to work better somehow when not using linear curves.
Comment 4 caulier.gilles 2011-10-19 05:03:40 UTC
Note : the same dysfunction appear in Curves tool from BQM. You confirm ?

Gilles
Comment 5 Andi Clemens 2011-10-20 08:09:13 UTC
Yes, it seems to work in the first place, but when you change the curve type to "free", it is broken. Changing the type back to "linear" doesn't seem to help.
Comment 6 Marcel Wiesweg 2011-11-05 13:40:59 UTC
seems to be a full duplicate... let's continue in the older report

*** This bug has been marked as a duplicate of bug 281095 ***
Comment 7 caulier.gilles 2021-12-29 14:03:09 UTC
Fixed with #281095