Bug 284180 - Crashed while installing many programs
Summary: Crashed while installing many programs
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-16 13:06 UTC by Reece
Modified: 2011-10-22 23:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reece 2011-10-16 13:06:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Had just entered password and enter

- Unusual behavior I noticed: crash occured and Crash reports popped up.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f44e98e3780 (LWP 21902))]

Thread 2 (Thread 0x7f44d51ef700 (LWP 21903)):
#0  0x00007fff375ff92c in clock_gettime ()
#1  0x00007f44e2fe007b in __GI_clock_gettime (clock_id=1, tp=0x7f44d51eeb40) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f44e85b1074 in do_gettime (frac=0x7f44d51eeb58, sec=0x7f44d51eeb50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f44e86736ed in QTimerInfoList::updateCurrentTime (this=0x206a6e0) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f44e8673a33 in QTimerInfoList::timerWait (this=0x206a6e0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007f44e867244c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f44d51eec3c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f44e86724f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f44e2d29ff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f44e2d2adfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f44e2d2b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f44e8672f3e in QEventDispatcherGlib::processEvents (this=0x1ed8fd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007f44e8646cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f44e8646ef7 in QEventLoop::exec (this=0x7f44d51eedd0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007f44e855e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007f44e8629cbf in QInotifyFileSystemWatcherEngine::run (this=0x1e994c0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f44e8560d05 in QThreadPrivate::start (arg=0x1e994c0) at thread/qthread_unix.cpp:331
#17 0x00007f44e380cefc in start_thread (arg=0x7f44d51ef700) at pthread_create.c:304
#18 0x00007f44e64c189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f44e98e3780 (LWP 21902)):
[KCrash Handler]
#6  value (akey=..., this=0x2ce2c28) at /usr/include/qt4/QtCore/qhash.h:607
#7  Application::getField (this=0x2ce2c20, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#8  0x000000000041d0dd in Application::untranslatedName (this=0x2ce2c20) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#9  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x20684f0, job=0x507f210) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x20684f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff374cd8a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00007f44e865aeba in QMetaObject::activate (sender=0x507f210, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff374cd8a0) at kernel/qobject.cpp:3278
#13 0x00007f44e78961d2 in KJob::result (this=<optimized out>, _t1=0x507f210) at ./kjob.moc:194
#14 0x00007f44e7896210 in KJob::emitResult (this=0x507f210) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007f44e90ecaea in KIO::FileCopyJob::slotResult (this=0x507f210, job=0x42283c0) at ../../kio/kio/job.cpp:2440
#16 0x00007f44e90ec890 in KIO::FileCopyJob::qt_metacall (this=0x507f210, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff374cda10) at ./jobclasses.moc:724
#17 0x00007f44e865aeba in QMetaObject::activate (sender=0x42283c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff374cda10) at kernel/qobject.cpp:3278
#18 0x00007f44e78961d2 in KJob::result (this=<optimized out>, _t1=0x42283c0) at ./kjob.moc:194
#19 0x00007f44e7896210 in KJob::emitResult (this=0x42283c0) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007f44e90e5364 in KIO::SimpleJob::slotFinished (this=0x42283c0) at ../../kio/kio/job.cpp:494
#21 0x00007f44e90ecd3d in KIO::TransferJob::slotFinished (this=0x42283c0) at ../../kio/kio/job.cpp:1081
#22 0x00007f44e90eb6a1 in KIO::TransferJob::qt_metacall (this=0x42283c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff374cddc0) at ./jobclasses.moc:369
#23 0x00007f44e865aeba in QMetaObject::activate (sender=0x27ecfd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007f44e9190f01 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007f44e918ddb5 in KIO::SlaveInterface::dispatch (this=0x27ecfd0) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007f44e9180f7e in KIO::Slave::gotInput (this=0x27ecfd0) at ../../kio/kio/slave.cpp:344
#27 0x00007f44e91816dc in KIO::Slave::qt_metacall (this=0x27ecfd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff374ce1f0) at ./slave.moc:82
#28 0x00007f44e865aeba in QMetaObject::activate (sender=0x4d33870, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007f44e90b6087 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0x4efbf30) at ../../kio/kio/connection.cpp:71
#31 0x00007f44e90b612d in KIO::Connection::qt_metacall (this=0x4d33870, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2d5d380) at ./connection.moc:79
#32 0x00007f44e865ea5e in QObject::event (this=0x4d33870, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007f44e6c82424 in notify_helper (e=0x2b60d20, receiver=0x4d33870, this=0x1d5fe90) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0x1d5fe90, receiver=0x4d33870, e=0x2b60d20) at kernel/qapplication.cpp:4458
#35 0x00007f44e6c87291 in QApplication::notify (this=0x7fff374ceaa0, receiver=0x4d33870, e=0x2b60d20) at kernel/qapplication.cpp:4365
#36 0x00007f44e7e661e6 in KApplication::notify (this=0x7fff374ceaa0, receiver=0x4d33870, event=0x2b60d20) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f44e8647afc in QCoreApplication::notifyInternal (this=0x7fff374ceaa0, receiver=0x4d33870, event=0x2b60d20) at kernel/qcoreapplication.cpp:787
#38 0x00007f44e864b51f in sendEvent (event=0x2b60d20, receiver=0x4d33870) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1d37be0) at kernel/qcoreapplication.cpp:1428
#40 0x00007f44e8672a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007f44e2d2aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f44e2d2b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f44e2d2b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f44e8672ed6 in QEventDispatcherGlib::processEvents (this=0x1d396f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007f44e6d2a07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f44e8646cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f44e8646ef7 in QEventLoop::exec (this=0x7fff374cea30, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007f44e864b789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#50 0x000000000041bd67 in main (argc=5, argv=0x7fff374ced18) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Jonathan Thomas 2011-10-22 23:16:43 UTC

*** This bug has been marked as a duplicate of bug 283728 ***