Bug 284146 - muon software center was closed after trying to open the installed application
Summary: muon software center was closed after trying to open the installed application
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
: 284499 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-16 02:43 UTC by Hector Jimenez
Modified: 2011-10-22 23:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector Jimenez 2011-10-16 02:43:23 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

finished installing the application and the message displays of the center of software, I click to run the application.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd653864780 (LWP 2360))]

Thread 2 (Thread 0x7fd63e215700 (LWP 2364)):
#0  0x00007fd650445773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd64ccbaf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd64ccbb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd652602f3e in QEventDispatcherGlib::processEvents (this=0x233f2c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd6525d6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd6525d6ef7 in QEventLoop::exec (this=0x7fd63e214dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd6524ee27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fd6525b9cbf in QInotifyFileSystemWatcherEngine::run (this=0x230e110) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd6524f0d05 in QThreadPrivate::start (arg=0x230e110) at thread/qthread_unix.cpp:331
#9  0x00007fd64d79cefc in start_thread (arg=0x7fd63e215700) at pthread_create.c:304
#10 0x00007fd65045189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd653864780 (LWP 2360)):
[KCrash Handler]
#6  QApt::Package::controlField (this=0x31, name=...) at /build/buildd/qapt-1.2.1/src/package.cpp:643
#7  0x000000000041d1ab in Application::untranslatedName (this=0x2da8630) at /build/buildd/muon-1.2.1/installer/Application.cpp:71
#8  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#9  0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x22d4030, job=0x3ce0d80) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#10 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x22d4030, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7dd4ca00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#11 0x00007fd6525eaeba in QMetaObject::activate (sender=0x3ce0d80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7dd4ca00) at kernel/qobject.cpp:3278
#12 0x00007fd6518261d2 in KJob::result (this=<optimized out>, _t1=0x3ce0d80) at ./kjob.moc:194
#13 0x00007fd651826210 in KJob::emitResult (this=0x3ce0d80) at ../../kdecore/jobs/kjob.cpp:312
#14 0x00007fd65307caea in KIO::FileCopyJob::slotResult (this=0x3ce0d80, job=0x3eb9290) at ../../kio/kio/job.cpp:2440
#15 0x00007fd65307c890 in KIO::FileCopyJob::qt_metacall (this=0x3ce0d80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7dd4cb70) at ./jobclasses.moc:724
#16 0x00007fd6525eaeba in QMetaObject::activate (sender=0x3eb9290, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7dd4cb70) at kernel/qobject.cpp:3278
#17 0x00007fd6518261d2 in KJob::result (this=<optimized out>, _t1=0x3eb9290) at ./kjob.moc:194
#18 0x00007fd651826210 in KJob::emitResult (this=0x3eb9290) at ../../kdecore/jobs/kjob.cpp:312
#19 0x00007fd653075364 in KIO::SimpleJob::slotFinished (this=0x3eb9290) at ../../kio/kio/job.cpp:494
#20 0x00007fd65307cd3d in KIO::TransferJob::slotFinished (this=0x3eb9290) at ../../kio/kio/job.cpp:1081
#21 0x00007fd65307b6a1 in KIO::TransferJob::qt_metacall (this=0x3eb9290, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7dd4cf20) at ./jobclasses.moc:369
#22 0x00007fd6525eaeba in QMetaObject::activate (sender=0x3e46d10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#23 0x00007fd653120f01 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#24 0x00007fd65311ddb5 in KIO::SlaveInterface::dispatch (this=0x3e46d10) at ../../kio/kio/slaveinterface.cpp:88
#25 0x00007fd653110f7e in KIO::Slave::gotInput (this=0x3e46d10) at ../../kio/kio/slave.cpp:344
#26 0x00007fd6531116dc in KIO::Slave::qt_metacall (this=0x3e46d10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7dd4d350) at ./slave.moc:82
#27 0x00007fd6525eaeba in QMetaObject::activate (sender=0x38c3020, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#28 0x00007fd653046087 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#29 KIO::ConnectionPrivate::dequeue (this=0x378d800) at ../../kio/kio/connection.cpp:71
#30 0x00007fd65304612d in KIO::Connection::qt_metacall (this=0x38c3020, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2c8a3d0) at ./connection.moc:79
#31 0x00007fd6525eea5e in QObject::event (this=0x38c3020, e=<optimized out>) at kernel/qobject.cpp:1217
#32 0x00007fd650c12424 in notify_helper (e=0x388e790, receiver=0x38c3020, this=0x20faaf0) at kernel/qapplication.cpp:4486
#33 QApplicationPrivate::notify_helper (this=0x20faaf0, receiver=0x38c3020, e=0x388e790) at kernel/qapplication.cpp:4458
#34 0x00007fd650c17291 in QApplication::notify (this=0x7fff7dd4dc00, receiver=0x38c3020, e=0x388e790) at kernel/qapplication.cpp:4365
#35 0x00007fd651df61e6 in KApplication::notify (this=0x7fff7dd4dc00, receiver=0x38c3020, event=0x388e790) at ../../kdeui/kernel/kapplication.cpp:311
#36 0x00007fd6525d7afc in QCoreApplication::notifyInternal (this=0x7fff7dd4dc00, receiver=0x38c3020, event=0x388e790) at kernel/qcoreapplication.cpp:787
#37 0x00007fd6525db51f in sendEvent (event=0x388e790, receiver=0x38c3020) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x20d0be0) at kernel/qcoreapplication.cpp:1428
#39 0x00007fd652602a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#40 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#41 0x00007fd64ccbaa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fd64ccbb258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fd64ccbb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007fd652602ed6 in QEventDispatcherGlib::processEvents (this=0x20d26f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#45 0x00007fd650cba07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007fd6525d6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007fd6525d6ef7 in QEventLoop::exec (this=0x7fff7dd4db90, flags=...) at kernel/qeventloop.cpp:201
#48 0x00007fd6525db789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#49 0x000000000041bd67 in main (argc=5, argv=0x7fff7dd4de78) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-10-19 20:44:53 UTC
*** Bug 284499 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Thomas 2011-10-22 23:16:47 UTC

*** This bug has been marked as a duplicate of bug 283728 ***