Bug 284018 - moving the position or the volume slider in Miro drags the window
Summary: moving the position or the volume slider in Miro drags the window
Status: CLOSED FIXED
Alias: None
Product: Oxygen
Classification: Plasma
Component: gtk2-engine (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-14 17:40 UTC by Antonio Rojas
Modified: 2011-10-15 09:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (15.47 KB, image/png)
2011-10-14 18:45 UTC, Antonio Rojas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2011-10-14 17:40:11 UTC
Version:           unspecified (using KDE 4.7.2) 
OS:                Linux

Trying to move the position slider or the volume slider in Miro drags the window, so it makes it very hard to change the volume or the position. 

Reproducible: Always

Steps to Reproduce:
Try to move the position slider or the volume slider in Miro

Actual Results:  
The window is dragged

Expected Results:  
the slider moves

oxygen-gtk 1.1.3
Comment 1 Hugo Pereira Da Costa 2011-10-14 18:38:22 UTC
Could you post a screenshot ? I'm not sure I understand which slider you refer to.
Thx,

Hugo
Comment 2 Antonio Rojas 2011-10-14 18:45:41 UTC
Created attachment 64525 [details]
Screenshot

These sliders (in the playback view)
Comment 3 Hugo Pereira Da Costa 2011-10-14 19:25:15 UTC
Git commit 7773ad606e7ea1871be9c7ff7b9111930aeb99d2 by Hugo Pereira Da Costa.
Committed on 14/10/2011 at 21:22.
Pushed by hpereiradacosta into branch '1.1'.

explicitly blacklist gtkscale from window dragging due to (buggy) miro custom widgets.
CCBUG: 284018

M  +1    -0    src/oxygenwindowmanager.cpp

http://commits.kde.org/oxygen-gtk/7773ad606e7ea1871be9c7ff7b9111930aeb99d2
Comment 4 Hugo Pereira Da Costa 2011-10-14 19:27:59 UTC
ok. Comment #3 fixes it for the "seek" slider.
I did not test the volume slider, because my version of miro does not have it
(could you tell me which version you are using ?)
Anyway, could you double-check, while compiling oxygen-gtk from git, if this is also fixed for the volume control, and close the report if yes ?
Comment 5 Antonio Rojas 2011-10-14 19:43:13 UTC
They are both fixed, thanks. Miro version 4.0.3
Comment 6 Hugo Pereira Da Costa 2011-10-14 19:46:12 UTC
ahah. Thats why. I have 3.5.1