Bug 283984 - ODF: List styles - bullet font-size by percentage not retained.
Summary: ODF: List styles - bullet font-size by percentage not retained.
Status: RESOLVED FIXED
Alias: None
Product: calligrastage
Classification: Applications
Component: opendocument (show other bugs)
Version: SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: T Zachmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-14 12:09 UTC by Matus Uzak
Modified: 2011-10-19 19:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
ODP file produced by the pptx filter. (92.62 KB, application/vnd.oasis.opendocument.presentation)
2011-10-14 12:09 UTC, Matus Uzak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matus Uzak 2011-10-14 12:09:16 UTC
Created attachment 64516 [details]
ODP file produced by the pptx filter.

Version:           svn
OS:                Linux

Both the list on the 1st slide and the list on the 2nd slide refer to the same list-style, which defines fo:font-size="100%".  The font-size of the list item on the 1st slide and the 2nd slide is 28pt and 54pt respectively.  As a result the bullet on the 2nd slide should have font-size=54pt, but it's 28pt. Looks like the absolute font-size is not re-calculated.

Reproducible: Always

Steps to Reproduce:
1. Open the provided ODP file in stage.
2. Check the bullet size on the 2nd slide, which should follow the font-size of the list item.

Actual Results:  
Size of the bullet on the 2nd slide is the same as size of the bullet on the 1st slide, 28pt.


Expected Results:  
Size of the bullet on the 2nd slide equal to 54pt.
Comment 1 Gopalakrishna Bhat 2011-10-15 14:12:24 UTC
Fixed with b0e28e2bea2602296da608b5b3305d0af635910f
Comment 2 Matus Uzak 2011-10-19 19:01:28 UTC
Fixed!  Again a lot of positive changes after running cstester on pptx documents.