Bug 283956 - Upgrade Kubuntu 11.10 program frames distorted loose right buttons resizing
Summary: Upgrade Kubuntu 11.10 program frames distorted loose right buttons resizing
Status: RESOLVED DUPLICATE of bug 282882
Alias: None
Product: kwin
Classification: Plasma
Component: scene-opengl (show other bugs)
Version: 4.7.1
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-14 02:24 UTC by Mike
Modified: 2012-07-29 07:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
screen shot taken in KDE with "print screen" to show distortion (458.99 KB, image/png)
2011-10-14 02:24 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2011-10-14 02:24:27 UTC
Created attachment 64499 [details]
screen shot taken in KDE with "print screen" to show distortion

Version:           unspecified (using KDE 4.7.1) 
OS:                OS X

Fresh upgrade from Kubuntu 11.04 to 11.10 on 10/13.  Any open window when resized small the top and bottom bars stay larger.   The smaller the window is drawn the controls (resize close ) are clipped then are lost.  Bottom resize control is lost.  Will attempt to attach a picture to illustrate.

Reproducible: Always

Steps to Reproduce:
Open any program, resize program.  Full size distorts top bar clipping bottom.  Shrinking window causes body to be smaller while top and bottom bars are larger and the right side controls clip then are lost.

Actual Results:  
Simply shrink a window of any program running with the bottom right "handle".  The top and bottom bars break.

Expected Results:  
Same as any window reisze, frames stay in tact.

OS: Linux (i686) release 3.0.0-12-generic
Compiler: gcc

Kubuntu, distribution upgrade to this version released today to version 11.10
Comment 1 Martin Flöser 2012-07-29 07:14:17 UTC
This problem has been fixed in later versions. E.g. an upgrade to 12.04 should fix it.

Otherwise please have a look at the duplicate bug whether there is a hint on how to workaround the issue.

*** This bug has been marked as a duplicate of bug 282882 ***