Bug 283821 - kmail2 can't send reply to calendar event request
Summary: kmail2 can't send reply to calendar event request
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 25 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-11 19:45 UTC by Divan Santana
Modified: 2012-01-25 20:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Divan Santana 2011-10-11 19:45:43 UTC
Version:           unspecified (using KDE 4.7.1) 
OS:                Linux

Can't send a reply to any calendar invite.
In a nut shell, kmail2 replies to this address:
<"LastName, FirstName" <flastname@example.com>>

it should reply to this address(I think):
"LastName, FirstName" <flastname@example.com>

It's simply adding extra brackets.

I would think this would be a quick and easy bug to fix so hopefully it makes it for 4.7.3 and it's one less problem for kmail2.

Reproducible: Always

Steps to Reproduce:
- I receive a calendar event invite.
- I click accept or deny, kmail2 then tries to send an email reply.

Actual Results:  
- It however gets stuck in my outbox as the smtp relay server doesn't allow an invalid email address in the to field.
- Basically when I send an email to this address it can send but when replying from a calendar event kmail2 adds extra brackets <> as per below example.

Expected Results:  
It sends the reply to the email recipients succesfully.

I have the latest stable kmail 4.7.2.

If I send via davmail locally I can capture the log of the error.
Note this happens with any SMTP server, not just davmail. See below details.

Date:                   Tue Oct 11 09:58:55 SAST 2011 (1318319935277)
Thread:         SmtpConnection-45046
Message #:      1
Level:          ERROR
NDC:                    
Category:       davmail
Message:                Invalid recipient: RCPT TO:<"LastName, FirstName" 
<flastname@example.com>>
Location:       
davmail.ui.tray.DavGatewayTray.displayMessage(DavGatewayTray.java:113)
Thrown:
davmail.exception.DavMailException: Invalid recipient: RCPT TO:<"LastName, 
FirstName" <flastname@example.com>>
        at davmail.smtp.SmtpConnection.run(SmtpConnection.java:141)
Comment 1 Andreas Cord-Landwehr 2011-10-17 09:27:56 UTC
I can confirm this with the described actions and a google-calendar test account. The mail's source is the following:

-----------------

User-Agent: KOrganizer/4.7.2 (Linux/3.0.0-1-686-pae; KDE/4.7.2; i686; )
From: Andreas Cord-Landwehr <phoenixx@uni-paderborn.de>
To: Andreas Cord-Landwehr <cordlandwehr@googlemail.com>
Date: Mon, 17 Oct 2011 11:26:03 +0200
Subject: test
Content-Type: multipart/mixed; boundary="nextPart329715083.Vnb0BDxrmH"
MIME-Version: 1.0


--nextPart329715083.Vnb0BDxrmH
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable

Summary: test
Organizer: "Andreas Cord-Landwehr" <phoenixx@uni-paderborn.de>
Start Date: 17.10.2011

--nextPart329715083.Vnb0BDxrmH
Content-Type: text/calendar; charset="utf-8"; method="request"; name="cal.ics"
Content-Disposition: attachment
Content-Transfer-Encoding: quoted-printable

BEGIN:VCALENDAR
PRODID:-//K Desktop Environment//NONSGML libkcal 4.3//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VEVENT
CREATED:20111017T092603Z
ORGANIZER;CN=3D"Andreas Cord-Landwehr":MAILTO:phoenixx@uni-paderborn.de=

ATTENDEE;CN=3D"Andreas Cord-Landwehr";RSVP=3DTRUE;PARTSTAT=3DNEEDS-ACTI=
ON;
 ROLE=3DREQ-PARTICIPANT;X-UID=3DdpThvBJOCU:mailto:cordlandwehr@googlema=
il.com
DTSTAMP:20111017T092536Z
UID:cc8bfb94-8d11-46de-96b7-5f96142bff92
LAST-MODIFIED:20111017T092536Z
SUMMARY:test
DTSTART;VALUE=3DDATE:20111017
DTEND;VALUE=3DDATE:20111018
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR

--nextPart329715083.Vnb0BDxrmH--
Comment 2 aldebarab 2012-01-17 22:39:04 UTC
Hallo all
at first thanks for the great improvements in kde 4.7.4.

I use korganizer 4.7.3 in kde 4.7.4. If I create a new event with attendees I will get the same behaviour as described for kmail2: the recipients addresses are not accepted by davmail, because of the extra <> brackets around the mail addresses:

log from davmail:  

Category:	davmail
Message:		Invalid recipient: RCPT TO:<firstname christianname <firstname.christianname@domainname.de>>
Location:	davmail.ui.tray.DavGatewayTray.displayMessage(DavGatewayTray.java:113)
Thrown:
davmail.exception.DavMailException: Invalid recipient: RCPT TO:<firstname christianname<firstname.christianname@domainname.de>>
	at davmail.smtp.SmtpConnection.run(SmtpConnection.java:141)

It seems to be a bug in a library used by kmail2 and korganizer.

Maybe this helps to locate the bug.

Thank you all for your engaged work. KDE4 starts to become as good as kde 3.5.10 and will be better!
Comment 3 aldebarab 2012-01-19 19:22:04 UTC
This seems tobe related to Bug 284685
Comment 4 Laurent Montel 2012-01-20 10:35:18 UTC
Fixed in 4.8
Comment 5 Divan Santana 2012-01-20 15:34:21 UTC
Huge Thanks and Regards!! :)
Comment 6 aldebarab 2012-01-25 20:42:20 UTC
Wowh, quick fix. To check, I wait for kde 4.8.x to appear in debian experimental. No Time to compile myself and looking for "configure" errors.

I will resend confirmation.

Thanks a lot