Bug 283620 - plasma crashes at logout
Summary: plasma crashes at logout
Status: RESOLVED DUPLICATE of bug 284989
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-08 18:49 UTC by Alin M Elena
Modified: 2011-10-28 00:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2011-10-08 18:49:09 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) "release 1"
Qt Version: 4.8.0
Operating System: Linux 3.1.0-rc7-3-desktop x86_64
Distribution: "openSUSE 12.1 Beta 1 (x86_64)"

-- Information about the crash:
plasma crashes as I try to logout...

after it crashes... restarts... but with a different style... 
when I login again the correct style is on.. but the plasmoid are in wrong positions,

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff5d751d760 (LWP 6969))]

Thread 4 (Thread 0x7ff5b0d95700 (LWP 6977)):
#0  0x00007ff5d5db7014 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007ff5d18bfaf3 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff5d18c08cd in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff5d18c0ef9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007ff5d6177976 in QEventDispatcherGlib::processEvents (this=0x1371820, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007ff5d6147722 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ff5d6147977 in QEventLoop::exec (this=0x7ff5b0d94d30, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007ff5d60490b7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007ff5d61275ff in QInotifyFileSystemWatcherEngine::run (this=0x136d910) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007ff5d604c0db in QThreadPrivate::start (arg=0x136d910) at thread/qthread_unix.cpp:298
#10 0x00007ff5c694d2dc in ?? () from /usr/lib64/libGL.so.1
#11 0x00007ff5d5db4f05 in start_thread () from /lib64/libpthread.so.0
#12 0x00007ff5d4b1824d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ff5ad4e3700 (LWP 6984)):
#0  0x00007ff5d5db8e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff5ca1e7772 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7ff5ca4dfe80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007ff5ca1e77a9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007ff5c694d2dc in ?? () from /usr/lib64/libGL.so.1
#4  0x00007ff5d5db4f05 in start_thread () from /lib64/libpthread.so.0
#5  0x00007ff5d4b1824d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff59f255700 (LWP 7060)):
#0  0x00007fffe87fe8de in ?? ()
#1  0x00000000021fd42c in ?? ()
#2  0x0000000000000001 in ?? ()
#3  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff5d751d760 (LWP 6969)):
[KCrash Handler]
#6  0x00007ff5cc5c5f0c in qDeleteAll<QList<Plasma::Applet*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#7  qDeleteAll<QList<Plasma::Applet*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#8  ~ContainmentPrivate (this=0xb437a0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.43_20111007/plasma/private/containment_p.h:71
#9  Plasma::Containment::~Containment (this=0xa3a360, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.43_20111007/plasma/containment.cpp:160
#10 0x00007ff5bad6d449 in Panel::~Panel (this=0xa3a360, __in_chrg=<optimized out>) at /usr/src/debug/kde-workspace-4.7.43_20111007/plasma/desktop/containments/panel/panel.cpp:129
#11 0x00007ff5cc5d9017 in qDeleteAll<QList<Plasma::Containment*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#12 qDeleteAll<QList<Plasma::Containment*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#13 Plasma::CoronaPrivate::~CoronaPrivate (this=0x95c910, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.43_20111007/plasma/corona.cpp:805
#14 0x00007ff5cc5d9244 in Plasma::Corona::~Corona (this=0x954b80, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.43_20111007/plasma/corona.cpp:82
#15 0x00007ff5c23651c9 in DesktopCorona::~DesktopCorona (this=0x954b80, __in_chrg=<optimized out>) at /usr/src/debug/kde-workspace-4.7.43_20111007/plasma/desktop/shell/desktopcorona.cpp:73
#16 0x00007ff5c2386b56 in PlasmaApp::cleanup (this=0x729950) at /usr/src/debug/kde-workspace-4.7.43_20111007/plasma/desktop/shell/plasmaapp.cpp:381
#17 0x00007ff5c238b8ea in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0x729950, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.7.43_20111007/build/plasma/desktop/shell/plasmaapp.moc:120
#18 PlasmaApp::qt_static_metacall (_o=0x729950, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kde-workspace-4.7.43_20111007/build/plasma/desktop/shell/plasmaapp.moc:97
#19 0x00007ff5d615c7d1 in QMetaObject::activate (sender=0x729950, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3546
#20 0x00007ff5d614c525 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1153
#21 0x00007ff5c2370993 in kdemain (argc=1, argv=0x6b0180) at /usr/src/debug/kde-workspace-4.7.43_20111007/plasma/desktop/shell/main.cpp:120
#22 0x00000000004088a4 in _start ()

This bug may be a duplicate of or related to bug 282934.

Possible duplicates by query: bug 283119, bug 282934, bug 282269, bug 281903, bug 281557.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-28 00:01:58 UTC

*** This bug has been marked as a duplicate of bug 284989 ***