Bug 283586 - Search (CTRL+F) in mails has too big search dialog and standard shortcuts (F3 for next result) do not work
Summary: Search (CTRL+F) in mails has too big search dialog and standard shortcuts (F3...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 1.99.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-08 07:36 UTC by H.H.
Modified: 2017-01-07 22:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.3


Attachments
to big search dialog (29.74 KB, image/png)
2011-10-08 07:36 UTC, H.H.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description H.H. 2011-10-08 07:36:51 UTC
Created attachment 64332 [details]
to big search dialog

Version:           1.99.0 (using KDE 4.7.1) 
OS:                Linux

please look at the screenshot for the too big search dialog. I also expect to use the standard key F3 for next search result.

Reproducible: Always

Steps to Reproduce:
- open a mail you received
- open search dialog (with ctrl-f)
- search something

Actual Results:  
- the dialog takes too much space
- F3 shortcut does not work

Expected Results:  
- dialog should use less space
- keyboard shortcuts should work

OS: Linux (x86_64) release 2.6.37.1-1.2-desktop
Compiler: gcc
Comment 1 Christophe Giboudeaux 2011-10-08 09:27:55 UTC
I cannot reproduce the oversize text field. Please report the real version:
kmail --version

Also check if you can reproduce the issue using 'kmail --style oxygen' or 'kmail --style cde'
Comment 2 H.H. 2011-10-08 10:46:46 UTC
This happens still with oxygen.

kmail --version
Qt: 4.7.4
KDE: 4.7.1 (4.7.1) "release 8"
KMail: 4.7.1
Comment 3 Christophe Giboudeaux 2011-10-08 17:37:59 UTC
what about kmail --style cde ?

Did you also check with a new user ?
Comment 4 H.H. 2011-10-09 14:39:45 UTC
same with cde-style (what an ugly style.. ;-))

I need a little bit more time to check with new user (could not imagine anyway what that should change)
Comment 5 H.H. 2011-10-09 17:58:19 UTC
ah, I noticed, that I have configured my kmail windows to be maximized. so try to maximize your window, I think then you will be able to reproduce this.
Comment 6 Laurent Montel 2011-10-10 08:27:29 UTC
I can confirm this bug (big area)
Comment 7 Laurent Montel 2011-10-10 13:14:26 UTC
F3 will not work in this search.
you can press enter if you want to see other element.

F3 is already uses in kmail

I will not add it.

But I will fix first bug
Comment 8 H.H. 2011-10-10 13:33:41 UTC
thanks.

> I will not add it.

you mean you won't add it as _possible_ (not default) shortcut? for now it is not possible to define a shortcut for that action. why?
Comment 9 Laurent Montel 2011-10-10 13:39:12 UTC
Because F3 is already used in kmail.
So I will not add it to this action.
We have pushbutton or "enter" allows to show next item.
Comment 10 Laurent Montel 2011-10-10 14:10:48 UTC
Git commit 14305e853d587aaacda37320d1824fd32d65a4de by Montel Laurent.
Committed on 10/10/2011 at 15:12.
Pushed by mlaurent into branch 'master'.

Fix "Bug 283586 - Search (CTRL+F) in mails has too big search dialog and standard shortcuts (F3 for next result) do not work"

FIXED-IN: 4.7.3
BUG: 283586

M  +1    -0    messageviewer/findbar/findbarbase.cpp

http://commits.kde.org/kdepim/14305e853d587aaacda37320d1824fd32d65a4de
Comment 11 Laurent Montel 2011-10-10 14:12:57 UTC
Git commit 323438be53fef825728dcf6a73b0019ba45f5f81 by Montel Laurent.
Committed on 10/10/2011 at 15:12.
Pushed by mlaurent into branch 'KDE/4.7'.

Fix "Bug 283586 - Search (CTRL+F) in mails has too big search dialog and standard shortcuts (F3 for next result) do not work"

FIXED-IN: 4.7.3
BUG: 283586
(cherry picked from commit 14305e853d587aaacda37320d1824fd32d65a4de)

M  +1    -0    messageviewer/findbar/findbarbase.cpp

http://commits.kde.org/kdepim/323438be53fef825728dcf6a73b0019ba45f5f81
Comment 12 H.H. 2011-10-10 15:20:58 UTC
In my last comment I did not ask for adding "F3" as action for "next search" result, but only for adding the possibility to add _any_ shortcut for that action.

so that I go in kmail menu settings, open "shortcuts" dialog, and find an action like "next search result" as "action", which has an empty default value. would that be possible?
Comment 13 Denis Kurz 2016-09-24 18:12:36 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 14 Denis Kurz 2017-01-07 22:49:00 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.