Bug 283367 - [NPOT] Opengl produces offset decorations
Summary: [NPOT] Opengl produces offset decorations
Status: RESOLVED DUPLICATE of bug 282882
Alias: None
Product: kwin
Classification: Plasma
Component: scene-opengl (show other bugs)
Version: 4.7.1
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-05 05:31 UTC by Ingo Ratsdorf
Modified: 2011-10-15 14:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
GLXInfo Log (23.51 KB, text/x-log)
2011-10-05 05:31 UTC, Ingo Ratsdorf
Details
Screenshot of kde-window-manager-gles (20.05 KB, image/jpeg)
2011-10-05 05:32 UTC, Ingo Ratsdorf
Details
Screenshot of kde-window-manager (93.00 KB, image/jpeg)
2011-10-05 05:33 UTC, Ingo Ratsdorf
Details
Screenshot of XRender (86.55 KB, image/jpeg)
2011-10-05 05:33 UTC, Ingo Ratsdorf
Details
glxinfo output after having switched from nouveau to nvidia 173 with still offset decorations (25.18 KB, text/x-log)
2011-10-06 11:03 UTC, Ingo Ratsdorf
Details
GLXinfo log nvidia-graphics-drivers-173 (173.14.30-0ubuntu7) oneiric (25.18 KB, text/x-log)
2011-10-07 06:56 UTC, Ingo Ratsdorf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Ratsdorf 2011-10-05 05:31:33 UTC
Created attachment 64226 [details]
GLXInfo Log

Version:           4.7.1 (using KDE 4.7.1) 
OS:                Linux

When I select opengl as compositing type, the window decorations will appear all offset, screenshot attached.


Reproducible: Always

Steps to Reproduce:
switch compositing type to opengl.

Actual Results:  
decorations offset, screenshot attached.

Expected Results:  
decorations correct, similar as per attached screenshot of XRender.

The graphic card is a NVidia FX5200Go using nouveau.
I also tried using the opengl2 shaders, that produces a similar effect like the screenshot of kwin-gles (kubuntu package "kde-window-manager-gles"), all black.
I also tried the 173.xx original Nvidia drivers instead of nouveau but to the very same result.
Have attached glxinfo output and three screenshots, one with XRender, one with kwin opengl and one with kwin gles.
Comment 1 Ingo Ratsdorf 2011-10-05 05:32:30 UTC
Created attachment 64227 [details]
Screenshot of kde-window-manager-gles
Comment 2 Ingo Ratsdorf 2011-10-05 05:33:15 UTC
Created attachment 64228 [details]
Screenshot of kde-window-manager
Comment 3 Ingo Ratsdorf 2011-10-05 05:33:49 UTC
Created attachment 64229 [details]
Screenshot of XRender
Comment 4 Ingo Ratsdorf 2011-10-06 10:57:55 UTC
Have installed nvidia-173-updates package.
Display performance is better and glxgears delivers 2500 frames per second compared to the 280 that nouveau did, however the weired decorations when switching kwin to opengl continue to persist.
Have attached glxinfo output.
Comment 5 Ingo Ratsdorf 2011-10-06 11:03:17 UTC
Created attachment 64279 [details]
glxinfo output after having switched from nouveau to nvidia 173 with still offset decorations
Comment 6 Thomas Lübking 2011-10-06 19:43:03 UTC
I tried git master w/o NPOT support (but on a non legacy nvidia gpu and mainline drivers - i probably can test a 5200 this WE)

The issue did not show up.
Is it related to the window decoration, ie. does it show up with decorations like KDE2 or Web (but NOT QtCurve with internal shadows)?
Comment 7 Ingo Ratsdorf 2011-10-07 06:55:03 UTC
It seems to be ONLY related to the decorations.
I have tried various decorations other than oxygen, ie nano, laptop, qtcurve, .. they ALL produce the same offset decorations as per screenshot (Screenshot of kde-window-manager).
I have switched the GTK2 engines from qtcurve to oxygen, I installed the latest nvidia-graphics-drivers-173 (173.14.30-0ubuntu7) oneiric, still the very same behaviour.
Logged in as a new user, same behaviour.

Only thing to note: It's a laptop with a built-in nvidia FX 5300Go.

I have also attached the glxinfo log of the latest nvidia driver installation.
Comment 8 Ingo Ratsdorf 2011-10-07 06:56:53 UTC
Created attachment 64299 [details]
GLXinfo log nvidia-graphics-drivers-173 (173.14.30-0ubuntu7) oneiric
Comment 9 Orion Poplawski 2011-10-07 17:58:21 UTC
Same here on Fedora 16 beta with two different cards:

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
Comment 10 Thomas Lübking 2011-10-07 21:28:46 UTC
do you see broken shadows like in bug #280116 as well?
Comment 11 Orion Poplawski 2011-10-07 21:49:24 UTC
(In reply to comment #10)
> do you see broken shadows like in bug #280116 as well?

I do (though I'm not the original reporter).
Comment 12 Ingo Ratsdorf 2011-10-08 05:23:25 UTC
I do too, similar as bug #280116, maybe even worse. Funny enough the report of bug #280116 has correct decorations, while I do not.
Comment 13 Ingo Ratsdorf 2011-10-08 05:31:01 UTC
As advised in comment #3 in bug #280116, I post the kwin --replace output here too.

ingo@ingo-laptop:~$ kwin --replace --graphicssystem raster &
[2] 7228
ingo@ingo-laptop:~$ kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_zoom"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_login"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_slidingpopups"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_minimizeanimation"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_translucency"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_screenshot"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_boxswitch"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_slide"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_desktopgrid"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_fade"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_dialogparent"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_highlightwindow"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_taskbarthumbnail"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_presentwindows"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_logout"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_dashboard"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_outline"
kwin(7221) KWin::EffectsHandlerImpl::unloadEffect: EffectsHandler::unloadEffect : Unloading Effect :  "kwin4_effect_startupfeedback"
kwin(7228) KWin::Extensions::init: Extensions: shape: 0x "11"  composite: 0x "4"  render: 0x "b"  fixes: 0x "50"
kwin(7228) KWin::CompositingPrefs::detect: glx version is  1 . 3
OpenGL vendor string:                   NVIDIA Corporation
OpenGL renderer string:                 GeForce FX Go53xx/AGP/SSE2
OpenGL version string:                  2.1.2 NVIDIA 173.14.30
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
Driver:                                 NVIDIA
Driver version:                         173.14.30
GPU class:                              Unknown
OpenGL version:                         2.1.2
GLSL version:                           1.20
X server version:                       1.10.4
Linux kernel version:                   3.0
Direct rendering:                       yes
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   no
kwin(7228) KDecorationPlugins::loadPlugin: kwin : path  "/usr/lib/kde4/kwin3_oxygen.so"  for  "kwin3_oxygen"
kwin(7228) KWin::Extensions::init: Extensions: shape: 0x "11"  composite: 0x "4"  render: 0x "b"  fixes: 0x "50"
kwin(7228) KWin::Extensions::init: Extensions: shape: 0x "11"  composite: 0x "4"  render: 0x "b"  fixes: 0x "50"
kwin(7228) KWin::Workspace::setupCompositing: Initializing OpenGL compositing
kwin(7228) KWin::SceneOpenGL::initBufferConfigs: Drawable visual (depth  24 ): 0x "59"
kwin(7228) KWin::SceneOpenGL::initBufferConfigs: Drawable visual (depth  32 ): 0x "80"
kwin(7228) KWin::SceneOpenGL::initBuffer: Buffer visual (depth  24 ): 0x "57"
kwin(7228) KWin::ShaderManager::initShaders: OpenGL Shaders disabled by config option
kwin(7228) KWin::SceneOpenGL::SceneOpenGL: No Scene Shaders available
kwin(7228) KWin::SceneOpenGL::SceneOpenGL: DB: true , Direct: true
kwin(7228) KWin::currentRefreshRate: Refresh rate  60 Hz
kwin(7228)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from "/var/tmp/kdecache-ingo/ksycoca4"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_slidingpopups"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_blur"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: EffectsHandler::loadEffect : Effect  "kwin4_effect_blur"  is not supported 
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_fade"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_desktopgrid"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_slide"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_presentwindows"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_dashboard"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_login"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_startupfeedback"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_outline"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_boxswitch"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_taskbarthumbnail"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_logout"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_screenshot"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_translucency"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_highlightwindow"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_zoom"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_dialogparent"
kwin(7228) KWin::EffectsHandlerImpl::loadEffect: Trying to load  "kwin4_effect_minimizeanimation"
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 38440509
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 33555080 ;WMCLASS: "plasma" : "plasma" ;Caption: "plasma-desktop" ' : 38440509
kwin(7228) KWin::Workspace::allowClientActivation: Activation: No client active, allowing
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 38805592
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 90177556 ;WMCLASS: "kmail" : "kmail" ;Caption: "Local Folders/inbox – KMail" ' : 38805592
kwin(7228) KWin::Workspace::allowClientActivation: Activation: No client active, allowing
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Workspace::createTile: Now tiling  "Local Folders/inbox – KMail"
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 38993189
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 92274707 ;WMCLASS: "systemsettings" : "systemsettings" ;Caption: "Desktop Effects – System Settings" ' : 38993189
kwin(7228) KWin::Workspace::allowClientActivation: Activation: No client active, allowing
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Workspace::createTile: Now tiling  "Desktop Effects – System Settings"
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 39195536
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 31457518 ;WMCLASS: "firefox" : "navigator" ;Caption: "Bug 280116 - kwin shadows are rendered badly wrong with nvidia GeForce FX5200 with nvidia-173xx drivers - Mozilla Firefox" ' : 39195536
kwin(7228) KWin::Workspace::allowClientActivation: Activation: No client active, allowing
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Workspace::createTile: Now tiling  "Bug 280116 - kwin shadows are rendered badly wrong with nvidia GeForce FX5200 with nvidia-173xx drivers - Mozilla Firefox"
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 39278291
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 96469010 ;WMCLASS: "konsole" : "konsole" ;Caption: "ingo : bash" ' : 39278291
kwin(7228) KWin::Workspace::allowClientActivation: Activation: No client active, allowing
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Workspace::createTile: Now tiling  "ingo : bash"
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 39198719
kwin(7228) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 33555071 ;WMCLASS: "plasma" : "plasma" ;Caption: "plasma-desktop" ' : 39198719
kwin(7228) KWin::Workspace::allowClientActivation: Activation: No client active, allowing
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
kwin(7228) KWin::Workspace::updateClientArea: screens:  1 desktops:  2
kwin(7228) KWin::Workspace::updateClientArea: Done.
Comment 14 Martin Flöser 2011-10-15 11:54:19 UTC
This issue can probably be worked around by *not* using the graphicssystem raster.

Try:
kwin --graphicssystem=native --replace &

I merge with a similar bug report for R200

*** This bug has been marked as a duplicate of bug 282882 ***
Comment 15 Donatas Glodenis 2011-10-15 12:44:05 UTC
Making it duplicate of bug 282882 is perhaps correct. With my Radeon 9200 card 

kwin --graphicssystem=raster --replace &

kwin --graphicssystem=opengl --replace &

Produce the same effects, and only

kwin --graphicssystem=native --replace &

does seem to work. I have reported my computer specs to the report 282882. However, some things are also not right with the native backend: the expose effect window names are corrupt (http://imagebin.org/179173) and popups in firefox window are distorted (http://imagebin.org/179174). I know I should report this as another bug...

thanks for working on this!
Comment 16 Martin Flöser 2011-10-15 12:51:15 UTC
The corruption of names is bug #269576 fixed a few minutes ago :-)

The Firefox issue I cannot reproduce here
Comment 17 Martin Flöser 2011-10-15 12:53:46 UTC
The Firefox issue might be Bug #280116
Comment 18 Donatas Glodenis 2011-10-15 13:44:09 UTC
Well, firefox issue is present for me, whether it is raster or native
as the graphicssystem...

> The Firefox issue might be Bug #280116

Looks similar, but it is not the same. I have no problem with popups
in kde applications. It is only strange that popups are all black, but
they are normal, even beautiful somehow. http://imagebin.org/179182

But I just opened gimp and xsane, they both have the popup problem.
But if, in systemsettings > Program Appearance > GTK+ appearance I
change the widget style from oxygen-gtk to raleigh, the problem goes
away (as well as the niceness of widgets, they are back to ugly :(
). Does this mean it is oxygen-gtk problem?

Donatas
Comment 19 Thomas Lübking 2011-10-15 14:33:50 UTC
From the screenshots it doesn't look like you'd use the Qt oxygen style but QtCurve or plastique or so.
=> No new shadows means no issues with new shadows.
Apart from this, things look alot like texture geometry issues in all screenshots (but for http://imagebin.org/179182, i doub't there's any bug with those popups, iirc Oxygen by now inverts them as well)

Unfortunately my attempts but "just plug this 5200 here" were... less successful, since the 173xx driver does no more match X11 and by "ignoreABI" i could start X, but not load glx :-(
From what i understood i'd have to downgrade half of my system (unless nvidia has beta drivers arch doesn't ship so far)

:-S