Bug 283351 - line spacing seems broken. REGRESSION
Summary: line spacing seems broken. REGRESSION
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
: 298364 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-04 21:07 UTC by Sune Vuorela
Modified: 2012-04-21 08:05 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sune Vuorela 2011-10-04 21:07:37 UTC
Version:           svn (using KDE 4.6.5) 
OS:                Linux

opening documents with linespacing seems to have it missing, just like creating a new document and try to do any linespacing seems to fail.

Reproducible: Always

Steps to Reproduce:
create new document
fill in some lines of text
select all text
go to paragraph settings and set linespacing to 1.5 and press apply

Actual Results:  
nothing

Expected Results:  
document linespaced with 1.5
Comment 1 Camilla Boemann 2011-10-04 21:36:25 UTC
Not layout or opendocument bug, but ui somehow not applying
Comment 2 lukewolf101010 2012-04-16 17:30:42 UTC
Bug Still exists in Calligra 2.4

can a developer outline what needs to be done in order to fix this?  I might take a look at and see if I can write a patch for this issue if someone can give me that information.
Comment 3 Camilla Boemann 2012-04-16 17:36:15 UTC
I fear it's too complicated an issue to just come and make a small but. But I'm going to look at a similar issue right now, os maybe it 's the sme thing. will keep this bug in mind too. Thanks for remininding me on this luckiest of moments.

If you are intersted in helpng out with Calligra in general, you would be very welcome btw. We hang out on #calligra  irc channel
Comment 4 Camilla Boemann 2012-04-20 20:50:37 UTC
*** Bug 298448 has been marked as a duplicate of this bug. ***
Comment 5 Camilla Boemann 2012-04-20 20:51:08 UTC
*** Bug 298365 has been marked as a duplicate of this bug. ***
Comment 6 Camilla Boemann 2012-04-20 20:59:15 UTC
*** Bug 298364 has been marked as a duplicate of this bug. ***
Comment 7 J. Jordan 2012-04-20 21:14:55 UTC
The bug I submitted was marked as a duplicate of this bug and removed.  The symptoms I am seeing are somewhat different than those detailed above.  I'm using 2.4.0 on Kubuntu 12.04 KDE 4.8.2.  

1.) opening a document with double line space works and shows double spaced lines
2.) manually setting line spaceing to 2x font size (i.e. 24pts for 12pt font) works 

The fact that the line spacing can be manually set indicates to me that (most of) the algorithm works, it just is not being called by the UI
Comment 8 Camilla Boemann 2012-04-20 21:57:39 UTC
Yes that is actually what this bug is about too if you read carefully, though i admit the title is not as telling. Good news is that i've had a fix for a week now, and i will push it in time for 2.4.1
Comment 9 J. Jordan 2012-04-20 22:44:34 UTC
I assure you I can read!  I also assure you that I searched for related bugs before I submitted, the one you cancelled.  This bug says: "opening documents with linespacing seems to have it missing, just like creating a new document and try to do any linespacing seems to fail."  THAT IS NOT WHAT I OBSERVED, so I attempted to provide some additional information.

Thank you for your time working on this project, I thought perhaps I could be of some assistance, obviously I was mistaken.  Please do not bother with any more rude responses.
Comment 10 Camilla Boemann 2012-04-21 06:40:12 UTC
I'm very sorry if i came a cross as rude. I had absolutely no intention of that. I assure you i had absolutely no intention of that. You can indeed be of assistance

I was simply pointing out that this bug can be misread - because i did so for quite a long time, and only when i talked to the reporter did i get what it was really about

And i asssure you the bug is the same - as i've here on my computer fixed it already
Comment 11 Camilla Boemann 2012-04-21 07:21:00 UTC
Git commit 8e379dff63f82105488f99f3ffb3477eec3be775 by C. Boemann.
Committed on 16/04/2012 at 21:05.
Pushed by boemann into branch 'master'.

Make sure linespacing is applied and also make usre we do the inheritance check

However the fix contains a new string so it can't be backported to 2.4 series

M  +41   -46   plugins/textshape/dialogs/ParagraphIndentSpacing.cpp
M  +2    -1    plugins/textshape/dialogs/ParagraphIndentSpacing.h
M  +133  -131  plugins/textshape/dialogs/ParagraphIndentSpacing.ui

http://commits.kde.org/calligra/8e379dff63f82105488f99f3ffb3477eec3be775
Comment 12 Camilla Boemann 2012-04-21 07:22:31 UTC
Git commit 3acb57721ce344d6d2ce7b63b5559cc0d80de581 by C. Boemann.
Committed on 16/04/2012 at 21:05.
Pushed by boemann into branch 'calligra/2.4'.

Make sure linespacing is applied and also make usre we do the inheritance check

However the fix contains a new string so it can't be backported to 2.4 series

M  +41   -46   plugins/textshape/dialogs/ParagraphIndentSpacing.cpp
M  +2    -1    plugins/textshape/dialogs/ParagraphIndentSpacing.h
M  +133  -131  plugins/textshape/dialogs/ParagraphIndentSpacing.ui

http://commits.kde.org/calligra/3acb57721ce344d6d2ce7b63b5559cc0d80de581
Comment 13 Camilla Boemann 2012-04-21 08:05:43 UTC
Git commit f654a9a63417fb42efc2acb324506467061fc668 by C. Boemann.
Committed on 16/04/2012 at 21:05.
Pushed by boemann into branch 'tuneKoUnitAPI'.

Make sure linespacing is applied and also make usre we do the inheritance check

However the fix contains a new string so it can't be backported to 2.4 series

M  +41   -46   plugins/textshape/dialogs/ParagraphIndentSpacing.cpp
M  +2    -1    plugins/textshape/dialogs/ParagraphIndentSpacing.h
M  +133  -131  plugins/textshape/dialogs/ParagraphIndentSpacing.ui

http://commits.kde.org/calligra/f654a9a63417fb42efc2acb324506467061fc668