Bug 283240 - Crashes when track info changes on webradio
Summary: Crashes when track info changes on webradio
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-03 12:14 UTC by SZÉKELYI Szabolcs
Modified: 2011-10-05 06:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (17.56 KB, text/plain)
2011-10-04 13:24 UTC, SZÉKELYI Szabolcs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SZÉKELYI Szabolcs 2011-10-03 12:14:41 UTC
Version:           2.4.3 (using KDE 4.6.5) 
OS:                Linux

When amarok is playing a stream (namely, http://stream1.neston.hu:8000/neston), and the track info changes, it crashes sometimes. The bug reporting assistant is unable to generate the backtrace, it shows an empty backtrace.

Reproducible: Sometimes

Steps to Reproduce:
Play the above mentioned stream and wait a few track changes.


Expected Results:  
It should just keep on playing.
Comment 1 Myriam Schweingruber 2011-10-04 05:08:01 UTC
Could you please provide a backtrace of the crash?
Comment 2 SZÉKELYI Szabolcs 2011-10-04 13:24:39 UTC
Created attachment 64201 [details]
New crash information added by DrKonqi

amarok (2.4.3) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

As I've written before, the Crach Reporting Assistant showed an empty backtrace. I tried it again now, and this time it managed to generate this backtrace.

-- Backtrace (Reduced):
#6  operator== (value=0, this=0xad) at /usr/include/qt4/QtCore/qbasicatomic.h:70
#7  isNull (this=0x22898c8) at /usr/include/qt4/QtCore/qsharedpointer_impl.h:558
#8  operator QWeakPointer<QTimer>::RestrictedBool (this=0x22898c8) at /usr/include/qt4/QtCore/qsharedpointer_impl.h:560
#9  Context::ContextView::addCollapseAnimation (this=0x2289850, anim=0x2ccab00) at ../../src/context/ContextView.cpp:247
#10 0x00007f2046350f84 in Context::Applet::collapse (this=0x241a1a0, on=<optimized out>) at ../../src/context/Applet.cpp:320
Comment 3 Myriam Schweingruber 2011-10-05 06:34:04 UTC
Thank you for the feedback.

*** This bug has been marked as a duplicate of bug 258741 ***