Bug 282708 - Other programs cannot open files when send to them by KSnapShot
Summary: Other programs cannot open files when send to them by KSnapShot
Status: RESOLVED DUPLICATE of bug 258431
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: 0.8.2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-24 19:13 UTC by Ruben van Os
Modified: 2011-09-24 20:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error message given by Pinta after using the "Send To..." button. (108.65 KB, image/png)
2011-09-24 19:13 UTC, Ruben van Os
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruben van Os 2011-09-24 19:13:05 UTC
Created attachment 63930 [details]
Error message given by Pinta after using the "Send To..." button.

Version:           0.8.2 (using KDE 4.6.2) 
OS:                Linux

After making a screenshot, clicking the "Send To..." button and selecting an application (for example, Pinta, Kopete, GwenView) the program complains that it cannot open the file.

If the "Save As..." option is used first, KSnapShot will rename the image (for example, snapshot9.png to snapshot10.png) in the client, causing the same error in the program the image is sent to as without saving, even though the actual screenshot does exist now.

Reproducible: Always

Steps to Reproduce:
Press PrintScreen, click Send To..., choose an application.

Actual Results:  
The selected application returns a "file not found" error.

Expected Results:  
The selected application opens the screenshot.

OS: Linux (i686) release 2.6.38-11-generic
Compiler: cc
Comment 1 Christoph Feck 2011-09-24 20:29:04 UTC

*** This bug has been marked as a duplicate of bug 258431 ***