Bug 282698 - Krita crashes upon launch
Summary: Krita crashes upon launch
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 2.4-snapshots
Platform: Chakra Linux
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-24 16:46 UTC by Neofytos Kolokotronis
Modified: 2011-10-30 14:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neofytos Kolokotronis 2011-09-24 16:46:39 UTC
Version:           2.4-snapshots (using KDE 4.7.1) 
OS:                Linux

After launching Krita, I get the Splash screen and then it crashes after showing the initial Krita start screen.

Reproducible: Always

Steps to Reproduce:
Just launch the application

Actual Results:  
Krita crashes and exits.

Expected Results:  
not crash =)

[tetris4@lappy ~]$ krita
krita(16116) KoGenericRegistry<T>::add: Registry already contains item "LABA" 
krita(16116) KoGenericRegistry<T>::add: Registry already contains item "RGBA16" 
krita(16116) KoGenericRegistry<T>::add: Registry already contains item "RGBA" 
krita(16116) KoGenericRegistry<T>::add: Registry already contains item "GRAYA16HISTO" 
krita(16116)/krita (general) MyPaintBrushResource::load:         we only read version 2 .myb files 
krita(16116)/krita (general) MyPaintBrushResource::load:         we only read version 2 .myb files 
krita(16116)/krita (general) MyPaintBrushResource::load:         we only read version 2 .myb files 
krita(16116) KoGenericRegistry<T>::add: Registry already contains item "PanTool" 
krita(16116)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/kritahistorydocker.so" does not offer a qt_plugin_instance function.
(Soprano::Redland::BackendPlugin) creating model of type "hashes" with options "hash-type='memory',contexts='yes'" 
Using Virtuoso Version: "6.1.3.3127-pthreads" 
krita(16116) KoDocumentRdf::backendIsSane: Found a backend:  "virtuosobackend" 
"/usr/bin/krita(16116)" Soprano: "Need a database storage path set to start a local Virtuoso instance."
krita(16116) KoDocumentRdf::backendIsSane: No model could be created. 
krita(16116) KoDocumentRdf::KoDocumentRdf: Looks like the backend is not sane! 
krita(16116)/kotext TextShapeFactory::newDocumentResourceManager: No KUndo2Stack found in the document resource manager, creating a new one 
krita(16116)/koffice (filter manager) KoFilterManager::filterAvailable: The library  ""  does not offer a check_ ""  function. 

krita(16116) KDirWatchPrivate::KDirWatchPrivate: INotify available:  true
krita(16116)/kotext TextShapeFactory::newDocumentResourceManager: No KUndo2Stack found in the document resource manager, creating a new one 
krita(16116)/koffice (lib kopageapp) KoOdfLoadingContext::KoOdfLoadingContext: could not parse manifest document 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116)/koffice (lib kopageapp) KoOdfLoadingContext::KoOdfLoadingContext: could not parse manifest document 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116)/koffice (lib kopageapp) KoOdfLoadingContext::KoOdfLoadingContext: could not parse manifest document 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116)/koffice (lib kopageapp) KoOdfLoadingContext::KoOdfLoadingContext: could not parse manifest document 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116)/koffice (lib kopageapp) KoOdfLoadingContext::KoOdfLoadingContext: could not parse manifest document 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116)/kotext KoOdfLoadingContext::addStyles: Parent style not found:  "paragraph" "Default" false 
krita(16116) KoDocumentInfo::aboutInfo: "comment page not found in documentInfo !" 
krita(16116)/kdeui (KAction) KActionCollection::setComponentData: this does not work on a KActionCollection containing actions! 
X Error: BadAtom (invalid Atom parameter) 5
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x0
krita(16116) SpaceNavigatorDevice::start: starting spacenavigator device...
connect failed: No such file or directory
LLVM ERROR: Cannot yet select: 0x113aa7b0: f32 = sint_to_fp 0x113a9290 [ORD=97] [ID=8]
  0x113a9290: i32,ch = load 0x171ad58, 0x113a0d30, 0x1139f320<LD4[%Variable8]> [ORD=96] [ID=5]
    0x171ad58: ch = EntryToken [ORD=96] [ID=0]
    0x113a0d30: i64 = FrameIndex<8> [ORD=96] [ID=1]
    0x1139f320: i64 = undef [ORD=96] [ID=2]
krita(16116) SpaceNavigatorDevice::stop: stopping spacenavigator device...
CRITICAL: According to statistics of the KisTileDataStore some tiles have leaked from the Krita control! 
CRITICAL: Tiles in memory: 7388 Total tiles: 7388
Comment 1 Halla Rempt 2011-10-08 11:39:08 UTC
Hi!

Thanks for your report. Are you by any chance using a gallium-based graphics driver, like the open source radeon driver? Those drivers are llvm-based and interfere with any application that also uses llvm.
Comment 2 Halla Rempt 2011-10-08 11:51:26 UTC
Changing to needsinfo. This report probably is duplicate of https://bugs.kde.org/show_bug.cgi?id=281446.
Comment 3 Neofytos Kolokotronis 2011-10-08 21:43:36 UTC
I use the i915 driver (which comes integrated with the Sandy Bridge CPU's ).

And I can confirm that another Chakra user also on KDE 4.7.2 and on i915  has a similar issue.

So it looks to be releated to the i915 drivers. 

How do we workaround this?

ps: Krita currently doesn't crash, just shows the splashscreen and then nothing happens. No output in the konsole  either. But it still appears in memory and I have to manually kill it.
Comment 4 Halla Rempt 2011-10-09 11:14:01 UTC
Right... I've asked on my blog for help, and I've received some very helpful mails. I'll have to figure out what to do now going forward. It's actually one of two really difficult problems I'm facing right now, the other being tablet support on some distributions.
Comment 5 Daniele Cocca 2011-10-09 22:56:18 UTC
Actually, I'm having the same kind of hang here, and I'm using the proprietary NVIDIA drivers. The latest console messages are color-related, so I think you are quite right about OpenGTL.

By the way, this also seems to affect Calligra Flow. The last line I see printed to the console before hanging is the same (except for the executable name, of course):

flow(30912)/krita (plugins) CTLCSPlugin::CTLCSPlugin: There are  6  CTL color transformations
Comment 6 Daniele Cocca 2011-10-09 23:48:55 UTC
Ok, this seemed to have something to do with some of our (Chakra) builds, which were based on a slightly old version of OpenGTL (0.9.15 instead of 0.9.15.1). Seems like the .1 upgrade did fix the issue for both me and tetris4. Now Krita and Flow work again!
Comment 7 Halla Rempt 2011-10-30 14:31:13 UTC
Great!