Bug 282593 - Konsole shortcut "Ctrl + Shift + X" for clearing scroll and reset appears as problematic
Summary: Konsole shortcut "Ctrl + Shift + X" for clearing scroll and reset appears as ...
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.6
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-23 04:55 UTC by Venkata Rama Krishna Boddu
Modified: 2014-06-24 13:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Venkata Rama Krishna Boddu 2011-09-23 04:55:09 UTC
Version:           2.6 (using KDE 4.6.0) 
OS:                Linux

In Konsole application, we using following shortcuts very often to do the Copy and Paste. Having "Ctrl + Shift + X" as default shortcut for "Clear scrollback and Reset" and Keys "X, C, V" adjacent to each other in QWERTY Keyboard Layout  is appearing problematic and posing the annoyance that, if a user intent to press the Copy shortcut"Ctrl + Shift + C" in QWERTY Keyboard and then he is in danger of pressing the "Ctrl + Shitf + X" as both "X and C" Keys on side-by-side.

It would better, if we choose any other default shortcut for "Clear scroll back and Reset" instead of "Ctrl + Shift + X"

Clear scrollback and Reset: Ctrl + Shift + X
Copy: Ctrl + Shift + C
Paste: Ctrl + Shift + V




Reproducible: Always

Steps to Reproduce:
1) When you are using the Konsole application for very busy need such as Administrating the Production Server or etc.,

2) Please only concentrate on the Konsole of your sever and try to use the shortcuts for doing some copy and paste work.

3) Now, after doing some serious work then try to copy some content from konsole and by mistake(or by intent) press the "Ctrl + Shift + X" instead of "Ctrl + Shift + C"

Actual Results:  
In real, because of QWERTY Layout Keyboard's side-by-side "XCV" characters and my hand mistake, Konsole got cleared and now, I have no way of get some  output copied from the production server konsole.

Expected Results:  
In my mind, I expected copy to happen
Comment 1 Jekyll Wu 2011-10-15 11:52:56 UTC
That sounds sensible. What about 'Ctrl + Shift + R' as the default shorcut ?
Comment 2 Kurt Hindenburg 2011-10-17 15:06:50 UTC
We are talking about the default - users can always change the shortcut.

I'm not sure it is worth changing the default.  If we decide to perhaps use K?
Comment 3 Venkata Rama Krishna Boddu 2011-10-18 13:13:17 UTC
What about the users, who don't know the default shortcut is "Ctrl + Shift + X"?

They might accidentally click "Ctrl + Shift + X" when doing the copy and paste.
Comment 4 Jekyll Wu 2012-01-10 03:56:23 UTC
Git commit dad64e67e73df7a6968cfdfdd8741531ec381dc9 by Jekyll Wu.
Committed on 09/01/2012 at 18:28.
Pushed by jekyllwu into branch 'master'.

Change the default shortcut of 'Clear Scrollback and Reset' to Ctrl+Shift+K

The current default shortcut is Ctrl+Shift+X, which might be accidentally
pressed when users intend to press Ctrl+Shift+C for copying or Ctrl+Shift+V for
pasting. Scrollback is important asset, but it is impossible to recover
once gone. So change the default shortcut to decrease the chance of
accidents.
FIXED-IN: 4.9
REVIEW: 103660

M  +1    -1    src/SessionController.cpp

http://commits.kde.org/konsole/dad64e67e73df7a6968cfdfdd8741531ec381dc9