Bug 282556 - Muon Software center crash
Summary: Muon Software center crash
Status: RESOLVED DUPLICATE of bug 286315
Alias: None
Product: muon
Classification: Applications
Component: installer (show other bugs)
Version: 1.1.2
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-22 13:54 UTC by romain
Modified: 2012-02-21 16:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description romain 2011-09-22 13:54:33 UTC
Application: muon-installer (1.1.2 "Bullish Bandril")
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
i was trying to install knetworkManager from kubuntu Backports, when a popup opened.  Title"Erreur d'initialisation - Centre de logiciels Muon" and message "Impossible d'initialiser le système de paquetages, il se peut que votre configuration soit brisée"

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7febcee26780 (LWP 3191))]

Thread 2 (Thread 0x7febbaf6e700 (LWP 3216)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007febbaf6dae0 in ?? ()
#2  0x00007fffdb9ff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7febcee26780 (LWP 3191)):
[KCrash Handler]
#6  FindPkg (this=0x9877f0, name=<value optimized out>) at /usr/include/apt-pkg/depcache.h:330
#7  QApt::Backend::package (this=0x9877f0, name=<value optimized out>) at /build/buildd/qapt-1.1.2/src/backend.cpp:268
#8  0x000000000041bc51 in Application::package (this=0x1cb6dc0) at /build/buildd/muon-1.1.2/installer/Application.cpp:94
#9  0x000000000041f07d in ApplicationBackend::init (this=0x9b9990) at /build/buildd/muon-1.1.2/installer/ApplicationBackend.cpp:75
#10 0x000000000041fb42 in ApplicationBackend::reload (this=0x9b9990) at /build/buildd/muon-1.1.2/installer/ApplicationBackend.cpp:114
#11 0x000000000041ff48 in ApplicationBackend::workerEvent (this=0x9b9990, event=<value optimized out>) at /build/buildd/muon-1.1.2/installer/ApplicationBackend.cpp:180
#12 0x000000000041b19b in ApplicationBackend::qt_metacall (this=0x9b9990, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdb8e4c90) at /build/buildd/muon-1.1.2/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:116
#13 0x00007febccae25f8 in QMetaObject::activate (sender=0x9877f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdb8e4c90) at kernel/qobject.cpp:3287
#14 0x00007febce3515c1 in QApt::Backend::workerEvent (this=<value optimized out>, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.1.2/obj-x86_64-linux-gnu/src/moc_backend.cxx:222
#15 0x00007febce3517ec in QApt::Backend::qt_metacall (this=0x9877f0, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0x7fffdb8e4da0) at /build/buildd/qapt-1.1.2/obj-x86_64-linux-gnu/src/moc_backend.cxx:182
#16 0x00007febccae25f8 in QMetaObject::activate (sender=0x9bd770, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdb8e4da0) at kernel/qobject.cpp:3287
#17 0x00007febce3520e1 in OrgKubuntuQaptworkerInterface::workerEvent (this=<value optimized out>, _t1=6) at /build/buildd/qapt-1.1.2/obj-x86_64-linux-gnu/src/workerdbus.moc:201
#18 0x00007febce35256e in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x9bd770, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fffdb8e51a0) at /build/buildd/qapt-1.1.2/obj-x86_64-linux-gnu/src/workerdbus.moc:119
#19 0x00007febcce229fa in QDBusConnectionPrivate::deliverCall (this=0x817e40, object=0x9bd770, msg=..., metaTypes=..., slotIdx=12) at qdbusintegrator.cpp:942
#20 0x00007febcce2ce4f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#21 0x00007febccae149a in QObject::event (this=0x9bd770, e=<value optimized out>) at kernel/qobject.cpp:1226
#22 0x00007febcbe8a9f4 in QApplicationPrivate::notify_helper (this=0x826430, receiver=0x9bd770, e=0x1cace40) at kernel/qapplication.cpp:4462
#23 0x00007febcbe8f3ba in QApplication::notify (this=<value optimized out>, receiver=0x9bd770, e=0x1cace40) at kernel/qapplication.cpp:4341
#24 0x00007febcd76d796 in KApplication::notify (this=0x7fffdb8e5bf0, receiver=0x9bd770, event=0x1cace40) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007febccacd49c in QCoreApplication::notifyInternal (this=0x7fffdb8e5bf0, receiver=0x9bd770, event=0x1cace40) at kernel/qcoreapplication.cpp:731
#26 0x00007febccad0c25 in sendEvent (receiver=0x0, event_type=0, data=0x7d9e90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x7d9e90) at kernel/qcoreapplication.cpp:1372
#28 0x00007febccaf8253 in sendPostedEvents (s=0x82b560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#29 postEventSourceDispatch (s=0x82b560) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007febc783abcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007febc783b3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007febc783b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007febccaf83ef in QEventDispatcherGlib::processEvents (this=0x7d9a90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007febcbf344de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007febccacc882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007febccaccabc in QEventLoop::exec (this=0x7fffdb8e5b80, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007febccad0ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#38 0x000000000041b6b0 in main (argc=1, argv=<value optimized out>) at /build/buildd/muon-1.1.2/installer/main.cpp:60

Reported using DrKonqi
Comment 1 Jonathan Thomas 2011-09-24 22:31:38 UTC

*** This bug has been marked as a duplicate of bug 274225 ***
Comment 2 Jonathan Thomas 2012-02-21 16:44:42 UTC

*** This bug has been marked as a duplicate of bug 286315 ***