Bug 282507 - Panning doesn't work properly
Summary: Panning doesn't work properly
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: some future version
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-21 20:39 UTC by Aleix Pol
Modified: 2021-03-10 08:08 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleix Pol 2011-09-21 20:39:54 UTC
Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

I've been trying to work with marble reading some GPX files and I've found out it's really hard because after some time of using it there are two kinds of glitches:
- It jumps to a (random?) position far from where I'm using it (close to Barcelona): 131° 04' 34,6"O,   0° 48' 34,4"N
- Panning stops working and the events are refused (and passed to the main window that tries to move itself).

Hope that helps

Reproducible: Sometimes

Steps to Reproduce:
Add a GPX file (although I think it happens without as well). It's usually impossible to get my viewport to fit the route.


Expected Results:  
I'd expect to be able to navigate without having  the viewport jumping around
Comment 1 Dennis Nienhüser 2011-09-24 09:26:20 UTC
Do you have any Position Tracking plugin activated in the Current Location tab on the left?
Comment 2 Aleix Pol 2011-09-28 18:36:58 UTC
It had gpsd enabled, but after disabling it (just changing the combobox works?) It still had the same effect.
Comment 3 Jonathan Marten 2011-12-07 21:34:27 UTC
Confirmed with current master (v4.5.90-1474-g5fab761) and the default OpenStreetMap.  Can neither pan the map by dragging nor zoom using the mouse wheel.

Position Tracking is disabled (and as far as I can remember has never been enabled).

In my case it jumps to somewhere near 22deg 35min S, 144deg 52min W every time the clock changes to a new minute.
Comment 4 Jonathan Marten 2011-12-13 14:58:33 UTC
~/.kde4/share/config/marblerc contains the section:

[Sun]
centerOnSun=true

If this section is removed (while Marble is not running), panning and zooming works correctly for the next run of Marble.  However, on exit the same setting is written back so subsequent runs of Marble will again not work.

I'm guessing that this setting is used by the "Sun" plugin, but the same problem happens even if the Sun plugin is disabled.
Comment 5 Florian Eßer 2011-12-13 16:50:03 UTC
I can confirm the sun-related problems:

Setting (free translation from German locales) "View -> Sun settings -> Sun in zenith" to "Display" in current master results on the map/globe displaying a small sun and fixing at that position, neither panning nor zooming working anymore.
Thought that might be some kind of misplaced feature for standalone presenting / background mode...
Comment 6 Justin Zobel 2021-03-09 22:51:31 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 7 Jonathan Marten 2021-03-10 08:08:51 UTC
Confirmed that the sun lock setting (which is now under View - Sun Control which displays a warning message if the option is turned on) works as intended.  The unwanted persistence does not seem to happen.