Bug 282386 - Crash on muon software center when looking at an application summary
Summary: Crash on muon software center when looking at an application summary
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-20 08:53 UTC by Xavier Besnard
Modified: 2011-10-23 20:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Besnard 2011-09-20 08:53:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-11-generic i686
Distribution: Ubuntu oneiric (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Amarok, firefox, konsole, thunderbird running. I opened muon software center and installe an application. then I  looked at an other application summary and the crash happend.
Conf: ACER one D531H with kubuntu 11.10 Oneiric updated dayly (incl. KDE 4.7)

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb778a930 (LWP 23262))]

Thread 2 (Thread 0xb54a5b70 (LWP 23269)):
#0  0x005ecf4f in pthread_mutex_unlock (mutex=0x8fd21c4) at forward.c:184
#1  0x06aaacdf in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x008bcb37 in QEventDispatcherGlib::processEvents (this=0x8fb5f28, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x0088d1dd in QEventLoop::processEvents (this=0xb54a52b0, flags=...) at kernel/qeventloop.cpp:149
#4  0x0088d421 in QEventLoop::exec (this=0xb54a52b0, flags=...) at kernel/qeventloop.cpp:201
#5  0x0079090b in QThread::exec (this=0x8fafc50) at thread/qthread.cpp:498
#6  0x0086de2d in QInotifyFileSystemWatcherEngine::run (this=0x8fafc50) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x007937b3 in QThreadPrivate::start (arg=0x8fafc50) at thread/qthread_unix.cpp:331
#8  0x00a41d31 in start_thread (arg=0xb54a5b70) at pthread_create.c:304
#9  0x005df0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb778a930 (LWP 23262)):
[KCrash Handler]
#7  QHash<QByteArray, QByteArray>::findNode (this=0x9894afc, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#8  0x0805e7ab in value (akey=..., this=0x9894afc) at /usr/include/qt4/QtCore/qhash.h:607
#9  Application::getField (this=0x9894af8, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#10 0x0805f0d7 in Application::untranslatedName (this=0x9894af8) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#11 0x0805f29d in Application::name (this=0x9894af8) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#12 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x8f83cc8, job=0xa220ac0) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#13 0x0805e465 in ReviewsBackend::qt_metacall (this=0x8f83cc8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa102a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#14 0x00894b7d in metacall (argv=0xbfa102a8, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x8f83cc8) at kernel/qmetaobject.cpp:237
#15 QMetaObject::metacall (object=0x8f83cc8, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfa102a8) at kernel/qmetaobject.cpp:232
#16 0x008a3a6a in QMetaObject::activate (sender=0xa220ac0, m=0x44ae58c, local_signal_index=3, argv=0xbfa102a8) at kernel/qobject.cpp:3278
#17 0x04300a05 in KJob::result (this=0xa220ac0, _t1=0xa220ac0) at ./kjob.moc:194
#18 0x04300a58 in KJob::emitResult (this=0xa220ac0) at ../../kdecore/jobs/kjob.cpp:312
#19 0x001d705c in KIO::FileCopyJob::slotResult (this=0xa220ac0, job=0xa099270) at ../../kio/kio/job.cpp:2440
#20 0x001d6ded in KIO::FileCopyJob::qt_metacall (this=0xa220ac0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa10428) at ./jobclasses.moc:724
#21 0x00894b7d in metacall (argv=0xbfa10428, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0xa220ac0) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0xa220ac0, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbfa10428) at kernel/qmetaobject.cpp:232
#23 0x008a3a6a in QMetaObject::activate (sender=0xa099270, m=0x44ae58c, local_signal_index=3, argv=0xbfa10428) at kernel/qobject.cpp:3278
#24 0x04300a05 in KJob::result (this=0xa099270, _t1=0xa099270) at ./kjob.moc:194
#25 0x04300a58 in KJob::emitResult (this=0xa099270) at ../../kdecore/jobs/kjob.cpp:312
#26 0x001ce738 in KIO::SimpleJob::slotFinished (this=0xa099270) at ../../kio/kio/job.cpp:494
#27 0x001d72bd in KIO::TransferJob::slotFinished (this=0xa099270) at ../../kio/kio/job.cpp:1081
#28 0x001d58f4 in KIO::TransferJob::qt_metacall (this=0xa099270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa106c4) at ./jobclasses.moc:369
#29 0x00894b7d in metacall (argv=0xbfa106c4, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0xa099270) at kernel/qmetaobject.cpp:237
#30 QMetaObject::metacall (object=0xa099270, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfa106c4) at kernel/qmetaobject.cpp:232
#31 0x008a3a6a in QMetaObject::activate (sender=0xa1e1ff0, m=0x3a96a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#32 0x00289b85 in KIO::SlaveInterface::finished (this=0xa1e1ff0) at ./slaveinterface.moc:171
#33 0x0028ca09 in KIO::SlaveInterface::dispatch (this=0xa1e1ff0, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#34 0x0028916a in KIO::SlaveInterface::dispatch (this=0xa1e1ff0) at ../../kio/kio/slaveinterface.cpp:88
#35 0x0027a798 in KIO::Slave::gotInput (this=0xa1e1ff0) at ../../kio/kio/slave.cpp:344
#36 0x0027b00c in KIO::Slave::qt_metacall (this=0xa1e1ff0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa109a4) at ./slave.moc:82
#37 0x00894b7d in metacall (argv=0xbfa109a4, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0xa1e1ff0) at kernel/qmetaobject.cpp:237
#38 QMetaObject::metacall (object=0xa1e1ff0, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbfa109a4) at kernel/qmetaobject.cpp:232
#39 0x008a3a6a in QMetaObject::activate (sender=0xa1be680, m=0x3a6508, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#40 0x00199cd5 in KIO::Connection::readyRead (this=0xa1be680) at ./connection.moc:92
#41 0x0019a50a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#42 KIO::ConnectionPrivate::dequeue (this=0x9f2aa80) at ../../kio/kio/connection.cpp:71
#43 0x0019a5df in KIO::Connection::qt_metacall (this=0xa1be680, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xa206e18) at ./connection.moc:79
#44 0x00894b7d in metacall (argv=0xa206e18, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0xa1be680) at kernel/qmetaobject.cpp:237
#45 QMetaObject::metacall (object=0xa1be680, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xa206e18) at kernel/qmetaobject.cpp:232
#46 0x0089f685 in QMetaCallEvent::placeMetaCall (this=0x9fb1e00, object=0xa1be680) at kernel/qobject.cpp:535
#47 0x008a6b52 in QObject::event (this=0xa1be680, e=0x9fb1e00) at kernel/qobject.cpp:1217
#48 0x0152dd14 in notify_helper (e=0x9fb1e00, receiver=0xa1be680, this=0x8e50ab8) at kernel/qapplication.cpp:4486
#49 QApplicationPrivate::notify_helper (this=0x8e50ab8, receiver=0xa1be680, e=0x9fb1e00) at kernel/qapplication.cpp:4458
#50 0x015330c3 in QApplication::notify (this=0x9fb1e00, receiver=0xa1be680, e=0x9fb1e00) at kernel/qapplication.cpp:3886
#51 0x01184791 in KApplication::notify (this=0xbfa12850, receiver=0xa1be680, event=0x9fb1e00) at ../../kdeui/kernel/kapplication.cpp:311
#52 0x0088e19e in QCoreApplication::notifyInternal (this=0xbfa12850, receiver=0xa1be680, event=0x9fb1e00) at kernel/qcoreapplication.cpp:787
#53 0x00891f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8e31300) at kernel/qcoreapplication.cpp:1428
#55 0x008920ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#56 0x008bc6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#57 postEventSourceDispatch (s=0x8e53378) at kernel/qeventdispatcher_glib.cpp:277
#58 0x06aaa2ef in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0x06aaaa20 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x06aaacba in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#61 0x008bcada in QEventDispatcherGlib::processEvents (this=0x8e32238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#62 0x015e5ada in QGuiEventDispatcherGlib::processEvents (this=0x8e32238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x00892383 in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#64 0x00a125c3 in QApt::CacheBuildProgress::Update (this=0x8f6c1cc) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#65 0x08759216 in OpProgress::Progress(unsigned long) () from /usr/lib/libapt-pkg.so.4.11
#66 0x0876f8db in pkgDepCache::Update(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#67 0x08774ccf in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#68 0x087a0e69 in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#69 0x087a0f04 in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#70 0x00a1233d in QApt::Cache::open (this=0x8f4a9e8) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#71 0x00a0d10a in QApt::Backend::reloadCache (this=0x8fbd7e0) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#72 0x080630cb in ApplicationBackend::reload (this=0x8f57818) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#73 0x08063385 in ApplicationBackend::workerEvent (this=0x8f57818, event=QApt::CommitChangesFinished) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#74 0x0805e23d in ApplicationBackend::qt_metacall (this=0x8f57818, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa11d98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#75 0x00894b7d in metacall (argv=0xbfa11d98, idx=16, cl=QMetaObject::InvokeMetaMethod, object=0x8f57818) at kernel/qmetaobject.cpp:237
#76 QMetaObject::metacall (object=0x8f57818, cl=QMetaObject::InvokeMetaMethod, idx=16, argv=0xbfa11d98) at kernel/qmetaobject.cpp:232
#77 0x008a3a6a in QMetaObject::activate (sender=0x8fbd7e0, m=0xa39cb8, local_signal_index=4, argv=0xbfa11d98) at kernel/qobject.cpp:3278
#78 0x00a29c65 in QApt::Backend::workerEvent (this=0x8fbd7e0, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/moc_backend.cxx:244
#79 0x00a06789 in QApt::Backend::emitWorkerEvent (this=0x8fbd7e0, event=6) at /build/buildd/qapt-1.2.1/src/backend.cpp:1323
#80 0x00a29f6e in QApt::Backend::qt_metacall (this=0x8fbd7e0, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0xbfa11ed8) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/moc_backend.cxx:204
#81 0x00894b7d in metacall (argv=0xbfa11ed8, idx=44, cl=QMetaObject::InvokeMetaMethod, object=0x8fbd7e0) at kernel/qmetaobject.cpp:237
#82 QMetaObject::metacall (object=0x8fbd7e0, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbfa11ed8) at kernel/qmetaobject.cpp:232
#83 0x008a3a6a in QMetaObject::activate (sender=0x8f96058, m=0xa39e38, local_signal_index=8, argv=0xbfa11ed8) at kernel/qobject.cpp:3278
#84 0x00a2acb5 in OrgKubuntuQaptworkerInterface::workerEvent (this=0x8f96058, _t1=6) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/workerdbus.moc:228
#85 0x00a2b1af in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x8f96058, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa1211c) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/workerdbus.moc:131
#86 0x00e9dd87 in QDBusConnectionPrivate::deliverCall (this=0x8fc0dc8, object=0x8f96058, msg=..., metaTypes=..., slotIdx=0) at qdbusintegrator.cpp:942
#87 0x00ea7c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa1ee680, object=0x8f96058) at qdbusintegrator_p.h:103
#88 0x008a6b52 in QObject::event (this=0x8f96058, e=0xa1ee680) at kernel/qobject.cpp:1217
#89 0x0152dd14 in notify_helper (e=0xa1ee680, receiver=0x8f96058, this=0x8e50ab8) at kernel/qapplication.cpp:4486
#90 QApplicationPrivate::notify_helper (this=0x8e50ab8, receiver=0x8f96058, e=0xa1ee680) at kernel/qapplication.cpp:4458
#91 0x015330c3 in QApplication::notify (this=0xa1ee680, receiver=0x8f96058, e=0xa1ee680) at kernel/qapplication.cpp:3886
#92 0x01184791 in KApplication::notify (this=0xbfa12850, receiver=0x8f96058, event=0xa1ee680) at ../../kdeui/kernel/kapplication.cpp:311
#93 0x0088e19e in QCoreApplication::notifyInternal (this=0xbfa12850, receiver=0x8f96058, event=0xa1ee680) at kernel/qcoreapplication.cpp:787
#94 0x00891f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#95 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8e31300) at kernel/qcoreapplication.cpp:1428
#96 0x008920ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#97 0x008bc6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#98 postEventSourceDispatch (s=0x8e53378) at kernel/qeventdispatcher_glib.cpp:277
#99 0x06aaa2ef in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#100 0x06aaaa20 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#101 0x06aaacba in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#102 0x008bcada in QEventDispatcherGlib::processEvents (this=0x8e32238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#103 0x015e5ada in QGuiEventDispatcherGlib::processEvents (this=0x8e32238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#104 0x0088d1dd in QEventLoop::processEvents (this=0xbfa127b4, flags=...) at kernel/qeventloop.cpp:149
#105 0x0088d421 in QEventLoop::exec (this=0xbfa127b4, flags=...) at kernel/qeventloop.cpp:201
#106 0x0089219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#107 0x0152b8b4 in QApplication::exec () at kernel/qapplication.cpp:3760
#108 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Jonathan Thomas 2011-10-23 20:54:47 UTC

*** This bug has been marked as a duplicate of bug 283728 ***