Bug 281850 - Color scheme not attached when "publishing" a scheme
Summary: Color scheme not attached when "publishing" a scheme
Status: RESOLVED FIXED
Alias: None
Product: frameworks-attica
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Jeremy Whiting
URL:
Keywords:
: 286143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-12 06:46 UTC by Petr Svoboda
Modified: 2011-12-30 08:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.2.9


Attachments
Patch (2.07 KB, patch)
2011-10-22 16:10 UTC, Stephane MANKOWSKI
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Svoboda 2011-09-12 06:46:11 UTC
Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

When I want to publish my color scheme through GHNS, the color scheme itself is not attached. I had to manually add it later through kde-look.org.

Name, description, license, screenshots, etc. are OK.

Reproducible: Always

Steps to Reproduce:
Try to send color scheme through GHNS

Actual Results:  
No color scheme is attached

Expected Results:  
Color scheme should be attached
Comment 1 Jeremy Whiting 2011-09-15 05:25:46 UTC
Tested here and I get the same problem. The debug output shows xml from opendesktop.org stating that the local file could not be found, but all the checks in the code before the upload happens didn't complain about a missing file at all.
Comment 2 Jeremy Whiting 2011-09-15 05:44:18 UTC
It seems Attica::PostJob only has a finished signal, no failed signal.  At any rate we should be checking for errors in our finished slot.
Comment 3 Stephane MANKOWSKI 2011-10-22 16:10:32 UTC
Created attachment 64792 [details]
Patch

Hi,

This small correction is working in my case. (The file is uploaded on the opendesktop server without error).
Comment 4 Jeremy Whiting 2011-10-22 16:44:28 UTC
Git commit 36781d9cd47e4d5f7e365cfe452a433bfef62f71 by Jeremy Whiting.
Committed on 22/10/2011 at 18:43.
Pushed by whiting into branch 'master'.

Fix upload by setting contentId.
Fix provided by Stephane MANKOWSKI <stephane@mankowski.fr>
BUG: 281850

M  +2    -1    lib/provider.cpp

http://commits.kde.org/attica/36781d9cd47e4d5f7e365cfe452a433bfef62f71
Comment 5 Jeremy Whiting 2011-11-10 17:14:04 UTC
*** Bug 286143 has been marked as a duplicate of this bug. ***
Comment 6 Halla Rempt 2011-12-30 08:30:29 UTC
Git commit 67f3478806aea135892d1beda70139f63f42c8fc by Boudewijn Rempt.
Committed on 30/12/2011 at 09:28.
Pushed by rempt into branch 'master'.

Only show the GHNS upload button if the attica version is high enough

Attica is buggy prior to 3.0 (a.k.a. 2.9) because of bug 281850. This
caused Krita bug 285441, where upload would fail sometimes because of
missing content-id. There's nothing we can do to fix that from within
Krita, so only show the upload button if the version of attica is new
enough. The download button is always enabled.
Related: bug 285441

M  +7    -0    libs/widgets/KoResourceItemChooser.cpp

http://commits.kde.org/calligra/67f3478806aea135892d1beda70139f63f42c8fc