Bug 281695 - Tasks Marked as completed in Korganiser is not updated on google task (web)
Summary: Tasks Marked as completed in Korganiser is not updated on google task (web)
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Google Resource (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-09 15:44 UTC by Bobby
Modified: 2017-01-07 22:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bobby 2011-09-09 15:44:17 UTC
Version:           GIT (using KDE 4.7.0) 
OS:                Linux

When I mark a task as completed or done on korganiser, the change is not reflected on google calendar (web) and when I do a manual refresh (F5) the same task is changed to unmarked/ uncompleted on korganiser. It would seem that marking task as complete on korganiser does not sync to google web,  hence korganiser takes the status of the task from google task (web) over changes I made to same task locally. 

I however noticed that if I were to make same task as completed via the google task (web) and then do a refresh via kograniser, the task is marked as complete on korganiser. 

Reproducible: Didn't try

Steps to Reproduce:
Mark a task as complete on Korganiser. The do a refresh (F5)

Actual Results:  
The status of the task is switched back to uncompleted. once I do a refresh

Expected Results:  
Task marked as completed on Korganiser is also updated to reflect as completed on google task (web)
Comment 1 Daniel Vrátil 2011-09-09 16:19:28 UTC
Was the task originally created in KOrganizer or was it synced from Google?

Could you please restart akonadi from console (akonadictl restart) and then without closing the console try to reproduce this bug and post here output from the console (just the relevant part, it's usually pretty long :) ? Thanks.
Comment 2 Bobby 2011-09-09 16:46:56 UTC
(In reply to comment #1)
> Was the task originally created in KOrganizer or was it synced from Google?
> 
> Could you please restart akonadi from console (akonadictl restart) and then
> without closing the console try to reproduce this bug and post here output from
> the console (just the relevant part, it's usually pretty long :) ? Thanks.

So I decided to create a test task from korganiser and when I created the task the output on terminal (following your suggestions) was  

Database "akonadi" opened using driver "QMYSQL" 
Known subscriber "korganizer" subscribes again 

However there was no output when I marked the task as completed or when I refreshed. Once the task got updated to google task (web) marking it as completed on korganiser got changed back to uncompleted once I refreshed. It seems it doesn't matter whether the task was created from korganiser or the google task web. Let me know how else I can be of help. Thanks alot :)
Comment 3 Daniel Vrátil 2011-09-11 18:11:23 UTC
I'm still not able to reproduce it. Could you please pull latest sources from git and run cmake with -DDEBUG_RAWDATA=TRUE switch? This will cause libkgoogle to log raw data it is sending and receiving from Google. Try to reproduce the issue again the same way as described in comment #1 and post the output here. Thank you.
Comment 4 Daniel Vrátil 2011-10-15 20:04:18 UTC
ping? :)
Comment 5 Bobby 2011-10-16 03:14:46 UTC
I am so sorry I have not gotten back to you concerning this bug. (Work over 
load) The issue is still there But I am starting to think this might be an api 
bug because I am getting the same issue with astrid google task sync on the 
android. I can only mark a task complete from the google task web. Any task I 
mark complete from korganiser or astrid gets unmarked once I do a refresh. I 
run cmake with -DDEBUG_RAWDATA=TRUE switch still I got no more output than I 
got the last time.

I ran a git pull just before sending this and the problem still persist.

On Saturday 15 October 2011 20:04:19 Dan Vratil wrote:
> https://bugs.kde.org/show_bug.cgi?id=281695
> 
> 
> 
> 
> 
> --- Comment #4 from Dan Vratil <dan progdan cz>  2011-10-15 20:04:18 ---
> ping? :)
Comment 6 Daniel Vrátil 2011-10-19 21:49:44 UTC
Can you check if the resource is selected in KDebugDialog and select it if not? You may need to relog. Then the debug information from resource should be redirected to the .xsession-errors file.
Comment 7 Bobby 2011-10-20 08:29:43 UTC
I followed you instructions and here were the logs I found when I tail 
.xsession-errors 

CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
09:25:19.247 DEBUG MainWindow:1136                  position 110 scrobble 
point 145 status 0 
(process:1704): libindicate-DEBUG: Proxy Indicator Modified
(process:1704): libindicate-DEBUG: Proxy Indicator Modified
(process:1704): libindicate-DEBUG: Proxy Indicator Modified
(process:1704): libindicate-DEBUG: Proxy Indicator Modified
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
09:25:29.247 DEBUG MainWindow:1136                  position 120 scrobble 
point 145 status 0 
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
09:25:39.247 DEBUG MainWindow:1136                  position 130 scrobble 
point 145 status 0 
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
09:25:49.247 DEBUG MainWindow:1136                  position 140 scrobble 
point 145 status 0 
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished

Let me know if its of any use


On Wednesday 19 October 2011 21:49:44 Dan Vratil wrote:
> https://bugs.kde.org/show_bug.cgi?id=281695
> 
> 
> Dan Vratil <dan@progdan.cz> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> Status|UNCONFIRMED                 |ASSIGNED
>      Ever Confirmed|0                           |1
> 
> 
> 
> 
> --- Comment #6 from Dan Vratil <dan progdan cz>  2011-10-19 21:49:44 ---
> Can you check if the resource is selected in KDebugDialog and select it if
> not? You may need to relog. Then the debug information from resource should
> be redirected to the .xsession-errors file.
Comment 8 Daniel Vrátil 2011-10-20 18:58:02 UTC
Thanks, but unfortunately this output is completely irrelevant. Well, not completely, but is not produced by libkgoogle so it does not give me any useful information :(

I'll try to prepare something to get the debug output from the resource next week.
Comment 9 Bobby 2011-10-21 07:05:06 UTC
OK I run a git pull almost every other day to get the latest codes. By the
way, are you able to replicate this bug?
On Oct 20, 2011 7:58 PM, "Dan Vratil" <dan@progdan.cz> wrote:

> https://bugs.kde.org/show_bug.cgi?id=281695
>
>
>
>
>
> --- Comment #8 from Dan Vratil <dan progdan cz>  2011-10-20 18:58:02 ---
> Thanks, but unfortunately this output is completely irrelevant. Well, not
> completely, but is not produced by libkgoogle so it does not give me any
> useful
> information :(
>
> I'll try to prepare something to get the debug output from the resource
> next
> week.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are a voter for the bug.
> You reported the bug.
>
Comment 10 Daniel Vrátil 2011-10-21 11:28:30 UTC
> By the way, are you able to replicate this bug?

That's the problem, I'm not. Updating a task in KOrganizer is immediately visible on Google (and vice versa) for me.

Btw you mentioned in comment #5 that you had similar problem with an Android app. Does it still happen? Could you test with [1] for example, if it works for you there? 

Anyway, I'm still going to make a patch to get the output from resources. I'm really curious what's Google (not) telling us :)

[1] http://kde-apps.org/content/show.php?content=145489
Comment 11 Daniel Vrátil 2011-10-21 11:33:20 UTC
Uhmm, sorry, taking back the part about the test application, it just embeds Google Tasks web interface into a widget, it does not use the Tasks protocol. I'll try to find something else...
Comment 12 Daniel Vrátil 2012-04-06 15:14:24 UTC
Is this issue still valid for you in Akonadi Google 0.3?
Comment 13 Daniel Vrátil 2013-02-28 12:53:13 UTC
Git commit dc1d1e496990b7b65fb422f71bfe82ac751a93e4 by Dan Vrátil.
Committed on 28/02/2013 at 13:19.
Pushed by dvratil into branch 'master'.

Port Akonadi resources for Google services to LibKGAPI2

Resources now use the new job-based API, which is more
flexible and solves many problems that were very hard
to fix with the previous API.

Lot of duplicated code has been factored out and moved
to /resources/google/common.

Featurewise, Google Contacts resources now fully supports
contacts groups and fetching contacts photos has been
notably improved, Google Calendar resource has improved
tasks handling and both resources have better status and
progress reporting and should be faster and more stable.
Related: bug 301647, bug 309320, bug 310741, bug 313368, bug 294639

FIXED-IN: 4.11

DIGEST:

M  +1    -1    CMakeLists.txt
M  +1    -1    resources/google/CMakeLists.txt
M  +5    -10   resources/google/calendar/CMakeLists.txt
D  +0    -102  resources/google/calendar/calendareditor.cpp
D  +0    -55   resources/google/calendar/calendareditor.h
M  +616  -519  resources/google/calendar/calendarresource.cpp
M  +35   -78   resources/google/calendar/calendarresource.h
M  +57   -50   resources/google/calendar/defaultreminderattribute.cpp
M  +17   -20   resources/google/calendar/defaultreminderattribute.h
D  +0    -298  resources/google/calendar/resource_events.cpp
M  +0    -166  resources/google/calendar/resource_tasks.cpp
M  +2    -22   resources/google/calendar/settings.cpp
M  +3    -23   resources/google/calendar/settings.h
M  +128  -731  resources/google/calendar/settingsdialog.cpp
M  +18   -51   resources/google/calendar/settingsdialog.h
D  +0    -52   resources/google/calendar/tasklisteditor.cpp
D  +0    -49   resources/google/calendar/tasklisteditor.h
D  +0    -128  resources/google/calendar/ui/calendar_editor.ui
D  +0    -204  resources/google/calendar/ui/settingsdialog.ui
D  +0    -85   resources/google/calendar/ui/tasklist_editor.ui
A  +244  -0    resources/google/common/googleaccountmanager.cpp     [License: GPL (v2+)]
A  +67   -0    resources/google/common/googleaccountmanager.h     [License: GPL (v2+)]
A  +275  -0    resources/google/common/googleresource.cpp     [License: GPL (v3+)]
A  +109  -0    resources/google/common/googleresource.h     [License: GPL (v3+)]
A  +55   -0    resources/google/common/googlesettings.cpp     [License: GPL (v3+)]
A  +58   -0    resources/google/common/googlesettings.h     [License: GPL (v3+)]
A  +213  -0    resources/google/common/googlesettingsdialog.cpp     [License: GPL (v3+)]
A  +77   -0    resources/google/common/googlesettingsdialog.h     [License: GPL (v3+)]
M  +4    -2    resources/google/contacts/CMakeLists.txt
M  +373  -593  resources/google/contacts/contactsresource.cpp
M  +31   -69   resources/google/contacts/contactsresource.h
M  +3    -24   resources/google/contacts/settings.cpp
M  +3    -23   resources/google/contacts/settings.h
M  +19   -128  resources/google/contacts/settingsdialog.cpp
M  +5    -23   resources/google/contacts/settingsdialog.h
D  +0    -38   resources/google/contacts/ui/groupeditor.ui
D  +0    -61   resources/google/contacts/ui/settingsdialog.ui

http://commits.kde.org/kdepim-runtime/dc1d1e496990b7b65fb422f71bfe82ac751a93e4
Comment 14 Denis Kurz 2016-09-24 20:41:38 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 15 Denis Kurz 2017-01-07 22:02:48 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.