Bug 281442 - kstars crashed when playing with satellite settings
Summary: kstars crashed when playing with satellite settings
Status: RESOLVED DUPLICATE of bug 279028
Alias: None
Product: kstars
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Microsoft Windows Microsoft Windows
: NOR crash (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-06 00:16 UTC by oneeyedelf1
Modified: 2012-04-10 14:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
windbg dump of process (no pdbs 32 bit vc10 4.7.0) (19.38 KB, application/octet-stream)
2011-09-06 00:16 UTC, oneeyedelf1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oneeyedelf1 2011-09-06 00:16:23 UTC
Created attachment 63427 [details]
windbg dump of process (no pdbs 32 bit vc10 4.7.0)

Version:           unspecified (using KDE 4.7.0) 
OS:                MS Windows

windows 7 32 bit, crashed when I was changing settings in the satellite portion of settings.

Reproducible: Didn't try

Steps to Reproduce:
Was configuring kstar's sattelite settings ... beyond that don't really know.

Actual Results:  
process crashed

Expected Results:  
Process does not crash

   0  Id: da0.1a78 Suspend: 1 Teb: 7ffde000 Unfrozen
ChildEBP RetAddr  
009d87b0 77b66a24 ntdll!KiFastSystemCallRet
009d87b4 75d4179c ntdll!NtWaitForSingleObject+0xc
009d8820 7731c2f3 KERNELBASE!WaitForSingleObjectEx+0x98
009d8838 7731c2a2 kernel32!WaitForSingleObjectExImplementation+0x75
009d884c 5a91e389 kernel32!WaitForSingleObject+0x12
009d88d8 5a91e95b kdeui!KCrash::startProcess+0x169 [n:\build\kde\kdelibs-20110130-1\work\kdelibs-4.7.0\kdeui\util\kcrash.cpp @ 470]
009d8abc 5a91e492 kdeui!KCrash::defaultCrashHandler+0x3ab [n:\build\kde\kdelibs-20110130-1\work\kdelibs-4.7.0\kdeui\util\kcrash.cpp @ 435]
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\system32\btmmhook.dll - 
009d8ad0 100102ed kdeui!KCrash::win32UnhandledExceptionFilter+0x52 [n:\build\kde\kdelibs-20110130-1\work\kdelibs-4.7.0\kdeui\util\kcrash.cpp @ 500]
WARNING: Stack unwind information not available. Following frames may be wrong.
009d8b80 77b97f1a btmmhook!SetBtMmHook+0xedbd
009d8b88 77b3e304 ntdll!__RtlUserThreadStart+0x62
009d8b9c 77b3e18c ntdll!_EH4_CallFilterFunc+0x12
009d8bc4 77b671b9 ntdll!_except_handler4+0x8e
009d8be8 77b6718b ntdll!ExecuteHandler2+0x26
009d8c0c 77b3f96f ntdll!ExecuteHandler+0x24
009d8c98 77b67017 ntdll!RtlDispatchException+0x127
009d8c98 010e0350 ntdll!KiUserExceptionDispatcher+0xf
009d8fac 013e0023 0x10e0350
009d8fb4 013e13d8 kstars!QList<DeepStarComponent *>::free+0x3 [n:\include\qtcore\qlist.h @ 744]
009d92a0 014f8ec8 kstars!SkyMapComposite::draw+0x308 [n:\build\kde\kstars-20110622\work\kstars-4.7.0\kstars\skycomponents\skymapcomposite.cpp @ 227]
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Users\knic\Documents\Downloads\bin\QtGui4.dll - 
009d9308 586b6a4f kstars!SkyMapQDraw::paintEvent+0x128 [n:\build\kde\kstars-20110622\work\kstars-4.7.0\kstars\skymapqdraw.cpp @ 62]
009d9414 5866eedd QtGui4!QWidget::event+0x5ff
009d96f4 5a8a77a0 QtGui4!QApplicationPrivate::notify_helper+0x9d
009d9718 5aa57beb kdeui!KApplication::notify+0x120 [n:\build\kde\kdelibs-20110130-1\work\kdelibs-4.7.0\kdeui\kernel\kapplication.cpp @ 312]
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Users\knic\Documents\Downloads\bin\QtCore4.dll - 
009d9760 5a641bb2 kdeui!getpid+0x2a141
009d988c 586b1c60 QtCore4!QCoreApplication::sendSpontaneousEvent+0x22
009d98cc 77b72ce8 QtGui4!QWidgetPrivate::paintSiblingsRecursive+0x380
009d98e4 00000000 ntdll!RtlFreeHeap+0x105

Attached is a windbg dump,
I used the vc10 binaries of the 4.7.0 windows release
Comment 1 Akarsh Simha 2011-09-06 01:40:49 UTC
Thanks for the report!

I've encountered this on Linux as well. Will try fixing it.

Regards
Akarsh
Comment 2 Alexey Khudiakov 2011-11-17 13:22:23 UTC
Could be related to #279028
Comment 3 Alexey Khudiakov 2012-04-10 14:32:30 UTC
Most likely a duplicate of #279028. Please reopen if problem persists with kstars-4.8. Sadly fix wasn't backported to 4.7

*** This bug has been marked as a duplicate of bug 279028 ***