Bug 281342 - TagWidget crash on destruction
Summary: TagWidget crash on destruction
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: libnepomukcore (show other bugs)
Version: 4.7
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 268738 276208 279231 280887 282362 284510 286401 299177 306645 309068 311203 312401 313026 313118 313650 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-04 20:28 UTC by abelius
Modified: 2013-01-22 06:46 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments
New crash information added by DrKonqi (10.68 KB, text/plain)
2011-12-27 21:03 UTC, Hrvoje Senjan
Details
New crash information added by DrKonqi (11.00 KB, text/plain)
2012-08-01 22:17 UTC, Marcus Harrison
Details
New crash information added by DrKonqi (12.25 KB, text/plain)
2012-10-09 19:49 UTC, Thomas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abelius 2011-09-04 20:28:31 UTC
Application: dolphin (1.7)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
* Open Dolphin
* Select a PDF file larger than 10mb 
* Click on add Tag
* When the dialogue appears, wait a few seconds
=> results in crash

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[Current thread is 1 (Thread 0xb77a7710 (LWP 2308))]

Thread 4 (Thread 0xb6af7b70 (LWP 2309)):
#0  0x00f15416 in __kernel_vsyscall ()
#1  0x001ee753 in ?? () from /lib/i386-linux-gnu/libc.so.6
#2  0x00181b94 in ?? () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0xb5100b70 (LWP 2338)):
#0  0x00f15416 in __kernel_vsyscall ()
#1  0x001d1f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x034f984b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x034e91af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x034e9524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x01323577 in QEventDispatcherGlib::processEvents (this=0xb6100d58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x012f5289 in QEventLoop::processEvents (this=0xb5100290, flags=...) at kernel/qeventloop.cpp:149
#7  0x012f5522 in QEventLoop::exec (this=0xb5100290, flags=...) at kernel/qeventloop.cpp:201
#8  0x011ff2a0 in QThread::exec (this=0x9534c50) at thread/qthread.cpp:492
#9  0x012d6fdb in QInotifyFileSystemWatcherEngine::run (this=0x9534c50) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01201da2 in QThreadPrivate::start (arg=0x9534c50) at thread/qthread_unix.cpp:320
#11 0x00c7ae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb4870b70 (LWP 2342)):
#0  0x00f15416 in __kernel_vsyscall ()
#1  0x001ee753 in ?? () from /lib/i386-linux-gnu/libc.so.6
#2  0x00181b94 in ?? () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb77a7710 (LWP 2308)):
[KCrash Handler]
#7  0x00f15416 in __kernel_vsyscall ()
#8  0x0013ae71 in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0x0013e34e in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0x00171577 in ?? () from /lib/i386-linux-gnu/libc.so.6
#11 0x0017b961 in ?? () from /lib/i386-linux-gnu/libc.so.6
#12 0x0017d28b in ?? () from /lib/i386-linux-gnu/libc.so.6
#13 0x0018041d in free () from /lib/i386-linux-gnu/libc.so.6
#14 0x008c84d1 in operator delete(void*) () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#15 0x004419da in KEditTagsDialog::~KEditTagsDialog (this=0xbfaeebc8, __in_chrg=<value optimized out>) at ../../nepomuk/ui/kedittagsdialog.cpp:104
#16 0x01309b87 in QObjectPrivate::deleteChildren (this=0x9788f88) at kernel/qobject.cpp:1964
#17 0x064b4144 in QWidget::~QWidget (this=0x97c0a60, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1631
#18 0x0043e9c4 in Nepomuk::TagWidget::~TagWidget (this=0x97c0a60, __in_chrg=<value optimized out>) at ../../nepomuk/ui/tagwidget.cpp:265
#19 0x0043ea22 in Nepomuk::TagWidget::~TagWidget (this=0x97c0a60, __in_chrg=<value optimized out>) at ../../nepomuk/ui/tagwidget.cpp:268
#20 0x01112fba in KFileMetaDataWidget::Private::deleteRows (this=0x91e16c0) at ../../kio/kfile/kfilemetadatawidget.cpp:184
#21 0x01113012 in KFileMetaDataWidget::Private::slotLoadingFinished (this=0x91e16c0) at ../../kio/kfile/kfilemetadatawidget.cpp:192
#22 0x01113a7e in KFileMetaDataWidget::qt_metacall (this=0x957d3e8, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfaededc) at ./kfilemetadatawidget.moc:88
#23 0x012fc6ba in QMetaObject::metacall (object=0x957d3e8, cl=QMetaObject::InvokeMetaMethod, idx=29, argv=0xbfaededc) at kernel/qmetaobject.cpp:237
#24 0x0130c4ff in QMetaObject::activate (sender=0x91d96e0, m=0x119d264, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#25 0x0114cac7 in KFileMetaDataProvider::loadingFinished (this=0x91d96e0) at ./kfilemetadataprovider_p.moc:110
#26 0x0114dc48 in KFileMetaDataProvider::Private::slotLoadingFinished (this=0x9598a40) at ../../kio/kfile/kfilemetadataprovider.cpp:222
#27 0x0114e656 in KFileMetaDataProvider::qt_metacall (this=0x91d96e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfaee0ec) at ./kfilemetadataprovider_p.moc:94
#28 0x012fc6ba in QMetaObject::metacall (object=0x91d96e0, cl=QMetaObject::InvokeMetaMethod, idx=8, argv=0xbfaee0ec) at kernel/qmetaobject.cpp:237
#29 0x0130c4ff in QMetaObject::activate (sender=0x9723b98, m=0x119d208, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#30 0x0114b797 in KFileMetaDataReader::finished (this=0x9723b98) at ./kfilemetadatareader_p.moc:88
#31 0x0114b97f in KFileMetaDataReader::Private::slotLoadingFinished (this=0x97e2d48, exitCode=0, exitStatus=QProcess::NormalExit) at ../../kio/kfile/kfilemetadatareader.cpp:96
#32 0x0114bbb0 in KFileMetaDataReader::qt_metacall (this=0x9723b98, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfaee2d4) at ./kfilemetadatareader_p.moc:77
#33 0x012fc6ba in QMetaObject::metacall (object=0x9723b98, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xbfaee2d4) at kernel/qmetaobject.cpp:237
#34 0x0130c4ff in QMetaObject::activate (sender=0x971d6f8, m=0x142f6e8, local_signal_index=2, argv=0xbfaee2d4) at kernel/qobject.cpp:3287
#35 0x01290719 in QProcess::finished (this=0x971d6f8, _t1=0, _t2=QProcess::NormalExit) at .moc/release-shared/moc_qprocess.cpp:142
#36 0x01295c30 in QProcessPrivate::_q_processDied (this=0x97431a0) at io/qprocess.cpp:1051
#37 0x01295d0e in QProcess::qt_metacall (this=0x971d6f8, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbfaee478) at .moc/release-shared/moc_qprocess.cpp:115
#38 0x030433fa in KProcess::qt_metacall (this=0x971d6f8, _c=QMetaObject::InvokeMetaMethod, _id=21, _a=0xbfaee478) at ./kprocess.moc:69
#39 0x012fc6ba in QMetaObject::metacall (object=0x971d6f8, cl=QMetaObject::InvokeMetaMethod, idx=21, argv=0xbfaee478) at kernel/qmetaobject.cpp:237
#40 0x0130c4ff in QMetaObject::activate (sender=0x97434c0, m=0x1431550, local_signal_index=0, argv=0xbfaee478) at kernel/qobject.cpp:3287
#41 0x01359183 in QSocketNotifier::activated (this=0x97434c0, _t1=35) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#42 0x01311fb7 in QSocketNotifier::event (this=0x97434c0, e=0xbfaee8f4) at kernel/qsocketnotifier.cpp:317
#43 0x06460d24 in QApplicationPrivate::notify_helper (this=0x9180af0, receiver=0x97434c0, e=0xbfaee8f4) at kernel/qapplication.cpp:4462
#44 0x064658ce in QApplication::notify (this=0xbfaf01d4, receiver=0x97434c0, e=0xbfaee8f4) at kernel/qapplication.cpp:3862
#45 0x0525493a in KApplication::notify (this=0xbfaf01d4, receiver=0x97434c0, event=0xbfaee8f4) at ../../kdeui/kernel/kapplication.cpp:311
#46 0x012f60bb in QCoreApplication::notifyInternal (this=0xbfaf01d4, receiver=0x97434c0, event=0xbfaee8f4) at kernel/qcoreapplication.cpp:731
#47 0x01322ec7 in sendEvent (source=0x9185c60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#48 socketNotifierSourceDispatch (source=0x9185c60) at kernel/qeventdispatcher_glib.cpp:110
#49 0x034e8aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#50 0x034e9270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0x034e9524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#52 0x01323577 in QEventDispatcherGlib::processEvents (this=0x914e418, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#53 0x065171e5 in QGuiEventDispatcherGlib::processEvents (this=0x914e418, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x012f5289 in QEventLoop::processEvents (this=0xbfaeeb70, flags=...) at kernel/qeventloop.cpp:149
#55 0x012f5522 in QEventLoop::exec (this=0xbfaeeb70, flags=...) at kernel/qeventloop.cpp:201
#56 0x06980a93 in QDialog::exec (this=0xbfaeebc8) at dialogs/qdialog.cpp:552
#57 0x0043f92c in Nepomuk::TagWidget::slotShowAll (this=0x97c0a60) at ../../nepomuk/ui/tagwidget.cpp:383
#58 0x00440493 in Nepomuk::TagWidget::qt_metacall (this=0x97c0a60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfaeed58) at ./tagwidget.moc:104
#59 0x012fc6ba in QMetaObject::metacall (object=0x97c0a60, cl=QMetaObject::InvokeMetaMethod, idx=36, argv=0xbfaeed58) at kernel/qmetaobject.cpp:237
#60 0x0130c4ff in QMetaObject::activate (sender=0x98189f0, m=0x6d995ac, local_signal_index=0, argv=0xbfaeed58) at kernel/qobject.cpp:3287
#61 0x068b4dc3 in QLabel::linkActivated (this=0x98189f0, _t1=...) at .moc/release-shared/moc_qlabel.cpp:180
#62 0x068b50fd in QLabel::qt_metacall (this=0x98189f0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfaeee88) at .moc/release-shared/moc_qlabel.cpp:110
#63 0x012fc6ba in QMetaObject::metacall (object=0x98189f0, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbfaeee88) at kernel/qmetaobject.cpp:237
#64 0x0130c4ff in QMetaObject::activate (sender=0x97435e0, m=0x6d96c8c, local_signal_index=13, argv=0xbfaeee88) at kernel/qobject.cpp:3287
#65 0x066c5783 in QTextControl::linkActivated (this=0x97435e0, _t1=...) at .moc/release-shared/moc_qtextcontrol_p.cpp:322
#66 0x066c8ecd in QTextControlPrivate::activateLinkUnderCursor (this=0x97c3090, href=...) at text/qtextcontrol.cpp:2621
#67 0x066c9768 in QTextControlPrivate::mouseReleaseEvent (this=0x97c3090, button=Qt::LeftButton, pos=...) at text/qtextcontrol.cpp:1710
#68 0x066cca8c in QTextControl::processEvent (this=0x97435e0, e=0xbfaef954, matrix=..., contextWidget=0x98189f0) at text/qtextcontrol.cpp:937
#69 0x066c1f40 in QTextControl::processEvent (this=0x97435e0, e=0xbfaef954, coordinateOffset=..., contextWidget=0x98189f0) at text/qtextcontrol.cpp:884
#70 0x068b34f9 in QLabelPrivate::sendControlEvent (this=0x97baac8, e=0xbfaef954) at widgets/qlabel.cpp:1627
#71 0x064b913a in QWidget::event (this=0x98189f0, event=0xbfaef954) at kernel/qwidget.cpp:8259
#72 0x068ad9f3 in QFrame::event (this=0x98189f0, e=0xbfaef954) at widgets/qframe.cpp:557
#73 0x068b07fa in QLabel::event (this=0x98189f0, e=0xbfaef954) at widgets/qlabel.cpp:1049
#74 0x06460d24 in QApplicationPrivate::notify_helper (this=0x9180af0, receiver=0x98189f0, e=0xbfaef954) at kernel/qapplication.cpp:4462
#75 0x06466201 in QApplication::notify (this=0xbfaf01d4, receiver=0x98189f0, e=0xbfaef954) at kernel/qapplication.cpp:4023
#76 0x0525493a in KApplication::notify (this=0xbfaf01d4, receiver=0x98189f0, event=0xbfaef954) at ../../kdeui/kernel/kapplication.cpp:311
#77 0x012f60bb in QCoreApplication::notifyInternal (this=0xbfaf01d4, receiver=0x98189f0, event=0xbfaef954) at kernel/qcoreapplication.cpp:731
#78 0x06461c3b in sendSpontaneousEvent (receiver=0x98189f0, event=0xbfaef954, alienWidget=0x98189f0, nativeWidget=0x9501a08, buttonDown=0x6dafc60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#79 QApplicationPrivate::sendMouseEvent (receiver=0x98189f0, event=0xbfaef954, alienWidget=0x98189f0, nativeWidget=0x9501a08, buttonDown=0x6dafc60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#80 0x064ed04c in QETWidget::translateMouseEvent (this=0x9501a08, event=0xbfaefe7c) at kernel/qapplication_x11.cpp:4558
#81 0x064eb9b5 in QApplication::x11ProcessEvent (this=0xbfaf01d4, event=0xbfaefe7c) at kernel/qapplication_x11.cpp:3680
#82 0x065175f4 in x11EventSourceDispatch (s=0x91861a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#83 0x034e8aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#84 0x034e9270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#85 0x034e9524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#86 0x0132353c in QEventDispatcherGlib::processEvents (this=0x914e418, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#87 0x065171e5 in QGuiEventDispatcherGlib::processEvents (this=0x914e418, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#88 0x012f5289 in QEventLoop::processEvents (this=0xbfaf0144, flags=...) at kernel/qeventloop.cpp:149
#89 0x012f5522 in QEventLoop::exec (this=0xbfaf0144, flags=...) at kernel/qeventloop.cpp:201
#90 0x012f9ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#91 0x0645e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#92 0x007b0169 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#93 0x080485bb in _start ()

Possible duplicates by query: bug 276208, bug 267046.

Reported using DrKonqi
Comment 1 Peter Penz 2011-09-05 05:42:33 UTC

*** This bug has been marked as a duplicate of bug 276208 ***
Comment 2 abelius 2011-09-05 10:01:50 UTC
Dear All,

This bug has been marked as a duplicate of bug:276208 (https://bugs.kde.org/show_bug.cgi?id=276208). However, I can not reproduce the crash reported in this bug (see comments on bug 276208). 
Also, I need to stress that I don't see the crash reported here for PDF files smaller than 10mb. If someone has an additional test case I can try, let me know.
Comment 3 Jekyll Wu 2011-09-22 18:45:58 UTC
*** Bug 279231 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2011-09-22 18:46:39 UTC
*** Bug 280887 has been marked as a duplicate of this bug. ***
Comment 5 Jekyll Wu 2011-12-04 13:26:31 UTC
[from bug 284510]

- What I was doing when the application crashed:
I selected more than 350 pictures in a folder and clicked on 'add tag'.

It doesn't crash when the size of the selected pictures is lower than 1GiB, but
almost instantly crashes when the combined size of all selected pictures is
only very little above 1GiB.

The crash can be reproduced every time.
Comment 6 Jekyll Wu 2011-12-04 13:26:43 UTC
*** Bug 284510 has been marked as a duplicate of this bug. ***
Comment 7 Hrvoje Senjan 2011-12-27 21:03:17 UTC
Created attachment 67166 [details]
New crash information added by DrKonqi

dolphin (1.99) on KDE Platform 4.7.95 (4.8 RC1 (4.7.95) "release 10" using Qt 4.8.0

- What I was doing when the application crashed:

Same as Jekyll, selected multiple images , clicked add tag , and dolphin crashed. Altough overall size of selected images is little over 100MB.
Using 4.8 RC1

-- Backtrace (Reduced):
#10 0x00007f8da7798e05 in QObjectPrivate::deleteChildren (this=0x18cda10) at kernel/qobject.cpp:1917
#11 0x00007f8da6939b90 in QWidget::~QWidget (this=0x1ecc860, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1675
#12 0x00007f8da053d5e9 in Nepomuk::TagWidget::~TagWidget (this=0x1ecc860, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.95/nepomuk/ui/tagwidget.cpp:268
#13 0x00007f8da0998607 in KFileMetaDataWidget::Private::deleteRows (this=0xd2c040) at /usr/src/debug/kdelibs-4.7.95/kio/kfile/kfilemetadatawidget.cpp:184
#14 0x00007f8da0998da9 in KFileMetaDataWidget::Private::slotLoadingFinished (this=0xd2c040) at /usr/src/debug/kdelibs-4.7.95/kio/kfile/kfilemetadatawidget.cpp:192
Comment 8 Jekyll Wu 2012-05-31 19:56:58 UTC
*** Bug 286401 has been marked as a duplicate of this bug. ***
Comment 9 Jekyll Wu 2012-05-31 19:57:08 UTC
*** Bug 299177 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2012-05-31 19:58:45 UTC
*** Bug 268738 has been marked as a duplicate of this bug. ***
Comment 11 Jekyll Wu 2012-07-05 12:02:56 UTC
*** Bug 282362 has been marked as a duplicate of this bug. ***
Comment 12 Vishesh Handa 2012-07-10 21:00:10 UTC
Thanks a lot for the detailed bug report.

I can't seem to reproduce it, but I did get a similar backtrace myself.
Comment 13 Marcus Harrison 2012-08-01 22:17:27 UTC
Created attachment 72882 [details]
New crash information added by DrKonqi

dolphin (2.1) on KDE Platform 4.9.00 using Qt 4.8.1

- What I was doing when the application crashed:

I experienced this crash under the following conditions:
1. Nepomuk was indexing and had not completed yet;
2. I had selected multiple files and clicked, "Add Tags..." in the Information window.

It is not reproduceable every time, unfortunately, but I will attempt to narrow down the cause and more reliably reproduce the crash.

-- Backtrace (Reduced):
#6  0x00007f0dca77a04c in __GI___libc_free (mem=0x7fffc80e1920) at malloc.c:2982
#7  0x00007f0dc7527935 in QObjectPrivate::deleteChildren (this=0x1cad700) at kernel/qobject.cpp:1908
#8  0x00007f0dc6665740 in QWidget::~QWidget (this=0x1d1e740, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1676
#9  0x00007f0dc90506b9 in Nepomuk::TagWidget::~TagWidget (this=0x1d1e740, __in_chrg=<optimized out>) at ../../nepomuk/ui/tagwidget.cpp:268
#10 0x00007f0dc87d8e17 in KFileMetaDataWidget::Private::deleteRows (this=0x13a2990) at ../../kio/kfile/kfilemetadatawidget.cpp:184
Comment 14 Vishesh Handa 2012-08-02 07:05:30 UTC
*** Bug 276208 has been marked as a duplicate of this bug. ***
Comment 15 Vishesh Handa 2012-09-25 10:46:30 UTC
*** Bug 306645 has been marked as a duplicate of this bug. ***
Comment 16 Thomas 2012-10-09 19:49:28 UTC
Created attachment 74447 [details]
New crash information added by DrKonqi

dolphin (2.0) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:
* Open Dolphin
* Selected multiple files (148 video files; >200MiB/file) in 4 folders (using detailed viewmode and expanding the folders)
* Click on add Tag
* When the dialogue appears, wait a few seconds
=> results in crash

reproducible every time when selecting all files

sometimes reproducible when i only select a part of the files(eg. 1 folder with 48 files).

sorry about the long backtrace, but idk what is useful and what is not, so i can’t reduce it

-- Backtrace (Reduced):
#6  0x00007f685bd825bc in __GI___libc_free (mem=0x7fffdb320640) at malloc.c:2982
#7  0x00007f6858e54935 in QObjectPrivate::deleteChildren (this=0x267a580) at kernel/qobject.cpp:1908
#8  0x00007f6857f92740 in QWidget::~QWidget (this=0x2dd3610, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1676
#9  0x00007f685a974349 in Nepomuk::TagWidget::~TagWidget (this=0x2dd3610, __in_chrg=<optimized out>) at ../../nepomuk/ui/tagwidget.cpp:268
#10 0x00007f6859ec1d57 in KFileMetaDataWidget::Private::deleteRows (this=0x2909980) at ../../kio/kfile/kfilemetadatawidget.cpp:184
Comment 17 Vishesh Handa 2012-11-30 23:10:27 UTC
*** Bug 309068 has been marked as a duplicate of this bug. ***
Comment 18 Vishesh Handa 2012-12-22 11:11:07 UTC
*** Bug 311203 has been marked as a duplicate of this bug. ***
Comment 19 Frank Reininghaus 2013-01-03 08:21:33 UTC
*** Bug 312401 has been marked as a duplicate of this bug. ***
Comment 20 Vishesh Handa 2013-01-11 19:19:21 UTC
*** Bug 313026 has been marked as a duplicate of this bug. ***
Comment 21 Emmanuel Pescosta 2013-01-12 07:30:25 UTC
*** Bug 313118 has been marked as a duplicate of this bug. ***
Comment 22 Vishesh Handa 2013-01-16 10:45:34 UTC
Git commit 2080bc1d4fe7c249c28930b18f03741c53025b13 by Vishesh Handa.
Committed on 11/01/2013 at 20:09.
Pushed by vhanda into branch 'KDE/4.10'.

KEditTagsDialog: Avoid using QDialog::exec

QDialog::exec runs an event loop at waits for the dialog to be closed.
Running another event loop is generally not recommended cause it can
result in *other* events being process which one might not want.

In this particular case the ResourceLoader, which runs in another
thread, would emit the finished signal would result in the
FileMetadataWidget deleting all its previous content, which would
delete the TagWidget and its children aka the KEditTagsDialog => CRASH

Instead we now set the windowModality and use QDialog::open, which
returns immediately and then connect to the finished signal.
REVIEW: 108354

M  +1    -0    ui/filemetadatawidget.cpp
M  +14   -3    ui/tagwidget.cpp
M  +1    -0    ui/tagwidget.h
M  +3    -0    ui/tagwidget_p.h

http://commits.kde.org/nepomuk-widgets/2080bc1d4fe7c249c28930b18f03741c53025b13
Comment 23 Vishesh Handa 2013-01-22 06:46:24 UTC
*** Bug 313650 has been marked as a duplicate of this bug. ***