Bug 281278 - Save and load routes in the Routing Widget
Summary: Save and load routes in the Routing Widget
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: 1.3 (KDE 4.8)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-03 17:21 UTC by Florian Eßer
Modified: 2012-05-13 21:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: KDE-4.9.0


Attachments
Patch to add save and load buttons to the RoutingWidget (2.70 KB, patch)
2011-09-03 17:21 UTC, Florian Eßer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Eßer 2011-09-03 17:21:28 UTC
Created attachment 63359 [details]
Patch to add save and load buttons to the RoutingWidget

Version:           unspecified (using Devel) 
OS:                Linux

I often use Marble's routing ability to plan somewhat longer routes with a lot of manually-tweaked waypoints (e.g. for cycling). I would like to be able not only to export the final gpx/kml file of the route, but also to save and reload it's "source" (the waypoints).

Basically, this functionality is already built in. The recently edited route is automatically saved to ~/.local/share/marble/routing/route.kml and restored on startup. But if I just quickly want to plan another route inbetween, all the previous work on the "big" route is gone.

Since I don't like to manually backup and restore the route.kml every time, I created this small patch to add save and load buttons to the RoutingWidget.


Reproducible: Always



Expected Results:  
Comfortable route saving and loading via the GUI.
Comment 1 Dennis Nienhüser 2012-05-13 21:10:21 UTC
Git commit 70003fa4d415f545c66d0ee13b16d18f7c4d812f by Dennis Nienhüser.
Committed on 13/05/2012 at 22:54.
Pushed by nienhueser into branch 'master'.

Make common tasks easier/possible in the user interface.

Adds buttons to open a route (from .kml), clear the current one,
reverse it, add a via point and save it.
GUI:
REVIEW: 102539
Related: bug 285090, bug 278625
FIXED-IN: KDE-4.9.0

A  +-    --    src/icons/16x16/configure.png
A  +-    --    src/icons/16x16/document-open.png
A  +-    --    src/icons/16x16/document-save.png
M  +19   -33   src/lib/routing/RoutingWidget.cpp
M  +72   -16   src/lib/routing/RoutingWidget.ui
M  +3    -0    src/marble.qrc

http://commits.kde.org/marble/70003fa4d415f545c66d0ee13b16d18f7c4d812f