Bug 280991 - crash after commenting/uncommenting some hundreds of lines in a large file (5.8MiB)
Summary: crash after commenting/uncommenting some hundreds of lines in a large file (5...
Status: RESOLVED DUPLICATE of bug 245663
Alias: None
Product: kate
Classification: Applications
Component: part (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-29 12:14 UTC by g2spot
Modified: 2011-09-09 13:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description g2spot 2011-08-29 12:14:10 UTC
Application: kate (3.7.0)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

1) open file
2) search for commented area
3) select commented area with click -> shift-click
4) hit CTRL-SHIFT-D or select uncomment form Tools menu
5) crash

Same behaviour with CTRL-D / comment. Every tenth time or so it works without crashing. Memory usage not unusually high.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8825a00780 (LWP 4836))]

Thread 3 (Thread 0x7f88144df700 (LWP 4837)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f88150c02a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f88153d9180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f88150c02d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f88153e7254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f88229e5d8c in start_thread (arg=0x7f88144df700) at pthread_create.c:304
#4  0x00007f882536404d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f88113f9700 (LWP 4840)):
#0  0x00007f8825356f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f882251a104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f882251a639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f88232bf446 in QEventDispatcherGlib::processEvents (this=0x1053b60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8823293882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8823293abc in QEventLoop::exec (this=0x7f88113f8dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f88231aa924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f8823275c2f in QInotifyFileSystemWatcherEngine::run (this=0x119b860) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f88231ad175 in QThreadPrivate::start (arg=0x119b860) at thread/qthread_unix.cpp:320
#9  0x00007f88229e5d8c in start_thread (arg=0x7f88113f9700) at pthread_create.c:304
#10 0x00007f882536404d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8825a00780 (LWP 4836)):
[KCrash Handler]
#6  0x00007f8815757790 in KateHighlighting::dropDynamicContexts (this=0xf4e940) at ../../part/syntax/katehighlight.cpp:240
#7  0x00007f8815751fef in KateHlManager::resetDynamicCtxs (this=0xe3bcb0) at ../../part/syntax/katesyntaxmanager.cpp:412
#8  0x00007f8815716129 in KateBuffer::doHighlight (this=0xf8a130, startLine=61957, endLine=62043, invalidate=false) at ../../part/document/katebuffer.cpp:410
#9  0x00007f8815717974 in KateBuffer::ensureHighlighted (this=0xf8a130, line=<value optimized out>) at ../../part/document/katebuffer.cpp:245
#10 0x00007f881578a975 in KateViewInternal::editEnd (this=0x11b6890, editTagLineStart=50323, editTagLineEnd=61956, tagFrom=false) at ../../part/view/kateviewinternal.cpp:3274
#11 0x00007f8815700be8 in KateDocument::editEnd (this=0xf89630) at ../../part/document/katedocument.cpp:856
#12 0x00007f8815701a01 in KateDocument::removeStartLineCommentFromSelection (this=0xf89630, view=<value optimized out>, attrib=<value optimized out>) at ../../part/document/katedocument.cpp:3297
#13 0x00007f88157033fe in KateDocument::comment (this=0xf89630, v=0x11f4970, line=61956, column=17, change=-1) at ../../part/document/katedocument.cpp:3398
#14 0x00007f8815775ac6 in KateView::uncomment (this=0x11f4970) at ../../part/view/kateview.cpp:2220
#15 0x00007f881577a5ad in KateView::qt_metacall (this=0x11f4970, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0x7fff064cf6e0) at ./kateview.moc:365
#16 0x00007f88232a95f8 in QMetaObject::activate (sender=0x1257e00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff064cf6e0) at kernel/qobject.cpp:3287
#17 0x00007f8824790122 in QAction::triggered (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f882479030f in QAction::activate (this=0x1257e00, event=<value optimized out>) at kernel/qaction.cpp:1257
#19 0x00007f8824bd49f3 in QMenuPrivate::activateCausedStack (this=0x117c030, causedStack=..., action=0x1257e00, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:993
#20 0x00007f8824bda9aa in QMenuPrivate::activateAction (this=0x117c030, action=0x1257e00, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1085
#21 0x00007f8823b2754d in KMenu::mouseReleaseEvent (this=0x117bff0, e=<value optimized out>) at ../../kdeui/widgets/kmenu.cpp:458
#22 0x00007f88247e7cc8 in QWidget::event (this=0x117bff0, event=0x7fff064d0310) at kernel/qwidget.cpp:8259
#23 0x00007f8824bdbb8b in QMenu::event (this=0x117bff0, e=0x7fff064d0310) at widgets/qmenu.cpp:2415
#24 0x00007f88247969f4 in QApplicationPrivate::notify_helper (this=0xcdf640, receiver=0x117bff0, e=0x7fff064d0310) at kernel/qapplication.cpp:4462
#25 0x00007f882479bdc3 in QApplication::notify (this=<value optimized out>, receiver=0x117bff0, e=0x7fff064d0310) at kernel/qapplication.cpp:4023
#26 0x00007f8823a68796 in KApplication::notify (this=0x7fff064d1010, receiver=0x117bff0, event=0x7fff064d0310) at ../../kdeui/kernel/kapplication.cpp:311
#27 0x00007f882329449c in QCoreApplication::notifyInternal (this=0x7fff064d1010, receiver=0x117bff0, event=0x7fff064d0310) at kernel/qcoreapplication.cpp:731
#28 0x00007f8824797a1d in sendEvent (receiver=0x117bff0, event=0x7fff064d0310, alienWidget=0x0, nativeWidget=0x117bff0, buttonDown=0x7f882527a218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QApplicationPrivate::sendMouseEvent (receiver=0x117bff0, event=0x7fff064d0310, alienWidget=0x0, nativeWidget=0x117bff0, buttonDown=0x7f882527a218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#30 0x00007f88248193e4 in QETWidget::translateMouseEvent (this=0x117bff0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4492
#31 0x00007f8824817ab7 in QApplication::x11ProcessEvent (this=0x7fff064d1010, event=0x7fff064d0c60) at kernel/qapplication_x11.cpp:3680
#32 0x00007f8824840842 in x11EventSourceDispatch (s=0xce2d90, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#33 0x00007f8822519bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f882251a3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f882251a639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f88232bf3ef in QEventDispatcherGlib::processEvents (this=0xc85340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#37 0x00007f88248404de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f8823293882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f8823293abc in QEventLoop::exec (this=0x7fff064d0f60, flags=...) at kernel/qeventloop.cpp:201
#40 0x00007f8823297ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#41 0x00007f88256193e5 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../kate/app/katemain.cpp:377
#42 0x00007f882529ceff in __libc_start_main (main=0x400730 <main(int, char**)>, argc=3, ubp_av=0x7fff064d2548, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff064d2538) at libc-start.c:226
#43 0x0000000000400659 in _start ()

This bug may be a duplicate of or related to bug 245663.

Possible duplicates by query: bug 245663, bug 225345.

Reported using DrKonqi
Comment 1 Dominik Haumann 2011-09-09 13:27:13 UTC

*** This bug has been marked as a duplicate of bug 245663 ***