Bug 280815 - KDE Daemon crash
Summary: KDE Daemon crash
Status: RESOLVED DUPLICATE of bug 256712
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-26 04:14 UTC by westsideseattlite
Modified: 2011-08-26 10:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description westsideseattlite 2011-08-26 04:14:46 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
This happened a few minutes after launching the gcaldaemon

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0x7f34732fc780 (LWP 2886))]

Thread 4 (Thread 0x7f345a8b8700 (LWP 2889)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f345a8b7b10 in ?? ()
#2  0x00007fff02f5a7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7f345a0b7700 (LWP 2894)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f345a0b6ae0 in ?? ()
#2  0x00007fff02f5a7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f34598b6700 (LWP 2895)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007f3470b6580f in _L_lock_12013 () from /lib/x86_64-linux-gnu/libc.so.6
#2  0x00007f3470b638d8 in __libc_free (mem=0x7f3470e761c0) at malloc.c:3736
#3  0x00007f346dfd29b4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3471fa87aa in QEventDispatcherGlib::~QEventDispatcherGlib (this=0xfede10, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:373
#5  0x00007f3471fa88f9 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0xfede10, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:401
#6  0x00007f3471e954d4 in QThreadPrivate::finish (arg=0x7f34722b0f60) at thread/qthread_unix.cpp:356
#7  0x00007f3471e9617d in ~__pthread_cleanup_class (arg=0x7f34722b0f60) at /usr/include/pthread.h:545
#8  QThreadPrivate::start (arg=0x7f34722b0f60) at thread/qthread_unix.cpp:279
#9  0x00007f346e696d8c in start_thread (arg=0x7f34598b6700) at pthread_create.c:304
#10 0x00007f3470bcd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f34732fc780 (LWP 2886)):
[KCrash Handler]
#6  0x00007f3470b1ad05 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f3470b1eab6 in abort () at abort.c:92
#8  0x00007f3470b53d7b in __libc_message (do_abort=2, fmt=0x7f3470c3c400 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#9  0x00007f3470b5fa8f in malloc_printerr (av=<value optimized out>, p=0xf30190) at malloc.c:6283
#10 _int_free (av=<value optimized out>, p=0xf30190) at malloc.c:4795
#11 0x00007f3470b638e3 in __libc_free (mem=<value optimized out>) at malloc.c:3738
#12 0x00007f346b4df8ed in KIO::AuthInfo::~AuthInfo (this=0xf56490, __in_chrg=<value optimized out>) at ../../kio/kio/authinfo.cpp:128
#13 0x00007f344940e866 in ~AuthInfoContainer (this=0xff5db0, key=<value optimized out>, info=...) at ../../kpasswdserver/kpasswdserver.h:81
#14 KPasswdServer::findAuthInfoItem (this=0xff5db0, key=<value optimized out>, info=...) at ../../kpasswdserver/kpasswdserver.cpp:749
#15 0x00007f344940ea1c in KPasswdServer::checkAuthInfoAsync (this=0xff5db0, info=..., windowId=0, usertime=<value optimized out>) at ../../kpasswdserver/kpasswdserver.cpp:306
#16 0x00007f34494142da in KPasswdServerAdaptor::checkAuthInfoAsync (this=0x114ca70, info=<value optimized out>, windowId=0, usertime=9674313) at kpasswdserveradaptor.cpp:57
#17 0x00007f34494146a5 in KPasswdServerAdaptor::qt_metacall (this=0x114ca70, _c=<value optimized out>, _id=5, _a=0x7fff02f302e0) at kpasswdserveradaptor.moc:151
#18 0x00007f346f5bd9fa in QDBusConnectionPrivate::deliverCall (this=0xeb7900, object=0x114ca70, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:942
#19 0x00007f346f5bebb5 in QDBusConnectionPrivate::activateCall (this=0xeb7900, object=0x114ca70, flags=497, msg=...) at qdbusintegrator.cpp:852
#20 0x00007f346f5bf33a in QDBusConnectionPrivate::activateObject (this=0xeb7900, node=..., msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1410
#21 0x00007f346f5bf578 in QDBusActivateObjectEvent::placeMetaCall (this=0x119a4c0) at qdbusintegrator.cpp:1524
#22 0x00007f3471f9149a in QObject::event (this=0xff5db0, e=<value optimized out>) at kernel/qobject.cpp:1226
#23 0x00007f347133a9f4 in QApplicationPrivate::notify_helper (this=0xec3f90, receiver=0xff5db0, e=0x119a4c0) at kernel/qapplication.cpp:4462
#24 0x00007f347133f3ba in QApplication::notify (this=<value optimized out>, receiver=0xff5db0, e=0x119a4c0) at kernel/qapplication.cpp:4341
#25 0x00007f3472cf8866 in KApplication::notify (this=0x7fff02f30f60, receiver=0xff5db0, event=0x119a4c0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f3471f7d49c in QCoreApplication::notifyInternal (this=0x7fff02f30f60, receiver=0xff5db0, event=0x119a4c0) at kernel/qcoreapplication.cpp:731
#27 0x00007f3471f80c25 in sendEvent (receiver=0x0, event_type=0, data=0xdf0890) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xdf0890) at kernel/qcoreapplication.cpp:1372
#29 0x00007f3471fa8253 in sendPostedEvents (s=0xec62b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=0xec62b0) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f346dfd6bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f346dfd73a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f346dfd7639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f3471fa83ef in QEventDispatcherGlib::processEvents (this=0xdf1ce0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007f34713e44de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f3471f7c882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f3471f7cabc in QEventLoop::exec (this=0x7fff02f30ef0, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f3471f80ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#39 0x00007f3462614135 in kdemain (argc=1, argv=0xe81150) at ../../kded/kded.cpp:925
#40 0x0000000000406dd3 in launch (argc=1, _name=0x40b2d7 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b15e "0") at ../../kinit/kinit.cpp:746
#41 0x00000000004098fe in main (argc=4, argv=0x7fff02f32078, envp=0x7fff02f320a0) at ../../kinit/kinit.cpp:1861

Possible duplicates by query: bug 278756, bug 278689, bug 277371, bug 277138, bug 275788.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-26 10:25:38 UTC

*** This bug has been marked as a duplicate of bug 256712 ***