Bug 280761 - crash after entering sieve password during fetch mail
Summary: crash after entering sieve password during fetch mail
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.13.2
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 298396 304016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-25 11:45 UTC by Milian Wolff
Modified: 2017-01-07 22:16 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.98 KB, text/plain)
2012-05-06 09:39 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (6.63 KB, text/plain)
2012-06-30 13:33 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (6.51 KB, text/plain)
2012-08-08 14:42 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (5.90 KB, text/plain)
2012-09-25 20:53 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (6.02 KB, text/plain)
2012-10-16 08:00 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (5.85 KB, text/plain)
2012-11-26 19:32 UTC, Bruno Friedmann
Details
New crash information added by DrKonqi (6.91 KB, text/plain)
2013-01-24 12:12 UTC, Bruno Friedmann
Details
New crash information added by DrKonqi (9.13 KB, text/plain)
2013-02-12 17:55 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (6.70 KB, text/plain)
2013-09-07 16:17 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (6.49 KB, text/plain)
2014-01-02 11:04 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milian Wolff 2011-08-25 11:45:03 UTC
Application: kmail (4.8 pre)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.3
Operating System: Linux 3.0-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
I started kmail and it tried to download my mails from multiple resources. Then the "sieve password" dialog for one of my dimap accounts popped up (it happens frequently - no idea why) and afterwards it crashed.

Maybe related: I have lots of filters, the ui hang a bit after accepting the sieve dialog.

After kmail crashed, my akonadi_pop3_resource crashed as well with this bt:

Application: Akonadi Resource (akonadi_pop3_resource), signal: Aborted
[KCrash Handler]
#6  0x00007fbbb57db795 in raise () from /lib/libc.so.6
#7  0x00007fbbb57dcc0b in abort () from /lib/libc.so.6
#8  0x00007fbbb84b3a2f in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#9  0x00007fbbb84b3baf in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007fbbb84b3d54 in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#11 0x00007fbbb8ca7c00 in Akonadi::ResourceBase::collectionsRetrieved (this=0x1807b20, collections=...) at /home/milian/projects/kde4/kdepimlibs/akonadi/resourcebase.cpp:556
#12 0x00000000004110b8 in _start ()

the kmail stuff is a hand compiled version from ~2 weeks ago, I'll update it now.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f57db122780 (LWP 2357))]

Thread 2 (Thread 0x7f57bd7e9700 (LWP 3295)):
#0  0x00007f57d6355ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f57cf1a80ea in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f57cf1a81d9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f57d6351d60 in start_thread () from /lib/libpthread.so.0
#4  0x00007f57d84bde2d in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f57db122780 (LWP 2357)):
[KCrash Handler]
#6  0x00007f57d8d7ea3e in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f57d8d850d6 in QUrl::detach() () from /usr/lib/libQtCore.so.4
#8  0x00007f57d8d862bb in QUrl::setUserName(QString const&) () from /usr/lib/libQtCore.so.4
#9  0x00007f57c967f8fe in KManageSieve::Session::saslInteract (this=0x1f84ad0, in=0x21d9a20) at /home/milian/projects/kde4/kdepim/libksieve/kmanagesieve/session.cpp:448
#10 0x00007f57c967f0a6 in KManageSieve::Session::startAuthentication (this=0x1f84ad0) at /home/milian/projects/kde4/kdepim/libksieve/kmanagesieve/session.cpp:375
#11 0x00007f57c967cc32 in KManageSieve::Session::processResponse (this=0x1f84ad0, response=..., data=...) at /home/milian/projects/kde4/kdepim/libksieve/kmanagesieve/session.cpp:194
#12 0x00007f57c967c46f in KManageSieve::Session::dataReceived (this=0x1f84ad0) at /home/milian/projects/kde4/kdepim/libksieve/kmanagesieve/session.cpp:134
#13 0x00007f57c9680231 in KManageSieve::Session::qt_metacall (this=0x1f84ad0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7ffffe23a770) at /home/milian/projects/.build/kde4/kdepim/libksieve/kmanagesieve/session.moc:76
#14 0x00007f57d8dd87fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x00007f57da5d7866 in KTcpSocket::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdecore.so.5
#16 0x00007f57d8dd87fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#17 0x00007f57d756c02b in ?? () from /usr/lib/libQtNetwork.so.4
#18 0x00007f57d756672d in QSslSocket::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtNetwork.so.4
#19 0x00007f57d8dd87fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x00007f57d754b32f in ?? () from /usr/lib/libQtNetwork.so.4
#21 0x00007f57d753a0c1 in ?? () from /usr/lib/libQtNetwork.so.4
#22 0x00007f57d92ad174 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x00007f57d92b1fe1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0x00007f57dab3c226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#25 0x00007f57d8dc5bbc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#26 0x00007f57d8deff57 in ?? () from /usr/lib/libQtCore.so.4
#27 0x00007f57cd14c29d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007f57cd14ca78 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007f57cd14cd09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007f57d8df0876 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x00007f57d93501be in ?? () from /usr/lib/libQtGui.so.4
#32 0x00007f57d8dc4db2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0x00007f57d8dc4fb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0x00007f57d8dc91ab in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#35 0x0000000000402b63 in ?? ()
#36 0x00007f57d840b17d in __libc_start_main () from /lib/libc.so.6
#37 0x0000000000403045 in _start ()

Reported using DrKonqi
Comment 1 Laurent Montel 2011-08-25 15:21:19 UTC
Ok for the backtrace but don't understand why sieve password is asking
Comment 2 Milian Wolff 2011-08-27 02:12:53 UTC
I get that dialog quite often at startup. Sometimes I get the dialog for all my resources. Sometimes no dialog at all.

Don't ask me what's going on, but it really looks flaky...
Comment 3 Christophe Giboudeaux 2012-04-20 12:18:38 UTC
*** Bug 298396 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Giboudeaux 2012-04-20 12:19:03 UTC
from bug 298396
- What I was doing when the application crashed:
I have setup Kontact/KMail/Akonadi to support Sieve. Kontact starts after logging in and I do not open accept the request to open KWallet by entering my password, because I am AFK. When I later come back, Kontact will have opened a window asking me for my Sieve password (and username, but that is already filled in) and the KWallet dialogue is still open. I enter my KWallet password in one dialogue and as soon as I enter the Sieve password into the other, Kontact will segfault.
Comment 5 Dennis Schridde 2012-05-06 09:39:54 UTC
Created attachment 70892 [details]
New crash information added by DrKonqi

kontact (4.8.3) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

The issue persists in KDE 4.8.3.

- What I was doing when the application crashed:
Same thing as last time: Using Kontact/KMail with Sieve, waiting after starting Kontact while ignoring the KWallet password dialogue, Sieve password dialogue pops up, I enter my password and Kontact crashes.

-- Backtrace (Reduced):
#6  0x0000003ea1131231 in QUrl::setUserName(QString const&) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x0000003eb7206904 in KManageSieve::Session::saslInteract (this=0x16f4bc0, in=0x1824180) at /var/tmp/portage/kde-base/kmail-4.8.3/work/kmail-4.8.3/libksieve/kmanagesieve/session.cpp:448
#8  0x0000003eb7207694 in KManageSieve::Session::startAuthentication (this=0x16f4bc0) at /var/tmp/portage/kde-base/kmail-4.8.3/work/kmail-4.8.3/libksieve/kmanagesieve/session.cpp:375
#9  0x0000003eb72087d1 in KManageSieve::Session::processResponse (this=0x16f4bc0, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.8.3/work/kmail-4.8.3/libksieve/kmanagesieve/session.cpp:190
#10 0x0000003eb72099f5 in KManageSieve::Session::dataReceived (this=0x16f4bc0) at /var/tmp/portage/kde-base/kmail-4.8.3/work/kmail-4.8.3/libksieve/kmanagesieve/session.cpp:134
Comment 6 Dennis Schridde 2012-06-30 13:33:47 UTC
Created attachment 72236 [details]
New crash information added by DrKonqi

kontact (4.8.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.2

- What I was doing when the application crashed:

Kontact started, I ignored the Akonadi KWallet password request, I am being asked for my Sieve password, I enter it and Kontact crashes.

-- Backtrace (Reduced):
#6  0x0000003a06f2913c in QUrlPrivate::QUrlPrivate(QUrlPrivate const&) () from /usr/lib64/qt4/libQtCore.so.4
[...]
#8  0x0000003a06f308bb in QUrl::setUserName(QString const&) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x0000003ad3a06904 in KManageSieve::Session::saslInteract (this=0x1b171e0, in=0x19b6220) at /var/tmp/portage/kde-base/kmail-4.8.4/work/kmail-4.8.4/libksieve/kmanagesieve/session.cpp:448
#10 0x0000003ad3a07694 in KManageSieve::Session::startAuthentication (this=0x1b171e0) at /var/tmp/portage/kde-base/kmail-4.8.4/work/kmail-4.8.4/libksieve/kmanagesieve/session.cpp:375
#11 0x0000003ad3a087d1 in KManageSieve::Session::processResponse (this=0x1b171e0, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.8.4/work/kmail-4.8.4/libksieve/kmanagesieve/session.cpp:190
Comment 7 Dennis Schridde 2012-08-08 14:42:34 UTC
Created attachment 73049 [details]
New crash information added by DrKonqi

kontact (4.9) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed:

Same as before: KWallet password dialogue appears to have timed out, Sieve password dialogue is being displayed, I wait even longer before entering my password and Kontact crashes. This time I am using KDE 4.9.0, still with Qt 4.8.2.

-- Backtrace (Reduced):
#6  0x0000003a5f52aa61 in QUrl::setUserName(QString const&) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f456ee16884 in KManageSieve::Session::saslInteract (this=this@entry=0x17aebf0, in=0x18275c0) at /var/tmp/portage/kde-base/kmail-4.9.0-r1/work/kmail-4.9.0/libksieve/kmanagesieve/session.cpp:448
#8  0x00007f456ee175d4 in KManageSieve::Session::startAuthentication (this=this@entry=0x17aebf0) at /var/tmp/portage/kde-base/kmail-4.9.0-r1/work/kmail-4.9.0/libksieve/kmanagesieve/session.cpp:375
#9  0x00007f456ee18329 in KManageSieve::Session::processResponse (this=this@entry=0x17aebf0, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.9.0-r1/work/kmail-4.9.0/libksieve/kmanagesieve/session.cpp:190
#10 0x00007f456ee1921d in KManageSieve::Session::dataReceived (this=0x17aebf0) at /var/tmp/portage/kde-base/kmail-4.9.0-r1/work/kmail-4.9.0/libksieve/kmanagesieve/session.cpp:134
Comment 8 Christophe Giboudeaux 2012-08-28 15:49:19 UTC
*** Bug 304016 has been marked as a duplicate of this bug. ***
Comment 9 David Faure 2012-09-19 20:45:15 UTC
I think the crash happens when "this" (the Session instance) gets deleted by some event handling that happens during the QDialog::exec() modal dialog.
Then it crashes when accessing a member variable (m_url) of "this", which is logical.

Solution 1: use a non-modal dialog
Solution 2: use Q[Weak]Pointer on "this", a common recommendation for modal dialogs nowadays.
Comment 10 Allen Winter 2012-09-20 19:08:44 UTC
David Faure writes:
> Solution 2: use Q[Weak]Pointer on "this", a common recommendation for modal dialogs nowadays.

For the record: I implemented this possible solution about 1 month ago so it should be included with KDE SC 4.9.1.  Would be interested to know if this solution works.  It was very hard for me to reproduce and I can't now -- but I'd like to hear back from others.
Comment 11 Dennis Schridde 2012-09-25 20:53:17 UTC
Created attachment 74173 [details]
New crash information added by DrKonqi

kontact (4.9.1) on KDE Platform 4.9.1 using Qt 4.8.3

- What I was doing when the application crashed:

The issue still exists in KDE 4.9.1.

[make drkonqi happy]

-- Backtrace (Reduced):
#6  0x00007fc526cad387 in QUrl::setUserName(QString const&) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007fc4cd3417ec in KManageSieve::Session::saslInteract (this=this@entry=0x13b4040, in=0x145c3c0) at /var/tmp/portage/kde-base/kmail-4.9.1/work/kmail-4.9.1/libksieve/kmanagesieve/session.cpp:448
#8  0x00007fc4cd342564 in KManageSieve::Session::startAuthentication (this=this@entry=0x13b4040) at /var/tmp/portage/kde-base/kmail-4.9.1/work/kmail-4.9.1/libksieve/kmanagesieve/session.cpp:377
#9  0x00007fc4cd3432b9 in KManageSieve::Session::processResponse (this=this@entry=0x13b4040, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.9.1/work/kmail-4.9.1/libksieve/kmanagesieve/session.cpp:192
#10 0x00007fc4cd3441ad in KManageSieve::Session::dataReceived (this=0x13b4040) at /var/tmp/portage/kde-base/kmail-4.9.1/work/kmail-4.9.1/libksieve/kmanagesieve/session.cpp:136
Comment 12 Dennis Schridde 2012-10-16 08:00:45 UTC
Created attachment 74575 [details]
New crash information added by DrKonqi

kontact (4.9.2) on KDE Platform 4.9.2 using Qt 4.8.3

- What I was doing when the application crashed:

The issue persists in KDE 4.9.2.

[more text to make drkonqi happy]

-- Backtrace (Reduced):
#6  0x000000397452b38e in QUrl::setUserName(QString const&) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x0000003995e067ec in KManageSieve::Session::saslInteract (this=this@entry=0x231b3e0, in=0x1871a70) at /var/tmp/portage/kde-base/kmail-4.9.2/work/kmail-4.9.2/libksieve/kmanagesieve/session.cpp:448
#8  0x0000003995e07564 in KManageSieve::Session::startAuthentication (this=this@entry=0x231b3e0) at /var/tmp/portage/kde-base/kmail-4.9.2/work/kmail-4.9.2/libksieve/kmanagesieve/session.cpp:377
#9  0x0000003995e082b9 in KManageSieve::Session::processResponse (this=this@entry=0x231b3e0, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.9.2/work/kmail-4.9.2/libksieve/kmanagesieve/session.cpp:192
#10 0x0000003995e091ad in KManageSieve::Session::dataReceived (this=0x231b3e0) at /var/tmp/portage/kde-base/kmail-4.9.2/work/kmail-4.9.2/libksieve/kmanagesieve/session.cpp:136
Comment 13 Bruno Friedmann 2012-11-26 19:32:14 UTC
Created attachment 75493 [details]
New crash information added by DrKonqi

kontact (4.9.3) on KDE Platform 4.9.3 "release 520" using Qt 4.8.3

- What I was doing when the application crashed: Like before let kmail2 open close your session (with restore on) 
Reboot the computer, and after the login let the kwallet password opened for at least 15 minutes ... enter the password, and hit cancel on the first imap login ...
you get a crash like one year and a half.

Still present in 4.9.3

-- Backtrace (Reduced):
#6  0x00007f6bf573d79a in sasl_errdetail (conn=0x605460 <QString::shared_null>) at common.c:1381
#7  0x00007f6ba0cfb92a in KManageSieve::Session::startAuthentication (this=this@entry=0x19f44b0) at /usr/src/debug/kdepim-4.9.3/libksieve/kmanagesieve/session.cpp:378
#8  0x00007f6ba0cfc709 in KManageSieve::Session::processResponse (this=this@entry=0x19f44b0, response=..., data=...) at /usr/src/debug/kdepim-4.9.3/libksieve/kmanagesieve/session.cpp:192
#9  0x00007f6ba0cfd5fd in KManageSieve::Session::dataReceived (this=0x19f44b0) at /usr/src/debug/kdepim-4.9.3/libksieve/kmanagesieve/session.cpp:136
[...]
#13 0x00007f6bfe57c671 in QSslSocketBackendPrivate::transmit (this=0x19f6580) at ssl/qsslsocket_openssl.cpp:1149
Comment 14 Bruno Friedmann 2013-01-24 12:12:55 UTC
Created attachment 76681 [details]
New crash information added by DrKonqi

kontact (4.9.5) on KDE Platform 4.9.5 "release 3" using Qt 4.8.4

- What I was doing when the application crashed: session opened alone, let kmail2 start and wait unlock for kwallet. 
10 minutes after the start open kwallet, sieve auth appear (why did it try to connect before the imap stay a mystery)
hit cancel button on the sieve login, and let kmail2 crash and drive you there...

-- Backtrace (Reduced):
#6  sasl_errdetail (conn=0x4050400000000000) at common.c:1377
#7  0x00007fb23404192a in KManageSieve::Session::startAuthentication (this=this@entry=0x1b75720) at /usr/src/debug/kdepim-4.9.5/libksieve/kmanagesieve/session.cpp:378
#8  0x00007fb234042709 in KManageSieve::Session::processResponse (this=this@entry=0x1b75720, response=..., data=...) at /usr/src/debug/kdepim-4.9.5/libksieve/kmanagesieve/session.cpp:192
#9  0x00007fb2340435fd in KManageSieve::Session::dataReceived (this=0x1b75720) at /usr/src/debug/kdepim-4.9.5/libksieve/kmanagesieve/session.cpp:136
[...]
#11 0x00007fb296a830ea in reemitReadyRead (this=<optimized out>) at /usr/src/debug/kdelibs-4.9.5/kdecore/network/ktcpsocket.cpp:370
Comment 15 Dennis Schridde 2013-02-12 17:55:54 UTC
Created attachment 77230 [details]
New crash information added by DrKonqi

kontact (4.10) on KDE Platform 4.10.00 using Qt 4.8.4

- What I was doing when the application crashed:

The issue persists/returned in KDE 4.10.0:

* After login, kontact was started automatically (it is usually not closed properly due to some other bug)
* There is a KWallet dialogue asking for my password, but I did not enter any
* Apparently the Sieve login timed out and thus Kontact asks for the password on its own
* I do not immediately enter a password there either
* I enter the Sieve password later and Kontact crashes with attached backtrace

-- Backtrace (Reduced):
#7  QList (l=..., this=0x7fff2b170870) at /usr/include/qt4/QtCore/qlist.h:122
#8  QStringList (l=..., this=0x7fff2b170870) at /usr/include/qt4/QtCore/qstringlist.h:71
#9  KManageSieve::Session::requestedSaslMethod (this=this@entry=0x1affb80) at /var/tmp/portage/kde-base/kmail-4.10.0/work/kmail-4.10.0/libksieve/kmanagesieve/session.cpp:412
#10 0x0000003a10c073cf in KManageSieve::Session::startAuthentication (this=this@entry=0x1affb80) at /var/tmp/portage/kde-base/kmail-4.10.0/work/kmail-4.10.0/libksieve/kmanagesieve/session.cpp:377
#11 0x0000003a10c08241 in KManageSieve::Session::processResponse (this=this@entry=0x1affb80, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.10.0/work/kmail-4.10.0/libksieve/kmanagesieve/session.cpp:194
Comment 16 Dennis Schridde 2013-09-07 16:17:40 UTC
Created attachment 82208 [details]
New crash information added by DrKonqi

kontact (4.11.1) on KDE Platform 4.11.1 using Qt 4.8.5

- What I was doing when the application crashed:

The situation / crash from comment #15 persists for KDE 4.11.1

-- Backtrace (Reduced):
#6  0x00007f6fbd301337 in sasl_errdetail () from /usr/lib64/libsasl2.so.3
#7  0x00007f6f6bf0f846 in KManageSieve::Session::startAuthentication (this=this@entry=0x1c99480) at /var/tmp/portage/kde-base/kmail-4.11.1/work/kmail-4.11.1/libksieve/kmanagesieve/session.cpp:389
#8  0x00007f6f6bf103a9 in KManageSieve::Session::processResponse (this=this@entry=0x1c99480, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.11.1/work/kmail-4.11.1/libksieve/kmanagesieve/session.cpp:194
#9  0x00007f6f6bf11102 in KManageSieve::Session::dataReceived (this=0x1c99480) at /var/tmp/portage/kde-base/kmail-4.11.1/work/kmail-4.11.1/libksieve/kmanagesieve/session.cpp:138
[...]
#11 0x0000003d8eddaae0 in QIODevice::readyRead (this=<optimized out>) at .moc/release-shared/moc_qiodevice.cpp:104
Comment 17 Dennis Schridde 2014-01-02 11:04:38 UTC
Created attachment 84407 [details]
New crash information added by DrKonqi

kontact (4.12) on KDE Platform 4.12.0 using Qt 4.8.5

- What I was doing when the application crashed:

The problem persists in KDE 4.12.

[dummy text]

-- Backtrace (Reduced):
#6  0x000000380dc0c337 in sasl_errdetail () from /usr/lib64/libsasl2.so.3
#7  0x0000003d44a07ab6 in KManageSieve::Session::startAuthentication (this=this@entry=0x1278a50) at /var/tmp/portage/kde-base/kmail-4.12.0/work/kmail-4.12.0/libksieve/kmanagesieve/session.cpp:414
#8  0x0000003d44a08619 in KManageSieve::Session::processResponse (this=this@entry=0x1278a50, response=..., data=...) at /var/tmp/portage/kde-base/kmail-4.12.0/work/kmail-4.12.0/libksieve/kmanagesieve/session.cpp:198
#9  0x0000003d44a09375 in KManageSieve::Session::dataReceived (this=0x1278a50) at /var/tmp/portage/kde-base/kmail-4.12.0/work/kmail-4.12.0/libksieve/kmanagesieve/session.cpp:142
[...]
#11 0x0000003c02bdaa20 in QIODevice::readyRead (this=<optimized out>) at .moc/release-shared/moc_qiodevice.cpp:104
Comment 18 Martin 2014-07-31 08:06:04 UTC
Application: kontact (4.13.3)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.15.5-1-CHAKRA x86_64
Distribution: "Chakra"

-- Information about the crash:
- What I was doing when the application crashed:

This error persists in 4.13.3. After closing the sieve password dialogue kontact crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa0d6746800 (LWP 523))]

Thread 4 (Thread 0x7fa0b8c13700 (LWP 548)):
#0  0x00007fa0cdc2caaf in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa0d141b47d in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007fa0d141b4b9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007fa0cdc280f4 in start_thread () from /lib/libpthread.so.0
#4  0x00007fa0d3c624bd in clone () from /lib/libc.so.6

Thread 3 (Thread 0x7fa0782f8700 (LWP 585)):
#0  0x00007fa0cdc2caaf in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa0d115d40d in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007fa0d144a906 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007fa0cdc280f4 in start_thread () from /lib/libpthread.so.0
#4  0x00007fa0d3c624bd in clone () from /lib/libc.so.6

Thread 2 (Thread 0x7fa069304700 (LWP 1082)):
#0  0x00007fa0d3c5981d in poll () from /lib/libc.so.6
#1  0x00007fa0cd6655d4 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007fa0cd6656ec in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007fa0d43eaf47 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007fa0d43baa51 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007fa0d43badb5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007fa0d42af809 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007fa0d42b206f in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007fa0cdc280f4 in start_thread () from /lib/libpthread.so.0
#9  0x00007fa0d3c624bd in clone () from /lib/libc.so.6

Thread 1 (Thread 0x7fa0d6746800 (LWP 523)):
[KCrash Handler]
#6  0x00007fa0d3c705eb in __vsnprintf_chk () from /lib/libc.so.6
#7  0x00007fa0d3c70578 in __snprintf_chk () from /lib/libc.so.6
#8  0x00007fa0c2635487 in sasl_errdetail () from /usr/lib/libsasl2.so.2
#9  0x00007fa06bf8f719 in KManageSieve::Session::startAuthentication (this=0x1501e30) at /chakra/desktop-testing/kdepim/src/kdepim-4.13.3/libksieve/kmanagesieve/session.cpp:414
#10 0x00007fa06bf914d6 in KManageSieve::Session::processResponse (this=0x1501e30, response=..., data=...) at /chakra/desktop-testing/kdepim/src/kdepim-4.13.3/libksieve/kmanagesieve/session.cpp:202
#11 0x00007fa06bf92237 in KManageSieve::Session::dataReceived (this=0x1501e30) at /chakra/desktop-testing/kdepim/src/kdepim-4.13.3/libksieve/kmanagesieve/session.cpp:142
#12 0x00007fa0d43d09fc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#13 0x00007fa0d48edab2 in reemitReadyRead (this=0x15012a0, this=0x15012a0) at /chakra/desktop-testing/kdelibs/src/kdelibs-4.13.3/kdecore/network/ktcpsocket.cpp:372
#14 KTcpSocket::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /chakra/desktop-testing/kdelibs/src/build/kdecore/ktcpsocket.moc:91
#15 0x00007fa0d43d09fc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x00007fa0cebe0d51 in ?? () from /usr/lib/libQtNetwork.so.4
#17 0x00007fa0cebdada9 in ?? () from /usr/lib/libQtNetwork.so.4
#18 0x00007fa0d43d09fc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#19 0x00007fa0cebb969e in ?? () from /usr/lib/libQtNetwork.so.4
#20 0x00007fa0cebc42cd in ?? () from /usr/lib/libQtNetwork.so.4
#21 0x00007fa0d4dd4e0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x00007fa0d4ddb858 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x00007fa0d5b2441a in KApplication::notify (this=0x7fffd1c27520, receiver=0x162b410, event=0x7fffd1c271e0) at /chakra/desktop-testing/kdelibs/src/kdelibs-4.13.3/kdeui/kernel/kapplication.cpp:311
#24 0x00007fa0d43bbefd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#25 0x00007fa0d43eb59c in ?? () from /usr/lib/libQtCore.so.4
#26 0x00007fa0cd66525e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#27 0x00007fa0cd665638 in ?? () from /usr/lib/libglib-2.0.so.0
#28 0x00007fa0cd6656ec in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#29 0x00007fa0d43eaf2d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0x00007fa0d4e78936 in ?? () from /usr/lib/libQtGui.so.4
#31 0x00007fa0d43baa51 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x00007fa0d43badb5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0x00007fa0d43c0347 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#34 0x0000000000403499 in main (argc=3, argv=0x7fffd1c27678) at /chakra/desktop-testing/kdepim/src/kdepim-4.13.3/kontact/src/main.cpp:219
Comment 19 Denis Kurz 2016-09-24 18:15:01 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 20 Denis Kurz 2017-01-07 22:16:21 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.