Bug 280376 - Experimenting with changing desktop settings
Summary: Experimenting with changing desktop settings
Status: RESOLVED DUPLICATE of bug 247416
Alias: None
Product: marble
Classification: Unclassified
Component: wallpaper (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-18 20:27 UTC by vince
Modified: 2012-07-05 21:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vince 2011-08-18 20:27:29 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was experimenting with changing desktop settings.  I changed the wallpaper several times then it crashed.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76d1720 (LWP 4381))]

Thread 2 (Thread 0xafa24b70 (LWP 5851)):
#0  0x00e32e36 in clock_gettime (clock_id=14905332, tp=0xafa23f80) at ../sysdeps/unix/clock_gettime.c:100
#1  0x0141250b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x014e96e5 in QTimerInfoList::updateCurrentTime (this=0x91e2034) at kernel/qeventdispatcher_unix.cpp:339
#4  0x014e972a in QTimerInfoList::timerWait (this=0x91e2034, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x014e77a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xafa240ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x014e783d in timerSourcePrepare (source=0x0, timeout=0xe36ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01821e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x01822279 in ?? () from /lib/libglib-2.0.so.0
#9  0x01822848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x014e759f in QEventDispatcherGlib::processEvents (this=0x93209c8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x014b7609 in QEventLoop::processEvents (this=0xafa24280, flags=) at kernel/qeventloop.cpp:149
#12 0x014b7a8a in QEventLoop::exec (this=0xafa24280, flags=...) at kernel/qeventloop.cpp:201
#13 0x013b3b7e in QThread::exec (this=0x91e15f8) at thread/qthread.cpp:490
#14 0x0149635b in QInotifyFileSystemWatcherEngine::run (this=0x91e15f8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x013b6df9 in QThreadPrivate::start (arg=0x91e15f8) at thread/qthread_unix.cpp:266
#16 0x004e1cc9 in start_thread (arg=0xafa24b70) at pthread_create.c:304
#17 0x00f0e69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb76d1720 (LWP 4381)):
[KCrash Handler]
#7  Marble::GeoSceneTexture::levelZeroColumns (this=0x8ffc630) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:87
#8  0x0409c04a in Marble::MergedLayerDecorator::paint (this=0x8ffc630, themeId=..., mapTheme=0x0) at ../../../../marble/src/lib/MergedLayerDecorator.cpp:106
#9  0x03fba77b in Marble::MarbleModel::paintTile (this=0x93525f0, tile=0x938a578, textureLayer=0x91dd3d8) at ../../../../marble/src/lib/MarbleModel.cpp:974
#10 0x04062d64 in mergeDecorations (this=0xaf12cd40, stackedTileId=..., tileId=...) at ../../../../marble/src/lib/StackedTileLoader.cpp:523
#11 Marble::StackedTileLoader::updateTile (this=0xaf12cd40, stackedTileId=..., tileId=...) at ../../../../marble/src/lib/StackedTileLoader.cpp:397
#12 0x04065784 in Marble::StackedTileLoader::qt_metacall (this=0xaf12cd40, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfee97a0) at ./StackedTileLoader.moc:86
#13 0x014be8ca in QMetaObject::metacall (object=0xaf12cd40, cl=6357093, idx=7, argv=0xbfee97a0) at kernel/qmetaobject.cpp:237
#14 0x014d16ad in QMetaObject::activate (sender=0xaf101bd8, m=0x40e6888, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3280
#15 0x03feb3c6 in tileCompleted (this=0xaf101bd8, data=..., tileId=...) at ./TileLoader.moc:102
#16 Marble::TileLoader::updateTile (this=0xaf101bd8, data=..., tileId=...) at ../../../../marble/src/lib/TileLoader.cpp:168
#17 0x03feb5b4 in Marble::TileLoader::qt_metacall (this=0xaf101bd8, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfee9904) at ./TileLoader.moc:83
#18 0x014be8ca in QMetaObject::metacall (object=0xaf101bd8, cl=6357093, idx=6, argv=0xbfee9904) at kernel/qmetaobject.cpp:237
#19 0x014d16ad in QMetaObject::activate (sender=0xaf11a9f0, m=0x40e6bc8, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3280
#20 0x0400f0f9 in Marble::HttpDownloadManager::downloadComplete (this=0xaf11a9f0, _t1=..., _t2=...) at ./HttpDownloadManager.moc:115
#21 0x0401121e in Marble::HttpDownloadManager::finishJob (this=0xaf11a9f0, data=..., destinationFileName=..., id=...) at ../../../../marble/src/lib/HttpDownloadManager.cpp:182
#22 0x040133db in Marble::HttpDownloadManager::qt_metacall (this=0xaf11a9f0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfee9af4) at ./HttpDownloadManager.moc:94
#23 0x014be8ca in QMetaObject::metacall (object=0xaf11a9f0, cl=6357093, idx=9, argv=0xbfee9af4) at kernel/qmetaobject.cpp:237
#24 0x014d16ad in QMetaObject::activate (sender=0xaf103c70, m=0x40e6a34, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3280
#25 0x04004f94 in jobFinished (this=0xaf103c70, job=0x935c6e0, data=...) at ./DownloadQueueSet.moc:126
#26 Marble::DownloadQueueSet::finishJob (this=0xaf103c70, job=0x935c6e0, data=...) at ../../../../marble/src/lib/DownloadQueueSet.cpp:110
#27 0x04006966 in Marble::DownloadQueueSet::qt_metacall (this=0xaf103c70, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfee9c74) at ./DownloadQueueSet.moc:94
#28 0x014be8ca in QMetaObject::metacall (object=0xaf103c70, cl=6357093, idx=9, argv=0xbfee9c74) at kernel/qmetaobject.cpp:237
#29 0x014d16ad in QMetaObject::activate (sender=0x935c6e0, m=0x40e6c24, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3280
#30 0x04013bf9 in Marble::HttpJob::dataReceived (this=0x935c6e0, _t1=0x935c6e0, _t2=...) at ./HttpJob.moc:110
#31 0x026af39c in Marble::QNamDownloadJob::finished (this=0x935c6e0) at ../../../../../../marble/src/plugins/network/qnam/QNamDownloadJob.cpp:84
#32 0x026af9a7 in Marble::QNamDownloadJob::qt_metacall (this=0x935c6e0, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfee9dec) at ./QNamDownloadJob.moc:80
#33 0x014be8ca in QMetaObject::metacall (object=0x935c6e0, cl=6357093, idx=10, argv=0xbfee9dec) at kernel/qmetaobject.cpp:237
#34 0x014d16ad in QMetaObject::activate (sender=0x8f2bec0, m=0xd6c48c, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3280
#35 0x00d2c587 in QNetworkReply::finished (this=0x8f2bec0) at .moc/release-shared/moc_qnetworkreply.cpp:152
#36 0x00cbbffc in QNetworkReplyImplPrivate::finished (this=0x93e9be8) at access/qnetworkreplyimpl.cpp:656
#37 0x00ca0010 in QNetworkAccessBackend::finished (this=0x93fed68) at access/qnetworkaccessbackend.cpp:309
#38 0x00ca6b11 in QNetworkAccessHttpBackend::finished (this=0x93fed68) at access/qnetworkaccesshttpbackend.cpp:338
#39 0x00ca70d0 in QNetworkAccessHttpBackend::replyFinished (this=0x93fed68) at access/qnetworkaccesshttpbackend.cpp:773
#40 0x00cbbd7e in QNetworkReplyImplPrivate::handleNotifications (this=0x93e9be8) at access/qnetworkreplyimpl.cpp:367
#41 0x00cbbe03 in QNetworkReplyImpl::event (this=0x93f0660, e=0x927b9a8) at access/qnetworkreplyimpl.cpp:866
#42 0x063a2fdc in QApplicationPrivate::notify_helper (this=0x8217758, receiver=0x8f2bec0, e=0x927b9a8) at kernel/qapplication.cpp:4396
#43 0x063a904e in QApplication::notify (this=0x820d710, receiver=0x8f2bec0, e=0x927b9a8) at kernel/qapplication.cpp:3798
#44 0x01174d8a in KApplication::notify (this=0x820d710, receiver=0x8f2bec0, event=0x927b9a8) at ../../kdeui/kernel/kapplication.cpp:310
#45 0x014b8b3b in QCoreApplication::notifyInternal (this=0x820d710, receiver=0x8f2bec0, event=0x927b9a8) at kernel/qcoreapplication.cpp:732
#46 0x014bbd8b in sendEvent (receiver=0x0, event_type=0, data=0x81f7028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#47 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x81f7028) at kernel/qcoreapplication.cpp:1373
#48 0x014bbf4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#49 0x014e7a74 in sendPostedEvents (s=0x8219b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=0x8219b10) at kernel/qeventdispatcher_glib.cpp:277
#51 0x0181e855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#52 0x01822668 in ?? () from /lib/libglib-2.0.so.0
#53 0x01822848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#54 0x014e7565 in QEventDispatcherGlib::processEvents (this=0x81f6ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#55 0x06464be5 in QGuiEventDispatcherGlib::processEvents (this=0x81f6ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x014b7609 in QEventLoop::processEvents (this=0xbfeea700, flags=) at kernel/qeventloop.cpp:149
#57 0x014b7a8a in QEventLoop::exec (this=0xbfeea700, flags=...) at kernel/qeventloop.cpp:201
#58 0x0690d873 in QDialog::exec (this=0x9430e40) at dialogs/qdialog.cpp:552
#59 0x0409be8d in Marble::MergedLayerDecorator::initCityLights (this=0x8ffc630) at ../../../../marble/src/lib/MergedLayerDecorator.cpp:78
#60 0x0409c088 in Marble::MergedLayerDecorator::paint (this=0x8ffc630, themeId=..., mapTheme=0x8246840) at ../../../../marble/src/lib/MergedLayerDecorator.cpp:102
#61 0x03fba77b in Marble::MarbleModel::paintTile (this=0x93525f0, tile=0x938a578, textureLayer=0x935fa38) at ../../../../marble/src/lib/MarbleModel.cpp:974
#62 0x04060cdf in Marble::StackedTileLoader::mergeDecorations (this=0xaf12cd40, tile=0x938a578, textureLayer=0x935fa38) at ../../../../marble/src/lib/StackedTileLoader.cpp:523
#63 0x04066a67 in Marble::StackedTileLoader::loadTile (this=0xaf12cd40, stackedTileId=..., usage=Marble::DownloadBrowse, forMergedLayerDecorator=false) at ../../../../marble/src/lib/StackedTileLoader.cpp:235
#64 0x0404e3d8 in Marble::AbstractScanlineTextureMapper::initTileSize (this=0x935e8e8) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:619
#65 0x0404e792 in Marble::AbstractScanlineTextureMapper::AbstractScanlineTextureMapper (this=0x935e8e8, textureLayer=0x9391ee8, tileLoader=0xaf12cd40, parent=0x93525f0) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:62
#66 0x04050cc7 in Marble::SphericalScanlineTextureMapper::SphericalScanlineTextureMapper (this=0x935e8e8, textureLayer=0x9391ee8, tileLoader=0xaf12cd40, parent=0x93525f0) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:33
#67 0x03fba2ce in Marble::MarbleModel::setupTextureMapper (this=0x93525f0, projection=Marble::Spherical) at ../../../../marble/src/lib/MarbleModel.cpp:522
#68 0x03fbfbf0 in Marble::MarbleModel::setMapTheme (this=0x93525f0, mapTheme=0x8246840, currentProjection=Marble::Spherical) at ../../../../marble/src/lib/MarbleModel.cpp:398
#69 0x03fc7c23 in Marble::MarbleMap::setMapThemeId (this=0x91ddb88, mapThemeId=...) at ../../../../marble/src/lib/MarbleMap.cpp:881
#70 0x026634c4 in Marble::MarbleWallpaper::init (this=0x824e360, config=...) at ../../../wallpapers/marble/marble.cpp:108
#71 0x0029fe19 in Plasma::Wallpaper::restore (this=0x824e360, config=...) at ../../plasma/wallpaper.cpp:303
#72 0x009e0dcc in BackgroundDialog::changeBackgroundMode (this=0x907fbd0, mode=7) at ../../../libs/plasmagenericshell/backgrounddialog.cpp:438
#73 0x009ddcb7 in BackgroundDialog::qt_metacall (this=0x907fbd0, _c=QMetaObject::InvokeMetaMethod, _id=87, _a=0xbfeeb1a8) at moc_backgrounddialog.cpp:157
#74 0x014be8ca in QMetaObject::metacall (object=0x907fbd0, cl=6357093, idx=87, argv=0xbfeeb1a8) at kernel/qmetaobject.cpp:237
#75 0x014d16ad in QMetaObject::activate (sender=0x90f8b98, m=0x6d26224, local_signal_index=5, argv=0x0) at kernel/qobject.cpp:3280
#76 0x067ea783 in QComboBox::currentIndexChanged (this=0x90f8b98, _t1=7) at .moc/release-shared/moc_qcombobox.cpp:302
#77 0x067ec3da in QComboBoxPrivate::_q_emitCurrentIndexChanged (this=0x90fa2b0, index=...) at widgets/qcombobox.cpp:1264
#78 0x067f0349 in QComboBoxPrivate::setCurrentIndex (this=0x90fa2b0, mi=...) at widgets/qcombobox.cpp:2022
#79 0x067f073c in QComboBoxPrivate::_q_itemSelected (this=0x90fa2b0, item=...) at widgets/qcombobox.cpp:1233
#80 0x067f6157 in QComboBox::qt_metacall (this=0x90f8b98, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfeeb3e8) at .moc/release-shared/moc_qcombobox.cpp:191
#81 0x014be8ca in QMetaObject::metacall (object=0x90f8b98, cl=6357093, idx=39, argv=0xbfeeb3e8) at kernel/qmetaobject.cpp:237
#82 0x014d16ad in QMetaObject::activate (sender=0x931ea28, m=0x6d34b14, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#83 0x06b12313 in QComboBoxPrivateContainer::itemSelected (this=0x931ea28, _t1=...) at .moc/release-shared/moc_qcombobox_p.cpp:213
#84 0x067ee7fa in QComboBoxPrivateContainer::eventFilter (this=0x931ea28, o=0x8fd6fd0, e=0xbfeeb9f0) at widgets/qcombobox.cpp:687
#85 0x014b829a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8217758, receiver=0x8fd6fd0, event=0xbfeeb9f0) at kernel/qcoreapplication.cpp:847
#86 0x063a2fb9 in QApplicationPrivate::notify_helper (this=0x8217758, receiver=0x8fd6fd0, e=0xbfeeb9f0) at kernel/qapplication.cpp:4392
#87 0x063a9c2e in QApplication::notify (this=0x820d710, receiver=0x8fd6fd0, e=0xbfeeb9f0) at kernel/qapplication.cpp:3959
#88 0x01174d8a in KApplication::notify (this=0x820d710, receiver=0x8fd6fd0, event=0xbfeeb9f0) at ../../kdeui/kernel/kapplication.cpp:310
#89 0x014b8b3b in QCoreApplication::notifyInternal (this=0x820d710, receiver=0x8fd6fd0, event=0xbfeeb9f0) at kernel/qcoreapplication.cpp:732
#90 0x063a8094 in sendEvent (receiver=0x8fd6fd0, event=0xbfeeb9f0, alienWidget=0x8fd6fd0, nativeWidget=0x931ea28, buttonDown=0x6d3d3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#91 QApplicationPrivate::sendMouseEvent (receiver=0x8fd6fd0, event=0xbfeeb9f0, alienWidget=0x8fd6fd0, nativeWidget=0x931ea28, buttonDown=0x6d3d3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#92 0x06437261 in QETWidget::translateMouseEvent (this=0x931ea28, event=0xbfeebf0c) at kernel/qapplication_x11.cpp:4337
#93 0x06436151 in QApplication::x11ProcessEvent (this=0x820d710, event=0xbfeebf0c) at kernel/qapplication_x11.cpp:3414
#94 0x0646536a in x11EventSourceDispatch (s=0x821a9a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#95 0x0181e855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#96 0x01822668 in ?? () from /lib/libglib-2.0.so.0
#97 0x01822848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#98 0x014e7565 in QEventDispatcherGlib::processEvents (this=0x81f6ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#99 0x06464be5 in QGuiEventDispatcherGlib::processEvents (this=0x81f6ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#100 0x014b7609 in QEventLoop::processEvents (this=0xbfeec204, flags=) at kernel/qeventloop.cpp:149
#101 0x014b7a8a in QEventLoop::exec (this=0xbfeec204, flags=...) at kernel/qeventloop.cpp:201
#102 0x014bc00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#103 0x063a1e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#104 0x006188e7 in kdemain (argc=1, argv=0xbfeec414) at ../../../../plasma/desktop/shell/main.cpp:118
#105 0x080485bb in main (argc=1, argv=0xbfeec414) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 271110, bug 269725.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-05 21:07:42 UTC

*** This bug has been marked as a duplicate of bug 247416 ***