Bug 280176 - Ark can't open 7-zip archives with password and filename encryption (-mhe) - password not prompted.
Summary: Ark can't open 7-zip archives with password and filename encryption (-mhe) - ...
Status: RESOLVED DUPLICATE of bug 35371
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.16
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-16 08:44 UTC by Jorg K
Modified: 2011-08-16 12:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test case of encrypted archive. (775 bytes, application/octet-stream)
2011-08-16 08:47 UTC, Jorg K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorg K 2011-08-16 08:44:12 UTC
Version:           2.16 (using KDE 4.6.0) 
OS:                Linux

I have 7-zip installed and the binaries are in the path.
I have to 7-zip archives, one with a password, one without.

The one without the password can be opened.

The one with the password cannot be opened. Ark hangs in "Loading archive ...". It doesn't prompt for the password.

Archive was created with 7-zip's -mhe switch, so the filenames in the archive are also encrypted. Archives created without the -mhe switch open fine.

Reproducible: Sometimes

Steps to Reproduce:
see above.


Expected Results:  
Password should be prompted when opening the archive.
Comment 1 Jorg K 2011-08-16 08:45:19 UTC
Sorry: Reproducible: ALWAYS.

I will enclose an archive.
Comment 2 Jorg K 2011-08-16 08:47:42 UTC
Created attachment 62864 [details]
Test case of encrypted archive.

Password is ARK.
Was created with: 7z a arktest -pARK -mhe <file>
Comment 3 Raphael Kubo da Costa 2011-08-16 08:53:02 UTC
This was fixed in 4.6.5 and 4.7.0, please consider updating your installation.

*** This bug has been marked as a duplicate of bug 35371 ***
Comment 4 Jorg K 2011-08-16 09:40:21 UTC
So sorry to trouble you with this.

I updated to 4.7 via openSUSE's YaST2 system. All went well, only that Ark (which wasn't part of the update) remained at 2.16 and therefore the problem persists.

I carefully browsed the kde.org website, but I couldn't find an link to update/download Ark 2.17.
Comment 5 Jorg K 2011-08-16 12:54:44 UTC
OK. All resolved now. For openSUSE the upgrade lives here:
http://ftp5.gwdg.de/pub/opensuse/repositories/KDE:/Release:/47/openSUSE_11.4/
Ark 2.17 isn't part of their "KDE-BASIS" upgrade, but it can be installed separately.
With Ark 2.17 (for 4.7) a prompt is issued and the 7-Zip archives with header encryption open.
Great! Sorry about the trouble.