Bug 279984 - Konquerer crashed
Summary: Konquerer crashed
Status: RESOLVED DUPLICATE of bug 264985
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-12 17:25 UTC by Andreas Mintgen
Modified: 2011-08-12 18:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Mintgen 2011-08-12 17:25:22 UTC
Application: konqueror (4.4.5 (KDE 4.4.5))
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-33-generic i686
Distribution: Ubuntu 10.04.3 LTS

-- Information about the crash:
Konquerer crashed and i don't no why

The crash can be reproduced every time.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76dd710 (LWP 11733))]

Thread 4 (Thread 0xb2ebdb70 (LWP 11761)):
#0  0x0525c577 in IA__g_main_context_dispatch (context=0xa62df88) at gmain.c:2601
#1  0x052604f0 in g_main_context_iterate (context=0xa62df88, block=<value optimized out>, dispatch=1, self=0xa62f4d0) at gmain.c:2675
#2  0x05260688 in IA__g_main_context_iteration (context=0xa62df88, may_block=1) at gmain.c:2738
#3  0x0073460f in QEventDispatcherGlib::processEvents (this=0xa613c58, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00707059 in QEventLoop::processEvents (this=0xb2ebd290, flags=) at kernel/qeventloop.cpp:149
#5  0x007074aa in QEventLoop::exec (this=0xb2ebd290, flags=...) at kernel/qeventloop.cpp:201
#6  0x006035a8 in QThread::exec (this=0xa615dc0) at thread/qthread.cpp:487
#7  0x006e6c1b in QInotifyFileSystemWatcherEngine::run (this=0xa615dc0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0060632e in QThreadPrivate::start (arg=0xa615dc0) at thread/qthread_unix.cpp:248
#9  0x0011596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x0619fa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xb23ffb70 (LWP 11947)):
#0  0x00ea2422 in __kernel_vsyscall ()
#1  0x0011a015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00607287 in QWaitConditionPrivate::wait (this=0xb46ded8, mutex=0xb46ded4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0xb46ded8, mutex=0xb46ded4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x07912d52 in QFileInfoGatherer::run (this=0xb46decc) at dialogs/qfileinfogatherer.cpp:203
#5  0x0060632e in QThreadPrivate::start (arg=0xb46decc) at thread/qthread_unix.cpp:248
#6  0x0011596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x0619fa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb19f0b70 (LWP 11948)):
#0  0x0525fb7c in IA__g_main_context_prepare (context=0xaf80680, priority=0xb19f014c) at gmain.c:2330
#1  0x052600c9 in g_main_context_iterate (context=0xaf80680, block=<value optimized out>, dispatch=1, self=0xb3acbb8) at gmain.c:2655
#2  0x05260688 in IA__g_main_context_iteration (context=0xaf80680, may_block=1) at gmain.c:2738
#3  0x0073460f in QEventDispatcherGlib::processEvents (this=0xa7f6170, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00707059 in QEventLoop::processEvents (this=0xb19f0290, flags=) at kernel/qeventloop.cpp:149
#5  0x007074aa in QEventLoop::exec (this=0xb19f0290, flags=...) at kernel/qeventloop.cpp:201
#6  0x006035a8 in QThread::exec (this=0xad431c8) at thread/qthread.cpp:487
#7  0x006e6c1b in QInotifyFileSystemWatcherEngine::run (this=0xad431c8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0060632e in QThreadPrivate::start (arg=0xad431c8) at thread/qthread_unix.cpp:248
#9  0x0011596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x0619fa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76dd710 (LWP 11733)):
[KCrash Handler]
#6  0x0473010f in khtml::RenderBlock::clearChildOfPageBreaks (this=0xa554328, child=0xa554470, pageBreakInfo=..., marginInfo=...) at ../../khtml/rendering/render_block.cpp:1667
#7  0x0473259a in khtml::RenderBlock::layoutBlockChildren (this=0xa554328, relayoutChildren=<value optimized out>) at ../../khtml/rendering/render_block.cpp:1604
#8  0x04732875 in khtml::RenderBlock::layoutBlock (this=0xa554328, relayoutChildren=true) at ../../khtml/rendering/render_block.cpp:835
#9  0x0479005d in khtml::RenderCanvas::layout (this=0xa554328) at ../../khtml/rendering/render_canvas.cpp:191
#10 0x045eebdf in khtml::RenderObject::layoutIfNeeded (this=0xa9ab950, quick=false) at ../../khtml/rendering/render_object.h:480
#11 KHTMLView::print (this=0xa9ab950, quick=false) at ../../khtml/khtmlview.cpp:3279
#12 0x0464cbe0 in KHTMLPartBrowserExtension::print (this=0xa900678) at ../../khtml/khtml_ext.cpp:371
#13 0x0464fc43 in KHTMLPartBrowserExtension::qt_metacall (this=0xa900678, _c=QMetaObject::InvokeMetaMethod, _id=56, _a=0xbf8a2308) at ./khtml_ext.moc:103
#14 0x0070dc9a in QMetaObject::metacall (object=0xa900678, cl=QMetaObject::InvokeMetaMethod, idx=56, argv=0xbf8a2308) at kernel/qmetaobject.cpp:237
#15 0x0071c3d5 in QMetaObject::activate (sender=0xa015360, m=0x7cbbd58, local_signal_index=1, argv=0xbf8a2308) at kernel/qobject.cpp:3293
#16 0x0738cbd9 in QAction::triggered (this=0xa015360, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#17 0x0738edcc in QAction::activate (this=0xa015360, event=QAction::Trigger) at kernel/qaction.cpp:1255
#18 0x0783260c in QMenuPrivate::activateCausedStack (this=0xa2f1840, causedStack=..., action=0xa015360, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1011
#19 0x07838abb in QMenuPrivate::activateAction (this=0xa2f1840, action=0xa015360, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1103
#20 0x07839ac7 in QMenu::mouseReleaseEvent (this=0xa2fc0f0, e=0xbf8a2ba0) at widgets/qmenu.cpp:2312
#21 0x01179745 in KMenu::mouseReleaseEvent (this=0xa2fc0f0, e=0xbf8a2ba0) at ../../kdeui/widgets/kmenu.cpp:471
#22 0x073f17f8 in QWidget::event (this=0xa2fc0f0, event=0xbf8a2ba0) at kernel/qwidget.cpp:7998
#23 0x0783b0cc in QMenu::event (this=0xa2fc0f0, e=0xbf8a2ba0) at widgets/qmenu.cpp:2414
#24 0x073934dc in QApplicationPrivate::notify_helper (this=0x9de2770, receiver=0xa2fc0f0, e=0xbf8a2ba0) at kernel/qapplication.cpp:4300
#25 0x0739a9f7 in QApplication::notify (this=0xbf8a35d4, receiver=0xa2fc0f0, e=0xbf8a2ba0) at kernel/qapplication.cpp:3865
#26 0x0108340a in KApplication::notify (this=0xbf8a35d4, receiver=0xa2fc0f0, event=0xbf8a2ba0) at ../../kdeui/kernel/kapplication.cpp:302
#27 0x00708a3b in QCoreApplication::notifyInternal (this=0xbf8a35d4, receiver=0xa2fc0f0, event=0xbf8a2ba0) at kernel/qcoreapplication.cpp:704
#28 0x07399952 in QCoreApplication::sendEvent (receiver=0xa2fc0f0, event=0xbf8a2ba0, alienWidget=0x0, nativeWidget=0xa2fc0f0, buttonDown=0x7cd7058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QApplicationPrivate::sendMouseEvent (receiver=0xa2fc0f0, event=0xbf8a2ba0, alienWidget=0x0, nativeWidget=0xa2fc0f0, buttonDown=0x7cd7058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#30 0x074255cf in QETWidget::translateMouseEvent (this=0xa2fc0f0, event=0xbf8a30bc) at kernel/qapplication_x11.cpp:4302
#31 0x07424511 in QApplication::x11ProcessEvent (this=0xbf8a35d4, event=0xbf8a30bc) at kernel/qapplication_x11.cpp:3379
#32 0x0745360a in x11EventSourceDispatch (s=0x9de5840, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#33 0x0525c6c5 in g_main_dispatch (context=0x9de48c0) at gmain.c:2044
#34 IA__g_main_context_dispatch (context=0x9de48c0) at gmain.c:2597
#35 0x052604f0 in g_main_context_iterate (context=0x9de48c0, block=<value optimized out>, dispatch=1, self=0x9de2930) at gmain.c:2675
#36 0x05260688 in IA__g_main_context_iteration (context=0x9de48c0, may_block=1) at gmain.c:2738
#37 0x007345d5 in QEventDispatcherGlib::processEvents (this=0x9d9ab48, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#38 0x07453135 in QGuiEventDispatcherGlib::processEvents (this=0x9d9ab48, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00707059 in QEventLoop::processEvents (this=0xbf8a33b4, flags=) at kernel/qeventloop.cpp:149
#40 0x007074aa in QEventLoop::exec (this=0xbf8a33b4, flags=...) at kernel/qeventloop.cpp:201
#41 0x0070b69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#42 0x07393577 in QApplication::exec () at kernel/qapplication.cpp:3579
#43 0x0132223e in kdemain (argc=2, argv=0x9dc9c90) at ../../../../apps/konqueror/src/konqmain.cpp:271
#44 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9dd4ddc "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#45 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#46 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#47 0x0804fe4f in main (argc=2, argv=0xbf8a41b4, envp=0xbf8a41c0) at ../../kinit/kinit.cpp:1845

Possible duplicates by query: bug 264985.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-12 18:09:10 UTC

*** This bug has been marked as a duplicate of bug 264985 ***