Bug 279977 - In the facial recognition view, when trying to remove multiple tags, tags outside of the selection are removed but not the entire selection.
Summary: In the facial recognition view, when trying to remove multiple tags, tags out...
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Recognition (show other bugs)
Version: 2.1.0
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Digikam Developers
Depends on:
Reported: 2011-08-12 15:36 UTC by obrienb8
Modified: 2017-08-02 06:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.2.0


Note You need to log in before you can comment on or make changes to this bug.
Description obrienb8 2011-08-12 15:36:23 UTC
Version:           2.1.0 (using KDE 4.6.5) 
OS:                Linux

When I select multiple images, whether using CTRL + Left click, or via highlighting that aren't tagged as images and try to remove then with the "X" option on one of the tags, it removes facial tags on some pictures outside of the selection and only removes a partial list of the images selected.

Reproducible: Always

Steps to Reproduce:
Select multiple images, remove tag.

Actual Results:  
Some of the selection is removed, pictures outside the selection are removed.

Expected Results:  
Selection to be removed.

OS: Linux (x86_64) release 2.6.40-4.fc15.x86_64
Compiler: gcc
Comment 1 Marcel Wiesweg 2011-08-13 11:58:50 UTC
Is there any pattern? Some minimum number of selected images, does the problem appear with a contiguous or a non-contiguous selection? For starters, can you reproduce when selecting one, two or three faces?
Comment 2 obrienb8 2011-08-16 00:46:25 UTC
Hello Marcel,
Thank you for your response. The only pattern I've noticed is more than one. I've tried concurrent selections of two, three, and four, and I've also tried non-contiguous selections of two, three, and four as well and tried them and it doesn't remove everything within the selection.
Comment 3 obrienb8 2011-08-18 15:18:31 UTC
I've also found the issue is the same for applying tags for faces, if you try to apply tags to multiple selections tags are applied to faces not within the selection. The correct number of tags are applied, but not to the correctly selected faces.
Comment 4 Thomas Bleher 2011-08-23 07:55:45 UTC
I can reproduce this on digikam from current git.

I just selected a whole folder containing 38 pictures. I clicked on the "-" link on one of the pictures. 19 pictures remained selected, and some other pictures that were not selected disappeared. After clicking again, 9 pictures remained selected, then 4, then 2, then 1. So the operation is applied to approximately half the images.

The bug is especially annoying because some other images are deselected and I found no way to bring them back.
Comment 5 Marcel Wiesweg 2011-09-06 19:50:01 UTC
Is the current a "normal" album, a tag or any of the searches? Does this matter? What are your settings regarding sorting and grouping of pictures?
Comment 6 obrienb8 2011-09-08 03:27:13 UTC
It is a "normal" album. I do not have any filters or searches enabled, when I do enable a filter such as "RAW Files" the issue still occurs. My current settings for sorting and grouping pictures is sorting images by name ascending, and grouping images by album. 

I have tried changing the sorting and grouping options and still get the same result, with a filter and without a filter.
Comment 7 Marcel Wiesweg 2011-09-10 20:55:00 UTC
Git commit 16d8236edd31e57410caea49bf5e4dcc6b8fbda1 by Marcel Wiesweg.
Committed on 10/09/2011 at 22:50.
Pushed by mwiesweg into branch 'master'.

Retrieve all information from the given indexes before starting to remove indexes

Removing an index and then having invalid indexes  may have introduced weird bugs.

CCBUG: 277808
CCBUG: 279977

M  +33   -15   digikam/items/digikamimageview.cpp

Comment 8 Marcel Wiesweg 2011-09-11 14:06:01 UTC
This may be related to 277808
Comment 9 obrienb8 2011-09-13 01:47:45 UTC
I tried to reproduce this issue with the latest git and it seems that the latest version fixed the issue that I was having. Thank you Marcel.
Comment 10 Marcel Wiesweg 2011-09-24 11:57:42 UTC
*** Bug 282592 has been marked as a duplicate of this bug. ***