Bug 279930 - Amarok won't play and crashes on exit
Summary: Amarok won't play and crashes on exit
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-11 23:46 UTC by Celso
Modified: 2011-08-12 00:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Celso 2011-08-11 23:46:22 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: I was using chrome and firefox. Had multiple youtube videos playing.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f76790687a0 (LWP 1604))]

Thread 3 (Thread 0x7f765a53f700 (LWP 1608)):
#0  0x00007f766dc453c4 in __pthread_mutex_lock (mutex=0x2810088) at pthread_mutex_lock.c:61
#1  0x00007f766d33f16c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f766d33f639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7675b6f446 in QEventDispatcherGlib::processEvents (this=0x24a78d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f7675b43882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7675b43abc in QEventLoop::exec (this=0x7f765a53edb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f7675a5a924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f7675b25c2f in QInotifyFileSystemWatcherEngine::run (this=0x280efb0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7675a5d175 in QThreadPrivate::start (arg=0x280efb0) at thread/qthread_unix.cpp:320
#9  0x00007f766dc42d8c in start_thread (arg=0x7f765a53f700) at pthread_create.c:304
#10 0x00007f767896e04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f764e7f4700 (LWP 1614)):
#0  0x00007f7678960f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f766d33f104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f766d33f639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7675b6f446 in QEventDispatcherGlib::processEvents (this=0x2ee4b80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f7675b43882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7675b43abc in QEventLoop::exec (this=0x7f764e7f3db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f7675a5a924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f7675b25c2f in QInotifyFileSystemWatcherEngine::run (this=0x2ee4550) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7675a5d175 in QThreadPrivate::start (arg=0x2ee4550) at thread/qthread_unix.cpp:320
#9  0x00007f766dc42d8c in start_thread (arg=0x7f764e7f4700) at pthread_create.c:304
#10 0x00007f767896e04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f76790687a0 (LWP 1604)):
[KCrash Handler]
#6  0x00007f76767a35df in QString (this=0x3740075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x3740075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f76767a8feb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f76767afd03 in KIconLoader::loadIcon (this=0x325c550, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f76767a7c99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007f7674fad4b5 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007f7678550099 in Plasma::IconWidgetPrivate::decoration (this=0x3760690, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007f7678555e51 in Plasma::IconWidget::paint (this=0x31fac00, painter=0x7fffcf64d5d0, option=0x21ab588, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007f765815e3e9 in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#15 0x00007f76754f388d in _q_paintItem (item=<value optimized out>, painter=0x7fffcf64d5d0, option=0x21ab588, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007f76754f3ba0 in _q_paintIntoCache (pix=0x7fffcf64db00, item=0x31fac10, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x21ab588, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007f76755073d8 in QGraphicsScenePrivate::drawItemHelper (this=0x21ab360, item=0x31fac10, painter=0x7fffcf64fb10, option=0x21ab588, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007f7675507faa in QGraphicsScenePrivate::draw (this=0x21ab360, item=0x31fac10, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, transformPtr=0x7fffcf64e1c0, exposedRegion=0x2e57a20, widget=0x2f9dac0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007f7675508c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x21ab360, item=0x31fac10, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, exposedRegion=0x2e57a20, widget=0x2f9dac0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007f7675507e20 in QGraphicsScenePrivate::draw (this=0x21ab360, item=0x2884ed0, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, transformPtr=0x7fffcf64e7c0, exposedRegion=0x2e57a20, widget=0x2f9dac0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007f7675508c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x21ab360, item=0x2884ed0, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, exposedRegion=0x2e57a20, widget=0x2f9dac0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007f7675507e20 in QGraphicsScenePrivate::draw (this=0x21ab360, item=0x28e6a40, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, transformPtr=0x7fffcf64edc0, exposedRegion=0x2e57a20, widget=0x2f9dac0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007f7675508c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x21ab360, item=0x28e6a40, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, exposedRegion=0x2e57a20, widget=0x2f9dac0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007f7675507e20 in QGraphicsScenePrivate::draw (this=0x21ab360, item=0x28690c0, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, transformPtr=0x7fffcf64f3c0, exposedRegion=0x2e57a20, widget=0x2f9dac0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007f7675508c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x21ab360, item=0x28690c0, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, exposedRegion=0x2e57a20, widget=0x2f9dac0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007f7675509484 in QGraphicsScenePrivate::drawItems (this=0x21ab360, painter=0x7fffcf64fb10, viewTransform=0x7fffcf64f8a0, exposedRegion=0x2e57a20, widget=0x2f9dac0) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007f76755262c2 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007f7674f52c7a in QWidget::event (this=0x30d79b0, event=0x7fffcf650430) at kernel/qwidget.cpp:8405
#29 0x00007f7675305156 in QFrame::event (this=0x30d79b0, e=0x7fffcf650430) at widgets/qframe.cpp:557
#30 0x00007f767552757b in QGraphicsView::viewportEvent (this=0x30d79b0, event=0x7fffcf650430) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007f7675b44627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2f9dac0, event=0x7fffcf650430) at kernel/qcoreapplication.cpp:846
#32 0x00007f7674f019c1 in QApplicationPrivate::notify_helper (this=0x20adbb0, receiver=0x2f9dac0, e=0x7fffcf650430) at kernel/qapplication.cpp:4458
#33 0x00007f7674f063ba in QApplication::notify (this=<value optimized out>, receiver=0x2f9dac0, e=0x7fffcf650430) at kernel/qapplication.cpp:4341
#34 0x00007f76767fc866 in KApplication::notify (this=0x209b540, receiver=0x2f9dac0, event=0x7fffcf650430) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f7675b4449c in QCoreApplication::notifyInternal (this=0x209b540, receiver=0x2f9dac0, event=0x7fffcf650430) at kernel/qcoreapplication.cpp:731
#36 0x00007f7674f4facd in sendSpontaneousEvent (this=0x2fd9b40, pdev=0x2f05398, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2ae9910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x2fd9b40, pdev=0x2f05398, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2ae9910) at kernel/qwidget.cpp:5492
#38 0x00007f7674f506e2 in QWidgetPrivate::paintSiblingsRecursive (this=0x2e57590, pdev=0x2f05398, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2ae9910) at kernel/qwidget.cpp:5699
#39 0x00007f7674f5059a in QWidgetPrivate::paintSiblingsRecursive (this=0x2e57590, pdev=0x2f05398, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2ae9910) at kernel/qwidget.cpp:5686
#40 0x00007f7674f4f80c in QWidgetPrivate::drawWidget (this=0x2e57590, pdev=0x2f05398, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x2ae9910) at kernel/qwidget.cpp:5545
#41 0x00007f76751169eb in QWidgetBackingStore::sync (this=0x2ae9910) at painting/qbackingstore.cpp:1333
#42 0x00007f7674f45f60 in QWidgetPrivate::syncBackingStore (this=0x2e57590) at kernel/qwidget.cpp:1842
#43 0x00007f7674f53194 in QWidget::event (this=0x30d79b0, event=0x325c550) at kernel/qwidget.cpp:8552
#44 0x00007f7675305156 in QFrame::event (this=0x30d79b0, e=0x325c550) at widgets/qframe.cpp:557
#45 0x00007f76753868eb in QAbstractScrollArea::event (this=0x30d79b0, e=0x325c550) at widgets/qabstractscrollarea.cpp:996
#46 0x00007f7678c5ffe6 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#47 0x00007f7674f019f4 in QApplicationPrivate::notify_helper (this=0x20adbb0, receiver=0x30d79b0, e=0x325c550) at kernel/qapplication.cpp:4462
#48 0x00007f7674f063ba in QApplication::notify (this=<value optimized out>, receiver=0x30d79b0, e=0x325c550) at kernel/qapplication.cpp:4341
#49 0x00007f76767fc866 in KApplication::notify (this=0x209b540, receiver=0x30d79b0, event=0x325c550) at ../../kdeui/kernel/kapplication.cpp:311
#50 0x00007f7675b4449c in QCoreApplication::notifyInternal (this=0x209b540, receiver=0x30d79b0, event=0x325c550) at kernel/qcoreapplication.cpp:731
#51 0x00007f7675b47c25 in sendEvent (receiver=0x30d79b0, event_type=77, data=0x2025b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x30d79b0, event_type=77, data=0x2025b60) at kernel/qcoreapplication.cpp:1372
#53 0x00007f76754fff7a in dispatchPendingUpdateRequests (this=0x21ab360) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#54 QGraphicsScenePrivate::_q_processDirtyItems (this=0x21ab360) at graphicsview/qgraphicsscene.cpp:510
#55 0x00007f767550039a in QGraphicsScene::qt_metacall (this=0x21aac70, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x312b7d0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#56 0x00007f76784a3b65 in Plasma::Corona::qt_metacall (this=0x21aac70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x312b7d0) at ./corona.moc:109
#57 0x00007f7678c54065 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#58 0x00007f7675b5849a in QObject::event (this=0x21aac70, e=<value optimized out>) at kernel/qobject.cpp:1226
#59 0x00007f767550cc7b in QGraphicsScene::event (this=0x21aac70, event=0x37624e0) at graphicsview/qgraphicsscene.cpp:3544
#60 0x00007f7674f019f4 in QApplicationPrivate::notify_helper (this=0x20adbb0, receiver=0x21aac70, e=0x37624e0) at kernel/qapplication.cpp:4462
#61 0x00007f7674f063ba in QApplication::notify (this=<value optimized out>, receiver=0x21aac70, e=0x37624e0) at kernel/qapplication.cpp:4341
#62 0x00007f76767fc866 in KApplication::notify (this=0x209b540, receiver=0x21aac70, event=0x37624e0) at ../../kdeui/kernel/kapplication.cpp:311
#63 0x00007f7675b4449c in QCoreApplication::notifyInternal (this=0x209b540, receiver=0x21aac70, event=0x37624e0) at kernel/qcoreapplication.cpp:731
#64 0x00007f7675b47c25 in sendEvent (receiver=0x0, event_type=0, data=0x2025b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2025b60) at kernel/qcoreapplication.cpp:1372
#66 0x00007f7675b6f253 in sendPostedEvents (s=0x20b09c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#67 postEventSourceDispatch (s=0x20b09c0) at kernel/qeventdispatcher_glib.cpp:277
#68 0x00007f766d33ebcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#69 0x00007f766d33f3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007f766d33f639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#71 0x00007f7675b6f3ef in QEventDispatcherGlib::processEvents (this=0x2025340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#72 0x00007f7674fab4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#73 0x00007f7675b43882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#74 0x00007f7675b43abc in QEventLoop::exec (this=0x7fffcf652590, flags=...) at kernel/qeventloop.cpp:201
#75 0x00007f7675b47ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#76 0x00007f7678c5a897 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#77 0x00007f76788a6eff in __libc_start_main (main=0x400740 <_start+256>, argc=1, ubp_av=0x7fffcf652958, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffcf652948) at libc-start.c:226
#78 0x0000000000400669 in _start ()

Possible duplicates by query: bug 279925, bug 279921, bug 279719, bug 279196, bug 278819.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-12 00:11:35 UTC

*** This bug has been marked as a duplicate of bug 258706 ***