Bug 279730 - Add PSD mimetype to Gwenview .desktop file
Summary: Add PSD mimetype to Gwenview .desktop file
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 2.9.0
Platform: OpenSUSE Linux
: NOR minor with 15 votes (vote)
Target Milestone: 2.10
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2011-08-09 12:37 UTC by Diederik van der Boor
Modified: 2013-02-24 11:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diederik van der Boor 2011-08-09 12:37:20 UTC
Version:           0.8.0 (using KDE 4.6.5) 
OS:                Linux

I just found out by accident that Gwenview is able to open PSD files.
When I click on a PSD file, Gwenview isn't opened by default however. A standard "Open with..." dialog box appears.

I actually searched the Internet in the past few days, trying to find out how to open a PSD file on Linux ..without success. Having the default mimetype association would certainly help :)

Reproducible: Always

Steps to Reproduce:
Open a PSD file


Expected Results:  
Gwenview opening the file, since it's a viewer supporting it.

OS: Linux (i686) release 2.6.39.2-3-desktop
Compiler: gcc
Comment 1 Christoph Feck 2011-08-09 14:13:33 UTC
> trying to find out how to open a PSD file on Linux

Use Krita. Its PSD loader is much better than what's provided by kimgio. That's the reason why applications don't register PSD as "supported" in the first place.
Comment 2 Diederik van der Boor 2011-09-05 13:21:59 UTC
Krita 2.3.1 is not able to open the file.
Actually gwenview only is.

Even it may not be the best, it's the only possible option at a default KDE install. I'd highly recommend allowing therefore,

It wouldn't hurt right, to have both krita and gwenview supporting it?
with gwenview being the second option?
Comment 3 Aurelien Gateau 2012-07-13 21:21:49 UTC
Bumping version number so that this report is not listed with reports against old versions of Gwenview.
Comment 4 Aurelien Gateau 2013-02-24 11:29:46 UTC
Git commit 87693fec84e227e239c80ca139c0f13f8d196ce0 by Aurélien Gâteau.
Committed on 24/02/2013 at 12:28.
Pushed by gateau into branch 'KDE/4.10'.

Add psd to supported mimetypes

FIXED-IN: 4.10.1

M  +1    -1    app/gwenview.desktop

http://commits.kde.org/gwenview/87693fec84e227e239c80ca139c0f13f8d196ce0